linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/21] eeprom: at24: driver refactoring
@ 2018-03-19  9:17 Bartosz Golaszewski
  2018-03-19  9:17 ` [PATCH 01/21] eeprom: at24: disable regmap locking Bartosz Golaszewski
                   ` (21 more replies)
  0 siblings, 22 replies; 36+ messages in thread
From: Bartosz Golaszewski @ 2018-03-19  9:17 UTC (permalink / raw)
  To: Arnd Bergmann, Greg Kroah-Hartman
  Cc: linux-i2c, linux-kernel, Bartosz Golaszewski

This series contains what I hope to be a non-controversial refactoring
of the at24 eeprom driver.

Most changes revolve around at24_probe() which became quite complicated
and hard to read.

The only functional changes are: disabling the internal locking
mechanisms of regmap (since we already take care of that in the driver)
and removing an if checking if byte_len is a power of 2 (as we do
support models for which it's not true).

All other patches affect readability and code structure.

Tested with a couple models and different both for device tree and
platform data modes.

Bartosz Golaszewski (21):
  eeprom: at24: disable regmap locking
  eeprom: at24: remove nvmem_config from at24_data
  eeprom: at24: arrange local variables
  eeprom: at24: use SPDX identifier instead of GPL boiler-plate
  eeprom: at24: remove code separators
  eeprom: at24: drop redundant variable in at24_read()
  eeprom: at24: drop redundant variable in at24_write()
  eeprom: at24: make struct initialization uniform in at24_probe()
  eeprom: at24: don't check if byte_len is a power of 2
  eeprom: at24: rename at24_get_pdata()
  eeprom: at24: rename chip to pdata in at24_probe()
  eeprom: at24: use a helper variable for dev
  eeprom: at24: readability tweak in at24_probe()
  eeprom: at24: provide and use at24_base_client_dev()
  eeprom: at24: switch to using probe_new() from the i2c framework
  eeprom: at24: move platform data processing into a separate routine
  eeprom: at24: remove at24_platform_data from at24_data
  eeprom: at24: refactor at24_probe()
  eeprom: at24: tweak newlines
  eeprom: at24: fix a line break
  eeprom: at24: simplify the i2c functionality checking

 drivers/misc/eeprom/at24.c | 293 ++++++++++++++++++++++++---------------------
 1 file changed, 156 insertions(+), 137 deletions(-)

-- 
2.16.1

^ permalink raw reply	[flat|nested] 36+ messages in thread

end of thread, other threads:[~2018-03-23 16:37 UTC | newest]

Thread overview: 36+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-03-19  9:17 [PATCH 00/21] eeprom: at24: driver refactoring Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 01/21] eeprom: at24: disable regmap locking Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 02/21] eeprom: at24: remove nvmem_config from at24_data Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 03/21] eeprom: at24: arrange local variables Bartosz Golaszewski
2018-03-23 15:21   ` Greg Kroah-Hartman
2018-03-23 16:06     ` Bartosz Golaszewski
2018-03-23 16:37       ` Greg Kroah-Hartman
2018-03-19  9:17 ` [PATCH 04/21] eeprom: at24: use SPDX identifier instead of GPL boiler-plate Bartosz Golaszewski
2018-03-19 11:03   ` Peter Rosin
2018-03-19 12:12     ` Bartosz Golaszewski
2018-03-19 12:51       ` Peter Rosin
2018-03-19 12:56         ` Bartosz Golaszewski
2018-03-19 15:38           ` Greg Kroah-Hartman
2018-03-19 15:43             ` Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 05/21] eeprom: at24: remove code separators Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 06/21] eeprom: at24: drop redundant variable in at24_read() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 07/21] eeprom: at24: drop redundant variable in at24_write() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 08/21] eeprom: at24: make struct initialization uniform in at24_probe() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 09/21] eeprom: at24: don't check if byte_len is a power of 2 Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 10/21] eeprom: at24: rename at24_get_pdata() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 11/21] eeprom: at24: rename chip to pdata in at24_probe() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 12/21] eeprom: at24: use a helper variable for dev Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 13/21] eeprom: at24: readability tweak in at24_probe() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 14/21] eeprom: at24: provide and use at24_base_client_dev() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 15/21] eeprom: at24: switch to using probe_new() from the i2c framework Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 16/21] eeprom: at24: move platform data processing into a separate routine Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 17/21] eeprom: at24: remove at24_platform_data from at24_data Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 18/21] eeprom: at24: refactor at24_probe() Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 19/21] eeprom: at24: tweak newlines Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 20/21] eeprom: at24: fix a line break Bartosz Golaszewski
2018-03-19  9:17 ` [PATCH 21/21] eeprom: at24: simplify the i2c functionality checking Bartosz Golaszewski
2018-03-19 14:43 ` [PATCH 00/21] eeprom: at24: driver refactoring Andy Shevchenko
2018-03-19 15:21   ` Bartosz Golaszewski
2018-03-21 14:52     ` Andy Shevchenko
2018-03-23 15:26       ` Greg Kroah-Hartman
2018-03-23 16:13         ` Bartosz Golaszewski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).