linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v4 0/8] ARM: davinci: complete the conversion to using the reset framework
@ 2018-03-23 13:04 Bartosz Golaszewski
  2018-03-23 13:04 ` [PATCH v4 1/8] reset: modify the way reset lookup works for board files Bartosz Golaszewski
                   ` (8 more replies)
  0 siblings, 9 replies; 25+ messages in thread
From: Bartosz Golaszewski @ 2018-03-23 13:04 UTC (permalink / raw)
  To: Sekhar Nori, Kevin Hilman, Rob Herring, Mark Rutland,
	Russell King, David Lechner, Michael Turquette, Stephen Boyd,
	Ohad Ben-Cohen, Bjorn Andersson, Philipp Zabel
  Cc: linux-arm-kernel, devicetree, linux-kernel, linux-clk,
	linux-remoteproc, Bartosz Golaszewski

From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

This series converts the only user of the handcoded, mach-specific reset
routines in the davinci platform to using the reset framework.

Patch 1 modifies the way lookup entries are registered with the reset
framework.

Patches 2-4 add necessary lookups/DT-properties.

Patches 5-7 convert the davinci-rproc driver to the reset framework.

Patch 8 removes now dead code.

Philipp: it turned out that it's indeed better to use the reset
controller's device name for the entry lookup.

Tested both in DT and legacy modes by booting the examples from
ti-ipc-rtos recipe in meta-ti.

This series applies on top of David Lechner's common-clk-v9 branch[1]
with Philipp Zabel's reset/next branch[2] pulled in.

It can be found in my github tree as well[3].

[1] git://github.com/dlech/ev3dev-kernel.git common-clk-v9
[2] git://git.pengutronix.de/git/pza/linux reset/next
[3] git@github.com:brgl/linux.git topic/davinci-reset

v1 -> v2:
- fixed the device tree patches the descriptions of which were mixed up
- return -EPROBE_DEFER from davinci-rproc's probe() if we can't get the
  reset provider, since it's possible that the lookup table was not yet
  registered
- made the local variable naming consistent in the davinci-rproc driver
- fixed a typo in PATCH 5/8

v2 -> v3:
- modify PATCH 1/8: drop the provider argument from the function adding
  lookup entries and instead pass the provider name to the RESET_LOOKUP
  macro, return -EPROBE_DEFER if we locate a correct lookup entry but
  cannot get the corresponding reset controller
- modify the reset lookup entry in psc-da850
- don't manually return -EPROBE_DEFER from davinci-rproc, instead don't
  emit an error message if devm_reset_control_get_exclusive() returns
  this error code

v3 -> v4:
- make index the second parameter in RESET_LOOKUP() (right after the
  provider name)

Bartosz Golaszewski (8):
  reset: modify the way reset lookup works for board files
  ARM: davinci: dts: make psc0 a reset provider
  ARM: davinci: dts: add a reset control to the dsp node
  clk: davinci: add a reset lookup table for psc0
  remoteproc: da8xx: add the missing retval check for clk_enable()
  remoteproc: da8xx: prepare and unprepare the clock where needed
  remoteproc: da8xx: use the reset framework
  clk: davinci: kill davinci_clk_reset_assert/deassert()

 arch/arm/boot/dts/da850.dtsi               |  2 ++
 arch/arm/mach-davinci/include/mach/clock.h | 21 ---------------
 drivers/clk/davinci/psc-da850.c            |  7 +++++
 drivers/clk/davinci/psc.c                  | 19 +-------------
 drivers/remoteproc/da8xx_remoteproc.c      | 42 +++++++++++++++++++++++++-----
 drivers/reset/core.c                       | 38 ++++++++++++++++++++++-----
 include/linux/reset-controller.h           | 14 +++++-----
 7 files changed, 84 insertions(+), 59 deletions(-)
 delete mode 100644 arch/arm/mach-davinci/include/mach/clock.h

-- 
2.16.1

^ permalink raw reply	[flat|nested] 25+ messages in thread

end of thread, other threads:[~2018-03-28 22:45 UTC | newest]

Thread overview: 25+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-03-23 13:04 [PATCH v4 0/8] ARM: davinci: complete the conversion to using the reset framework Bartosz Golaszewski
2018-03-23 13:04 ` [PATCH v4 1/8] reset: modify the way reset lookup works for board files Bartosz Golaszewski
2018-03-23 13:43   ` Philipp Zabel
2018-03-23 13:46     ` Bartosz Golaszewski
2018-03-23 13:04 ` [PATCH v4 2/8] ARM: davinci: dts: make psc0 a reset provider Bartosz Golaszewski
2018-03-23 13:04 ` [PATCH v4 3/8] ARM: davinci: dts: add a reset control to the dsp node Bartosz Golaszewski
2018-03-23 13:04 ` [PATCH v4 4/8] clk: davinci: add a reset lookup table for psc0 Bartosz Golaszewski
2018-03-23 13:04 ` [PATCH v4 5/8] remoteproc: da8xx: add the missing retval check for clk_enable() Bartosz Golaszewski
2018-03-26 21:15   ` Suman Anna
2018-03-23 13:04 ` [PATCH v4 6/8] remoteproc: da8xx: prepare and unprepare the clock where needed Bartosz Golaszewski
2018-03-26 21:19   ` Suman Anna
2018-03-23 13:04 ` [PATCH v4 7/8] remoteproc: da8xx: use the reset framework Bartosz Golaszewski
2018-03-26 21:28   ` Suman Anna
2018-03-23 13:04 ` [PATCH v4 8/8] clk: davinci: kill davinci_clk_reset_assert/deassert() Bartosz Golaszewski
2018-03-23 16:49 ` [PATCH v4 0/8] ARM: davinci: complete the conversion to using the reset framework Stephen Boyd
2018-03-23 16:55   ` Bartosz Golaszewski
2018-03-23 17:08     ` Stephen Boyd
2018-03-23 17:16       ` Bartosz Golaszewski
2018-03-24  0:30         ` Suman Anna
2018-03-27  0:42           ` Suman Anna
2018-03-27  5:24             ` Sekhar Nori
2018-03-28 22:44               ` Suman Anna
2018-03-27  6:09         ` Sekhar Nori
2018-03-27  9:23           ` Philipp Zabel
2018-03-27  9:29           ` Bartosz Golaszewski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).