linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: Dominik Brodowski <linux@dominikbrodowski.net>
Cc: linux-kernel@vger.kernel.org, Al Viro <viro@zeniv.linux.org.uk>,
	Andi Kleen <ak@linux.intel.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Andy Lutomirski <luto@kernel.org>,
	Brian Gerst <brgerst@gmail.com>,
	Denys Vlasenko <dvlasenk@redhat.com>,
	"H. Peter Anvin" <hpa@zytor.com>, Ingo Molnar <mingo@redhat.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	x86@kernel.org, Maninder Singh <maninder1.s@samsung.com>,
	Arnd Bergmann <arnd@arndb.de>,
	linux-arch <linux-arch@vger.kernel.org>
Subject: Re: [PATCH 0/3] syscalls: clean up stub naming convention
Date: Sun, 8 Apr 2018 10:35:50 +0200	[thread overview]
Message-ID: <20180408083550.32d65b6ra6yca5p7@gmail.com> (raw)
In-Reply-To: <20180407074651.29014-1-linux@dominikbrodowski.net>


* Dominik Brodowski <linux@dominikbrodowski.net> wrote:

> In short (0xffffffff prefix removed, re-ordered):
> 
> 810f0af0 t            kernel_waitid	# common (32/64) kernel helper
> 
> <inline>            __in_sys_waitid	# inlined helper doing actual work
> 810f0be0 t          __do_sys_waitid	# C func calling inlined helper
> 
> <inline>     __in_compat_sys_waitid	# inlined helper doing actual work
> 810f0d80 t   __do_compat_sys_waitid	# compat C func calling inlined helper
> 
> 810f2080 T         __x64_sys_waitid	# x64 64-bit-ptregs -> C stub
> 810f20b0 T        __ia32_sys_waitid	# ia32 32-bit-ptregs -> C stub [unused]
> 810f2470 T __ia32_compat_sys_waitid	# ia32 32-bit-ptregs -> compat C stub
> 810f2490 T  __x32_compat_sys_waitid	# x32 64-bit-ptregs -> compat C stub

Ok, looks pretty clean and nice to me all around, and looking at the highest level 
syscall tables the actual calling convention and address encoding is now a _lot_ 
more obvious at first sight as well.

The "in" part is a tiny bit confusing because it reads like a preposition:
"are we in sys_waitid?".

But I have no better idea, other than we could perhaps use more underscores to 
signal the inline helper, instead of the 'in_' prefix:

> 810f0af0 t            kernel_waitid	# common (32/64) kernel helper
> 
> <inline>            _____sys_waitid	# inlined helper doing actual work
> 810f0be0 t          __do_sys_waitid	# C func calling inlined helper
> 
> <inline>     _____compat_sys_waitid	# inlined helper doing actual work
> 810f0d80 t   __do_compat_sys_waitid	# compat C func calling inlined helper
> 
> 810f2080 T         __x64_sys_waitid	# x64 64-bit-ptregs -> C stub
> 810f20b0 T        __ia32_sys_waitid	# ia32 32-bit-ptregs -> C stub [unused]
> 810f2470 T __ia32_compat_sys_waitid	# ia32 32-bit-ptregs -> compat C stub
> 810f2490 T  __x32_compat_sys_waitid	# x32 64-bit-ptregs -> compat C stub

?

There are some other variants as well, here's the list of all the options I could 
think of:

  - _____sys_waitid()      # ridiculous number of underscores?
  - __sys_waitid()         # too generic sounding?
  - __inline_sys_waitid()  # too long?
  - __il_sys_waitid()      # reminds me of the IL country code ;-)
  - __in_sys_waitid()      # easy to read as 'are we in syscall?'

None is super convinging - but maybe __inline_sys_waitid is the most natural one.

[ Note, whichever we pick (if we pick a new one), there no need to resend, I can 
  edit the patches in place if you agree. ]

One more fundamental question: why do we have the __do_sys_waitid() and 
__inline_sys_waitid() distinction - aren't the function call signatures the same 
with no conversion done?

I.e. couldn't we just do a single, static __do_sys_waitid(), where the compiler 
would decide to what extent inlining is justified? This would allow the compiler 
to inline all the intermediate code into the stubs themselves.

Or is this a side effect of the error injection feature, which needs to add extra 
logic at this intermediate level? That too should be able to use the 
__do_sys_waitid() variant though.

> The kbuild test robot barked at an alleged +20038 bytes kernel size regression
> for i386-tinyconfig due to the first patch of this series. That seems to be a
> false positive, as it likely doesn't take into account the change to
> scripts/bloat-o-meter. Moreover, I could not reproduce such a size regression
> on local i386 builds.

Ok, I'll ignore that.

Is UML unaffected by these renames?

Thanks,

	Ingo

  parent reply	other threads:[~2018-04-08  8:35 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-07  7:46 [PATCH 0/3] syscalls: clean up stub naming convention Dominik Brodowski
2018-04-07  7:46 ` [PATCH 1/3] syscalls: clean up syscall " Dominik Brodowski
2018-04-07  7:46 ` [PATCH 2/3] syscalls: clean up compat " Dominik Brodowski
2018-04-07  7:46 ` [PATCH 3/3] syscalls: rename struct pt_regs-based sys_*() to __x64_sys_*() Dominik Brodowski
2018-04-08  8:35 ` Ingo Molnar [this message]
2018-04-08  9:15   ` [PATCH 0/3] syscalls: clean up stub naming convention Dominik Brodowski
2018-04-08 19:59     ` Dominik Brodowski
2018-04-08 20:06       ` [PATCH 4/3] syscalls/x86: adapt syscall_wrapper.h to the new syscall " Dominik Brodowski
2018-04-09  6:49       ` [PATCH 0/3] syscalls: clean up " Ingo Molnar
2018-04-09  6:54         ` Dominik Brodowski
2018-04-09  6:39     ` Ingo Molnar
2018-04-09 19:13       ` Linus Torvalds
2018-04-09  6:45     ` Ingo Molnar
2018-04-09  6:53       ` Dominik Brodowski
2018-04-09  7:06       ` Ingo Molnar
2018-04-09  7:08         ` Dominik Brodowski
2018-04-09  7:34           ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180408083550.32d65b6ra6yca5p7@gmail.com \
    --to=mingo@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=brgerst@gmail.com \
    --cc=dvlasenk@redhat.com \
    --cc=hpa@zytor.com \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@dominikbrodowski.net \
    --cc=luto@kernel.org \
    --cc=maninder1.s@samsung.com \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=viro@zeniv.linux.org.uk \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).