linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: Dominik Brodowski <linux@dominikbrodowski.net>
Cc: linux-kernel@vger.kernel.org, Al Viro <viro@zeniv.linux.org.uk>,
	Andi Kleen <ak@linux.intel.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Andy Lutomirski <luto@kernel.org>,
	Brian Gerst <brgerst@gmail.com>,
	Denys Vlasenko <dvlasenk@redhat.com>,
	"H. Peter Anvin" <hpa@zytor.com>, Ingo Molnar <mingo@redhat.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	x86@kernel.org, Maninder Singh <maninder1.s@samsung.com>,
	Arnd Bergmann <arnd@arndb.de>,
	linux-arch <linux-arch@vger.kernel.org>
Subject: Re: [PATCH 0/3] syscalls: clean up stub naming convention
Date: Mon, 9 Apr 2018 08:39:21 +0200	[thread overview]
Message-ID: <20180409063921.wkrqbnv4lzxb3isg@gmail.com> (raw)
In-Reply-To: <20180408091536.GA10120@light.dominikbrodowski.net>

* Dominik Brodowski <linux@dominikbrodowski.net> wrote:

> > One more fundamental question: why do we have the __do_sys_waitid() and 
> > __inline_sys_waitid() distinction - aren't the function call signatures the same 
> > with no conversion done?
> > 
> > I.e. couldn't we just do a single, static __do_sys_waitid(), where the compiler 
> > would decide to what extent inlining is justified? This would allow the compiler 
> > to inline all the intermediate code into the stubs themselves.
> > 
> > Or is this a side effect of the error injection feature, which needs to add extra 
> > logic at this intermediate level? That too should be able to use the 
> > __do_sys_waitid() variant though.
> 
> Error injection is unrelated. It seems to be for three reasons, if I read
> the code (include/linux/syscalls.h) correctly:
> 
> 	asmlinkage long __do_sys##name(__MAP(x,__SC_LONG,__VA_ARGS__))
> 
> 1)  This takes arguments of type long (to protect against CVE-2009-0029);
>     see https://lwn.net/Articles/604287/ : "Digging into the history of
>     this, it turns out that the long version ensures that 32-bit values
>     are correctly sign-extended for some 64-bit kernel platforms,
>     preventing a historical vulnerability."
> 
> 	{
> 		long ret = __in_sys##name(__MAP(x,__SC_CAST,__VA_ARGS__));
> 		__MAP(x,__SC_TEST,__VA_ARGS__);

I see - so it's _not_ the same function call signature, but a wrapper with a 
sign-extended version, which is fair and useful. So on architectures where this 
matters there's type conversion and active code generated.

Thanks,

	Ingo

  parent reply	other threads:[~2018-04-09  6:39 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-07  7:46 [PATCH 0/3] syscalls: clean up stub naming convention Dominik Brodowski
2018-04-07  7:46 ` [PATCH 1/3] syscalls: clean up syscall " Dominik Brodowski
2018-04-07  7:46 ` [PATCH 2/3] syscalls: clean up compat " Dominik Brodowski
2018-04-07  7:46 ` [PATCH 3/3] syscalls: rename struct pt_regs-based sys_*() to __x64_sys_*() Dominik Brodowski
2018-04-08  8:35 ` [PATCH 0/3] syscalls: clean up stub naming convention Ingo Molnar
2018-04-08  9:15   ` Dominik Brodowski
2018-04-08 19:59     ` Dominik Brodowski
2018-04-08 20:06       ` [PATCH 4/3] syscalls/x86: adapt syscall_wrapper.h to the new syscall " Dominik Brodowski
2018-04-09  6:49       ` [PATCH 0/3] syscalls: clean up " Ingo Molnar
2018-04-09  6:54         ` Dominik Brodowski
2018-04-09  6:39     ` Ingo Molnar [this message]
2018-04-09 19:13       ` Linus Torvalds
2018-04-09  6:45     ` Ingo Molnar
2018-04-09  6:53       ` Dominik Brodowski
2018-04-09  7:06       ` Ingo Molnar
2018-04-09  7:08         ` Dominik Brodowski
2018-04-09  7:34           ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180409063921.wkrqbnv4lzxb3isg@gmail.com \
    --to=mingo@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=brgerst@gmail.com \
    --cc=dvlasenk@redhat.com \
    --cc=hpa@zytor.com \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@dominikbrodowski.net \
    --cc=luto@kernel.org \
    --cc=maninder1.s@samsung.com \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=viro@zeniv.linux.org.uk \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).