linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] xfs_attr_leaf: use swap macro in xfs_attr3_leaf_rebalance
@ 2018-07-09 16:12 Gustavo A. R. Silva
  2018-07-11 17:44 ` Darrick J. Wong
  0 siblings, 1 reply; 2+ messages in thread
From: Gustavo A. R. Silva @ 2018-07-09 16:12 UTC (permalink / raw)
  To: Darrick J. Wong; +Cc: linux-xfs, linux-kernel, Gustavo A. R. Silva

Make use of the swap macro and remove some unnecessary variables.
This makes the code easier to read and maintain. Also, reduces the
stack usage.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 fs/xfs/libxfs/xfs_attr_leaf.c | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)

diff --git a/fs/xfs/libxfs/xfs_attr_leaf.c b/fs/xfs/libxfs/xfs_attr_leaf.c
index 76e9004..ec0bf96 100644
--- a/fs/xfs/libxfs/xfs_attr_leaf.c
+++ b/fs/xfs/libxfs/xfs_attr_leaf.c
@@ -1570,17 +1570,10 @@ xfs_attr3_leaf_rebalance(
 	 */
 	swap = 0;
 	if (xfs_attr3_leaf_order(blk1->bp, &ichdr1, blk2->bp, &ichdr2)) {
-		struct xfs_da_state_blk	*tmp_blk;
-		struct xfs_attr3_icleaf_hdr tmp_ichdr;
+		swap(blk1, blk2);
 
-		tmp_blk = blk1;
-		blk1 = blk2;
-		blk2 = tmp_blk;
-
-		/* struct copies to swap them rather than reconverting */
-		tmp_ichdr = ichdr1;
-		ichdr1 = ichdr2;
-		ichdr2 = tmp_ichdr;
+		/* swap structures rather than reconverting them */
+		swap(ichdr1, ichdr2);
 
 		leaf1 = blk1->bp->b_addr;
 		leaf2 = blk2->bp->b_addr;
-- 
2.7.4


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] xfs_attr_leaf: use swap macro in xfs_attr3_leaf_rebalance
  2018-07-09 16:12 [PATCH] xfs_attr_leaf: use swap macro in xfs_attr3_leaf_rebalance Gustavo A. R. Silva
@ 2018-07-11 17:44 ` Darrick J. Wong
  0 siblings, 0 replies; 2+ messages in thread
From: Darrick J. Wong @ 2018-07-11 17:44 UTC (permalink / raw)
  To: Gustavo A. R. Silva; +Cc: linux-xfs, linux-kernel

On Mon, Jul 09, 2018 at 11:12:47AM -0500, Gustavo A. R. Silva wrote:
> Make use of the swap macro and remove some unnecessary variables.
> This makes the code easier to read and maintain. Also, reduces the
> stack usage.
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>

Looks ok, will test...
Reviewed-by: Darrick J. Wong <darrick.wong@oracle.com>

--D

> ---
>  fs/xfs/libxfs/xfs_attr_leaf.c | 13 +++----------
>  1 file changed, 3 insertions(+), 10 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_attr_leaf.c b/fs/xfs/libxfs/xfs_attr_leaf.c
> index 76e9004..ec0bf96 100644
> --- a/fs/xfs/libxfs/xfs_attr_leaf.c
> +++ b/fs/xfs/libxfs/xfs_attr_leaf.c
> @@ -1570,17 +1570,10 @@ xfs_attr3_leaf_rebalance(
>  	 */
>  	swap = 0;
>  	if (xfs_attr3_leaf_order(blk1->bp, &ichdr1, blk2->bp, &ichdr2)) {
> -		struct xfs_da_state_blk	*tmp_blk;
> -		struct xfs_attr3_icleaf_hdr tmp_ichdr;
> +		swap(blk1, blk2);
>  
> -		tmp_blk = blk1;
> -		blk1 = blk2;
> -		blk2 = tmp_blk;
> -
> -		/* struct copies to swap them rather than reconverting */
> -		tmp_ichdr = ichdr1;
> -		ichdr1 = ichdr2;
> -		ichdr2 = tmp_ichdr;
> +		/* swap structures rather than reconverting them */
> +		swap(ichdr1, ichdr2);
>  
>  		leaf1 = blk1->bp->b_addr;
>  		leaf2 = blk2->bp->b_addr;
> -- 
> 2.7.4
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2018-07-11 17:44 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-09 16:12 [PATCH] xfs_attr_leaf: use swap macro in xfs_attr3_leaf_rebalance Gustavo A. R. Silva
2018-07-11 17:44 ` Darrick J. Wong

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).