linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/16] staging:rtl8192u: Proxy Structures?
@ 2018-07-26 19:24 John Whitmore
  2018-07-26 19:24 ` [PATCH 01/16] staging:rtl8192u: Rename SwChnlCmd - Style John Whitmore
                   ` (15 more replies)
  0 siblings, 16 replies; 17+ messages in thread
From: John Whitmore @ 2018-07-26 19:24 UTC (permalink / raw)
  To: linux-kernel; +Cc: devel, gregkh, John Whitmore

This series of patches contains coding style changes.

There is one type of change, proxy structures, which whilst not flagged
by checkpatch, as an issue, I have changed. I can't see the purpose of
defining a structure, in this case arrays, and then using a #define to
name the structure something else.

This may well be a pattern which I'm not familiar with, in which case
the patches can be rejected, and I'll have learned something, but I thought
I'd better explicitly mention it, as I'm assuming that there is not actual
point to the practice.

Apart from that all the rest are simple coding style changes.

John Whitmore (16):
  staging:rtl8192u: Rename SwChnlCmd - Style
  staging:rtl8192u: Rename CmdID - Style
  staging:rtl8192u: Rename Para1 > para_1 - Style
  staging:rtl8192u: Rename Para2 to para_2 - style
  staging:rtl8192u: Rename msDelay to ms_delay - Style
  staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG - Style
  staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray - Style
  staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioA_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioB_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioC_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioD_Array - Style
  staging:rtl8192u: Rename HW90_BLOCK_E - Style
  staging:rtl8192u: Rename RF90_RADIO_PATH_E - Style
  staging:rtl8192u: Remove repeated definitions - Style
  staging:rtl8192u: Rename eRFPath - Style

 drivers/staging/rtl8192u/r8190_rtl8256.c |  42 ++---
 drivers/staging/rtl8192u/r8192U_core.c   |   4 +-
 drivers/staging/rtl8192u/r819xU_phy.c    | 230 +++++++++++------------
 drivers/staging/rtl8192u/r819xU_phy.h    |  42 ++---
 4 files changed, 147 insertions(+), 171 deletions(-)

-- 
2.18.0


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2018-07-26 19:26 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-26 19:24 [PATCH 00/16] staging:rtl8192u: Proxy Structures? John Whitmore
2018-07-26 19:24 ` [PATCH 01/16] staging:rtl8192u: Rename SwChnlCmd - Style John Whitmore
2018-07-26 19:24 ` [PATCH 02/16] staging:rtl8192u: Rename CmdID " John Whitmore
2018-07-26 19:24 ` [PATCH 03/16] staging:rtl8192u: Rename Para1 > para_1 " John Whitmore
2018-07-26 19:24 ` [PATCH 04/16] staging:rtl8192u: Rename Para2 to para_2 - style John Whitmore
2018-07-26 19:24 ` [PATCH 05/16] staging:rtl8192u: Rename msDelay to ms_delay - Style John Whitmore
2018-07-26 19:24 ` [PATCH 06/16] staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG " John Whitmore
2018-07-26 19:24 ` [PATCH 07/16] staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray " John Whitmore
2018-07-26 19:24 ` [PATCH 08/16] staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 09/16] staging:rtl8192u: Remove proxy rtl819XRadioA_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 10/16] staging:rtl8192u: Remove proxy rtl819XRadioB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 11/16] staging:rtl8192u: Remove proxy rtl819XRadioC_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 12/16] staging:rtl8192u: Remove proxy rtl819XRadioD_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 13/16] staging:rtl8192u: Rename HW90_BLOCK_E " John Whitmore
2018-07-26 19:24 ` [PATCH 14/16] staging:rtl8192u: Rename RF90_RADIO_PATH_E " John Whitmore
2018-07-26 19:24 ` [PATCH 15/16] staging:rtl8192u: Remove repeated definitions " John Whitmore
2018-07-26 19:24 ` [PATCH 16/16] staging:rtl8192u: Rename eRFPath " John Whitmore

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).