linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] drm/sun4i: tcon-top: Use struct_size() in devm_kzalloc()
@ 2018-08-24  1:05 Gustavo A. R. Silva
  2018-08-24  2:56 ` Kees Cook
  0 siblings, 1 reply; 3+ messages in thread
From: Gustavo A. R. Silva @ 2018-08-24  1:05 UTC (permalink / raw)
  To: Maxime Ripard, David Airlie, Chen-Yu Tsai
  Cc: dri-devel, linux-arm-kernel, linux-kernel, Kees Cook,
	Gustavo A. R. Silva

One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
	int stuff;
        void *entry[];
};

instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 drivers/gpu/drm/sun4i/sun8i_tcon_top.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/sun4i/sun8i_tcon_top.c b/drivers/gpu/drm/sun4i/sun8i_tcon_top.c
index 55fe398..3040a79 100644
--- a/drivers/gpu/drm/sun4i/sun8i_tcon_top.c
+++ b/drivers/gpu/drm/sun4i/sun8i_tcon_top.c
@@ -129,8 +129,7 @@ static int sun8i_tcon_top_bind(struct device *dev, struct device *master,
 	if (!tcon_top)
 		return -ENOMEM;
 
-	clk_data = devm_kzalloc(dev, sizeof(*clk_data) +
-				sizeof(*clk_data->hws) * CLK_NUM,
+	clk_data = devm_kzalloc(dev, struct_size(clk_data, hws, CLK_NUM),
 				GFP_KERNEL);
 	if (!clk_data)
 		return -ENOMEM;
-- 
2.7.4


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] drm/sun4i: tcon-top: Use struct_size() in devm_kzalloc()
  2018-08-24  1:05 [PATCH] drm/sun4i: tcon-top: Use struct_size() in devm_kzalloc() Gustavo A. R. Silva
@ 2018-08-24  2:56 ` Kees Cook
  2018-08-24 14:32   ` Maxime Ripard
  0 siblings, 1 reply; 3+ messages in thread
From: Kees Cook @ 2018-08-24  2:56 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Maxime Ripard, David Airlie, Chen-Yu Tsai,
	Maling list - DRI developers, linux-arm-kernel, LKML

On Thu, Aug 23, 2018 at 6:05 PM, Gustavo A. R. Silva
<gustavo@embeddedor.com> wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
>         int stuff;
>         void *entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
>
> This issue was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>

Reviewed-by: Kees Cook <keescook@chromium.org>

-Kees

> ---
>  drivers/gpu/drm/sun4i/sun8i_tcon_top.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/sun4i/sun8i_tcon_top.c b/drivers/gpu/drm/sun4i/sun8i_tcon_top.c
> index 55fe398..3040a79 100644
> --- a/drivers/gpu/drm/sun4i/sun8i_tcon_top.c
> +++ b/drivers/gpu/drm/sun4i/sun8i_tcon_top.c
> @@ -129,8 +129,7 @@ static int sun8i_tcon_top_bind(struct device *dev, struct device *master,
>         if (!tcon_top)
>                 return -ENOMEM;
>
> -       clk_data = devm_kzalloc(dev, sizeof(*clk_data) +
> -                               sizeof(*clk_data->hws) * CLK_NUM,
> +       clk_data = devm_kzalloc(dev, struct_size(clk_data, hws, CLK_NUM),
>                                 GFP_KERNEL);
>         if (!clk_data)
>                 return -ENOMEM;
> --
> 2.7.4
>



-- 
Kees Cook
Pixel Security

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] drm/sun4i: tcon-top: Use struct_size() in devm_kzalloc()
  2018-08-24  2:56 ` Kees Cook
@ 2018-08-24 14:32   ` Maxime Ripard
  0 siblings, 0 replies; 3+ messages in thread
From: Maxime Ripard @ 2018-08-24 14:32 UTC (permalink / raw)
  To: Kees Cook
  Cc: Gustavo A. R. Silva, David Airlie, Chen-Yu Tsai,
	Maling list - DRI developers, linux-arm-kernel, LKML

[-- Attachment #1: Type: text/plain, Size: 1076 bytes --]

On Thu, Aug 23, 2018 at 07:56:12PM -0700, Kees Cook wrote:
> On Thu, Aug 23, 2018 at 6:05 PM, Gustavo A. R. Silva
> <gustavo@embeddedor.com> wrote:
> > One of the more common cases of allocation size calculations is finding
> > the size of a structure that has a zero-sized array at the end, along
> > with memory for some number of elements for that array. For example:
> >
> > struct foo {
> >         int stuff;
> >         void *entry[];
> > };
> >
> > instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
> >
> > Instead of leaving these open-coded and prone to type mistakes, we can
> > now use the new struct_size() helper:
> >
> > instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
> >
> > This issue was detected with the help of Coccinelle.
> >
> > Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
> 
> Reviewed-by: Kees Cook <keescook@chromium.org>

Applied, thanks!
Maxime

-- 
Maxime Ripard, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2018-08-24 14:32 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-08-24  1:05 [PATCH] drm/sun4i: tcon-top: Use struct_size() in devm_kzalloc() Gustavo A. R. Silva
2018-08-24  2:56 ` Kees Cook
2018-08-24 14:32   ` Maxime Ripard

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).