linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ASoC: soc-utils: Rename dummy_dma_ops to snd_dummy_ops
@ 2018-09-25  0:47 Matthias Kaehlcke
  2018-09-25  8:36 ` Andy Shevchenko
  0 siblings, 1 reply; 3+ messages in thread
From: Matthias Kaehlcke @ 2018-09-25  0:47 UTC (permalink / raw)
  To: Liam Girdwood, Mark Brown, Jaroslav Kysela, Takashi Iwai
  Cc: alsa-devel, linux-kernel, Matthias Kaehlcke

The symbols 'dummy_dma_ops' is declared with different data types by
sound/soc/soc-utils.c and arch/arm64/include/asm/dma-mapping.h. This
leads to conflicts when soc-utils.c (indirectly) includes dma-mapping.h:

sound/soc/soc-utils.c:282:33: error: conflicting types for 'dummy_dma_ops'
  static const struct snd_pcm_ops dummy_dma_ops = {
                                  ^
...
arch/arm64/include/asm/dma-mapping.h:27:33: note: previous declaration of 'dummy_dma_ops' was here
  extern const struct dma_map_ops dummy_dma_ops;
                                  ^

Rename the symbol in soc-utils.c to 'snd_dummy_ops' to avoid the conflict.

Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
---
 sound/soc/soc-utils.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/sound/soc/soc-utils.c b/sound/soc/soc-utils.c
index e0c93496c0cd..ab44133bc0bf 100644
--- a/sound/soc/soc-utils.c
+++ b/sound/soc/soc-utils.c
@@ -273,13 +273,13 @@ static int dummy_dma_open(struct snd_pcm_substream *substream)
 	return 0;
 }
 
-static const struct snd_pcm_ops dummy_dma_ops = {
+static const struct snd_pcm_ops snd_dummy_ops = {
 	.open		= dummy_dma_open,
 	.ioctl		= snd_pcm_lib_ioctl,
 };
 
 static const struct snd_soc_component_driver dummy_platform = {
-	.ops = &dummy_dma_ops,
+	.ops = &snd_dummy_ops,
 };
 
 static const struct snd_soc_component_driver dummy_codec = {
-- 
2.19.0.605.g01d371f741-goog


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] ASoC: soc-utils: Rename dummy_dma_ops to snd_dummy_ops
  2018-09-25  0:47 [PATCH] ASoC: soc-utils: Rename dummy_dma_ops to snd_dummy_ops Matthias Kaehlcke
@ 2018-09-25  8:36 ` Andy Shevchenko
  2018-09-25 16:49   ` Mark Brown
  0 siblings, 1 reply; 3+ messages in thread
From: Andy Shevchenko @ 2018-09-25  8:36 UTC (permalink / raw)
  To: Matthias Kaehlcke
  Cc: Liam Girdwood, Mark Brown, Jaroslav Kysela, Takashi Iwai,
	ALSA Development Mailing List, Linux Kernel Mailing List

On Tue, Sep 25, 2018 at 3:48 AM Matthias Kaehlcke <mka@chromium.org> wrote:
>
> The symbols 'dummy_dma_ops' is declared with different data types by
> sound/soc/soc-utils.c and arch/arm64/include/asm/dma-mapping.h. This
> leads to conflicts when soc-utils.c (indirectly) includes dma-mapping.h:
>
> sound/soc/soc-utils.c:282:33: error: conflicting types for 'dummy_dma_ops'
>   static const struct snd_pcm_ops dummy_dma_ops = {
>                                   ^
> ...
> arch/arm64/include/asm/dma-mapping.h:27:33: note: previous declaration of 'dummy_dma_ops' was here
>   extern const struct dma_map_ops dummy_dma_ops;
>                                   ^
>
> Rename the symbol in soc-utils.c to 'snd_dummy_ops' to avoid the conflict.

But it misses 'dma' part as I can see they are still DMA related.

snd_dummy_dma_ops ?

>
> Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
> ---
>  sound/soc/soc-utils.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/sound/soc/soc-utils.c b/sound/soc/soc-utils.c
> index e0c93496c0cd..ab44133bc0bf 100644
> --- a/sound/soc/soc-utils.c
> +++ b/sound/soc/soc-utils.c
> @@ -273,13 +273,13 @@ static int dummy_dma_open(struct snd_pcm_substream *substream)
>         return 0;
>  }
>
> -static const struct snd_pcm_ops dummy_dma_ops = {
> +static const struct snd_pcm_ops snd_dummy_ops = {
>         .open           = dummy_dma_open,
>         .ioctl          = snd_pcm_lib_ioctl,
>  };
>
>  static const struct snd_soc_component_driver dummy_platform = {
> -       .ops = &dummy_dma_ops,
> +       .ops = &snd_dummy_ops,
>  };
>
>  static const struct snd_soc_component_driver dummy_codec = {
> --
> 2.19.0.605.g01d371f741-goog
>


-- 
With Best Regards,
Andy Shevchenko

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] ASoC: soc-utils: Rename dummy_dma_ops to snd_dummy_ops
  2018-09-25  8:36 ` Andy Shevchenko
@ 2018-09-25 16:49   ` Mark Brown
  0 siblings, 0 replies; 3+ messages in thread
From: Mark Brown @ 2018-09-25 16:49 UTC (permalink / raw)
  To: Andy Shevchenko
  Cc: Matthias Kaehlcke, Liam Girdwood, Jaroslav Kysela, Takashi Iwai,
	ALSA Development Mailing List, Linux Kernel Mailing List

[-- Attachment #1: Type: text/plain, Size: 516 bytes --]

On Tue, Sep 25, 2018 at 11:36:55AM +0300, Andy Shevchenko wrote:
> On Tue, Sep 25, 2018 at 3:48 AM Matthias Kaehlcke <mka@chromium.org> wrote:

> >   extern const struct dma_map_ops dummy_dma_ops;
> >                                   ^

> > Rename the symbol in soc-utils.c to 'snd_dummy_ops' to avoid the conflict.

> But it misses 'dma' part as I can see they are still DMA related.

> snd_dummy_dma_ops ?

Yes, we have many different set of operations in ALSA, snd_dummy_ops is
just inviting further collisions.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2018-09-25 16:49 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-09-25  0:47 [PATCH] ASoC: soc-utils: Rename dummy_dma_ops to snd_dummy_ops Matthias Kaehlcke
2018-09-25  8:36 ` Andy Shevchenko
2018-09-25 16:49   ` Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).