linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/7] IP101GR: devicetree based configuration of SEL_INTR32
@ 2018-11-17 18:20 Martin Blumenstingl
  2018-11-17 18:20 ` [PATCH 1/7] dt-bindings: vendor-prefix: add prefix for IC Plus Corp Martin Blumenstingl
                   ` (6 more replies)
  0 siblings, 7 replies; 18+ messages in thread
From: Martin Blumenstingl @ 2018-11-17 18:20 UTC (permalink / raw)
  To: netdev, devicetree, f.fainelli, andrew, mark.rutland, robh+dt, davem
  Cc: linux-kernel, Martin Blumenstingl

The IP101GR is a 32-pin QFN package variant of the IP101G/IP101GA
Ethernet PHY. Due to it's limited amount of pins the RXER (receive
error) and INTR32 (interrupt) functions share pin 21.

The goal of this series is:
- some small cleanups in patches 3, 4 and 5
- allowing the kernel to detect IRQ floods on boards where the IP101GR
  is configured in RXER mode but the RXER line is configured on the
  host SoC as interrupt line (patch 6)
- configuration of the SEL_INTR32 register so we can use the interrupt
  function on boards where the RXER/INTR32 pin (pin 21) is routed to
  one of the host SoC's interrupt inputs (patches 1, 2, 7)

A use-case where this is needed is the Endless Mini (EC-100). I have
tested my changes on that board. This also confirms that Heiner
Kallweit's recent icplus.c PHY driver changes are working (at least on
my setup).

This series is based on net-next commit 9c549a6b057386d ("selftests:
add explicit test for multiple concurrent GRO sockets")


Martin Blumenstingl (7):
  dt-bindings: vendor-prefix: add prefix for IC Plus Corp.
  dt-bindings: net: phy: add bindings for the IC Plus Corp. IP101A/G
    PHYs
  net: phy: icplus: keep all ip101a_g functions together
  net: phy: icplus: use the BIT macro where possible
  net: phy: icplus: rename IP101A_G_NO_IRQ to IP101A_G_IRQ_ALL_MASK
  net: phy: icplus: implement .did_interrupt for IP101A/G
  net: phy: icplus: allow configuring the interrupt function on IP101GR

 .../bindings/net/icplus-ip101ag.txt           |  19 +++
 .../devicetree/bindings/vendor-prefixes.txt   |   1 +
 drivers/net/phy/icplus.c                      | 125 +++++++++++++++---
 3 files changed, 125 insertions(+), 20 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/net/icplus-ip101ag.txt

-- 
2.19.1


^ permalink raw reply	[flat|nested] 18+ messages in thread

end of thread, other threads:[~2018-11-18 21:25 UTC | newest]

Thread overview: 18+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-11-17 18:20 [PATCH 0/7] IP101GR: devicetree based configuration of SEL_INTR32 Martin Blumenstingl
2018-11-17 18:20 ` [PATCH 1/7] dt-bindings: vendor-prefix: add prefix for IC Plus Corp Martin Blumenstingl
2018-11-17 18:20 ` [PATCH 2/7] dt-bindings: net: phy: add bindings for the IC Plus Corp. IP101A/G PHYs Martin Blumenstingl
2018-11-18 17:03   ` Andrew Lunn
2018-11-18 17:29     ` Martin Blumenstingl
2018-11-17 18:20 ` [PATCH 3/7] net: phy: icplus: keep all ip101a_g functions together Martin Blumenstingl
2018-11-18 17:04   ` Andrew Lunn
2018-11-17 18:20 ` [PATCH 4/7] net: phy: icplus: use the BIT macro where possible Martin Blumenstingl
2018-11-18 17:04   ` Andrew Lunn
2018-11-17 18:20 ` [PATCH 5/7] net: phy: icplus: rename IP101A_G_NO_IRQ to IP101A_G_IRQ_ALL_MASK Martin Blumenstingl
2018-11-18 17:06   ` Andrew Lunn
2018-11-17 18:20 ` [PATCH 6/7] net: phy: icplus: implement .did_interrupt for IP101A/G Martin Blumenstingl
2018-11-18 17:09   ` Andrew Lunn
2018-11-17 18:20 ` [PATCH 7/7] net: phy: icplus: allow configuring the interrupt function on IP101GR Martin Blumenstingl
2018-11-18 17:13   ` Andrew Lunn
2018-11-18 17:30     ` Martin Blumenstingl
2018-11-18 17:45       ` Andrew Lunn
2018-11-18 21:25         ` Martin Blumenstingl

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).