linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v8 00/13] arch/resctrl: AMD QoS support
@ 2018-11-16 20:54 Moger, Babu
  2018-11-16 20:54 ` [PATCH v8 01/13] arch/resctrl: Start renaming the rdt files to more generic names Moger, Babu
                   ` (12 more replies)
  0 siblings, 13 replies; 32+ messages in thread
From: Moger, Babu @ 2018-11-16 20:54 UTC (permalink / raw)
  To: tglx, mingo, bp, corbet, fenghua.yu, reinette.chatre, peterz,
	gregkh, davem, akpm
  Cc: hpa, x86, mchehab+samsung, arnd, kstewart, pombredanne, rafael,
	kirill.shutemov, tony.luck, qianyue.zj, xiaochen.shen, pbonzini,
	Singh, Brijesh, Hurwitz, Sherry, dwmw2, Lendacky, Thomas, luto,
	joro, jannh, vkuznets, rian, jpoimboe, Moger, Babu, linux-kernel,
	linux-doc

This series adds support for AMD64 architectural extensions for Platform
Quality of Service. These extensions are intended to provide for the
monitoring of the usage of certain system resources by one or more
processors and for the separate allocation and enforcement of limits on
the use of certain system resources by one or more processors.

The monitoring and enforcement are not necessarily applied across the
entire system, but in general apply to a QOS domain which corresponds to
some shared system resource.  The set of resources which are monitored and
the set for which the enforcement of limits is provided are implementation
dependent. Platform QOS features are implemented on a logical processor
basis. Therefore, multiple hardware threads of a single physical CPU core
may have independent resource monitoring and enforcement configurations.

AMD's next generation of processors support following QoS sub-features.
- L3 Cache allocation enforcement
- L3 Cache occupancy monitoring
- L3 Code-Data Prioritization support
- Memory Bandwidth Enforcement(Allocation)

The public specification for this feature is available at
https://developer.amd.com/wp-content/resources/56375.pdf

Obviously, there are multiple ways we can go about these changes. We felt
it is appropriate to rename and re-organize the code little bit before
making the functional changes. The first few patches(1-10) renames and
re-organizes the sources in preparation. Rest of the patches(7-11) adds
support for AMD QoS features.

Please review.

Changes from v7 -> v8:
https://lore.kernel.org/lkml/20181109205153.14811-1-babu.moger@amd.com/
 a. Addressed comments from Borislav Petkov.
    Changed the subject line to arch/resctrl from arch/x86.
    Few code cleanup related changes on patch 2 and 3.

Changes from v6 -> v7:
 a. Mainly addressed the comments from Mattew Wilcox. Removed both 
    CONFIG_INTEL_RDT and CONFIG_AMD_QOS config parameter. We dont need
    to use two separate config parameter to enable this feature. The
    final code will be same in both the cases. So, used the new vendor
    neutral parameter CONFIG_RESCTRL to enable resource control feature
    for both Intel and AMD 

Changes from v5 -> v6:
https://lore.kernel.org/lkml/20181106154034.15386-1-babu.moger@amd.com/
 a. Addressed comments from Fenghua Yu. Added vendor check while
    detecting MBA software controller support.
 a. Rebased again on top of
    git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git x86/cache

Changes from v4 -> v5:
https://lore.kernel.org/lkml/20181018225124.23043-1-babu.moger@amd.com/
 a. Addressed comments from Fenghua Yu.
 b. The functions update_mba_bw and set_mba_sc is not required for AMD.
    Removed all the changes related to these functions.

Changes from v3 -> v4:
https://lore.kernel.org/lkml/20181015205514.25387-1-babu.moger@amd.com/
 a. Addressed comments from Reinette Chatre and Borislav Petkov.
 b. Removed X86 dependency for CONFIG_AMD_QOS. Implicitly is it already
    dependent on X86.
 c. Updated the MAINTAINER file for name changes.
 d. Addressed most of "checkpatch.pl --strict" issues.
 d. Updated Documentation/x86/resctrl_ui.txt(previously
    intel_rdt_ui.txt) file with AMD specific details. Changed few names
    to resctrl from intel_rdt.

Changes from v2 -> v3:
 https://lore.kernel.org/lkml/20181011203223.18157-1-babu.moger@amd.com/
 a. Rebased the patches on top of below branch as suggested by Thomas Gleixner.
    git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git x86/cache
 b. Addressed comments from Reinette Chatre, Fenghua Yu and Borislav Petkov.
 c. Main changes are related to renaming the files and functions.
    Renamed from intel_rdt to more generic resctrl(patches 1 to 3).
 d. Config parameter changed from PLATFORM_QOS to more generic RESCTRL.
 e. Fixed minor indentation issues.

Changes from v1 -> v2:
 https://lore.kernel.org/lkml/20181005205512.29545-1-babu.moger@amd.com/
 a. Removed RFC from subject header. Based on the discussion so far, 
    plan is to go ahead with these patches and eventually re-structure
    the code to make arch and non-arch separate.
 b. Addressed comments from Reinette Chatre and Fenghua Yu.
 c. Separated quirks and MBA from rdt init code. Kept the rest of the
    code as is.
 d. Added _intel suffixes all the Intel only code just like AMD code.
 e. Added one more patch to bring the macros into header file.
 f. Few minor text changes.

v1:
 https://lore.kernel.org/lkml/20180924191841.29111-1-babu.moger@amd.com/

Babu Moger (12):
  arch/resctrl: Start renaming the rdt files to more generic names
  arch/resctrl: Rename the RDT functions and definitions
  arch/resctrl: Re-arrange RDT init code
  arch/resctrl: Bring all the macros to resctrl.h
  arch/resctrl: Rename config parameter INTEL_RDT to RESCTRL
  arch/resctrl: Initialize the resource functions that are different
  arch/resctrl: Bring cbm_validate function into the resource structure
  arch/resctrl: Add vendor check for MBA software controller
  arch/resctrl: Update the RESCTRL config parameter
  arch/resctrl: Introduce QOS feature for AMD
  Documentation: Rename and update intel_rdt_ui.txt to resctrl_ui.txt
  MAINTAINERS: Update the file and documentation names in arch/x86

Sherry Hurwitz (1):
  arch/resctrl: Add AMD feature bit X86_FEATURE_MBA in cpuid bits array

 .../x86/{intel_rdt_ui.txt => resctrl_ui.txt}  |   9 +-
 MAINTAINERS                                   |   6 +-
 arch/x86/Kconfig                              |  23 ++-
 .../{intel_rdt_sched.h => resctrl_sched.h}    |  28 +--
 arch/x86/kernel/cpu/Makefile                  |   6 +-
 .../x86/kernel/cpu/{intel_rdt.c => resctrl.c} | 165 +++++++++++++++---
 .../x86/kernel/cpu/{intel_rdt.h => resctrl.h} |  37 ++--
 ...dt_ctrlmondata.c => resctrl_ctrlmondata.c} |  80 ++++++++-
 ...{intel_rdt_monitor.c => resctrl_monitor.c} |  20 +--
 ...dt_pseudo_lock.c => resctrl_pseudo_lock.c} |   6 +-
 ...ck_event.h => resctrl_pseudo_lock_event.h} |   2 +-
 ...ntel_rdt_rdtgroup.c => resctrl_rdtgroup.c} |  19 +-
 arch/x86/kernel/cpu/scattered.c               |   7 +-
 arch/x86/kernel/process_32.c                  |   4 +-
 arch/x86/kernel/process_64.c                  |   4 +-
 include/linux/sched.h                         |   2 +-
 16 files changed, 315 insertions(+), 103 deletions(-)
 rename Documentation/x86/{intel_rdt_ui.txt => resctrl_ui.txt} (99%)
 rename arch/x86/include/asm/{intel_rdt_sched.h => resctrl_sched.h} (77%)
 rename arch/x86/kernel/cpu/{intel_rdt.c => resctrl.c} (85%)
 rename arch/x86/kernel/cpu/{intel_rdt.h => resctrl.h} (94%)
 rename arch/x86/kernel/cpu/{intel_rdt_ctrlmondata.c => resctrl_ctrlmondata.c} (86%)
 rename arch/x86/kernel/cpu/{intel_rdt_monitor.c => resctrl_monitor.c} (97%)
 rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock.c => resctrl_pseudo_lock.c} (99%)
 rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock_event.h => resctrl_pseudo_lock_event.h} (95%)
 rename arch/x86/kernel/cpu/{intel_rdt_rdtgroup.c => resctrl_rdtgroup.c} (99%)

-- 
2.17.1


^ permalink raw reply	[flat|nested] 32+ messages in thread

end of thread, other threads:[~2018-11-21 16:47 UTC | newest]

Thread overview: 32+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-11-16 20:54 [PATCH v8 00/13] arch/resctrl: AMD QoS support Moger, Babu
2018-11-16 20:54 ` [PATCH v8 01/13] arch/resctrl: Start renaming the rdt files to more generic names Moger, Babu
2018-11-18 14:07   ` Borislav Petkov
2018-11-19 19:13     ` Thomas Gleixner
2018-11-19 20:11       ` Moger, Babu
2018-11-19 20:22         ` Borislav Petkov
2018-11-19 20:26           ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 02/13] arch/resctrl: Rename the RDT functions and definitions Moger, Babu
2018-11-16 20:54 ` [PATCH v8 03/13] arch/resctrl: Re-arrange RDT init code Moger, Babu
2018-11-20  9:27   ` Borislav Petkov
2018-11-20 16:31     ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 04/13] arch/resctrl: Bring all the macros to resctrl.h Moger, Babu
2018-11-20  9:35   ` Borislav Petkov
2018-11-20 16:32     ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 05/13] arch/resctrl: Rename config parameter INTEL_RDT to RESCTRL Moger, Babu
2018-11-20  9:42   ` Borislav Petkov
2018-11-20 19:15     ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 06/13] arch/resctrl: Initialize the resource functions that are different Moger, Babu
2018-11-20  9:59   ` Borislav Petkov
2018-11-20 12:05     ` Borislav Petkov
2018-11-21 16:47       ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 07/13] arch/resctrl: Bring cbm_validate function into the resource structure Moger, Babu
2018-11-16 20:54 ` [PATCH v8 08/13] arch/resctrl: Add vendor check for MBA software controller Moger, Babu
2018-11-16 20:54 ` [PATCH v8 09/13] arch/resctrl: Update the RESCTRL config parameter Moger, Babu
2018-11-16 21:17   ` Randy Dunlap
2018-11-17 16:30     ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 10/13] arch/resctrl: Add AMD feature bit X86_FEATURE_MBA in cpuid bits array Moger, Babu
2018-11-16 20:54 ` [PATCH v8 11/13] arch/resctrl: Introduce QOS feature for AMD Moger, Babu
2018-11-20 12:16   ` Borislav Petkov
2018-11-20 19:40     ` Moger, Babu
2018-11-16 20:54 ` [PATCH v8 12/13] Documentation: Rename and update intel_rdt_ui.txt to resctrl_ui.txt Moger, Babu
2018-11-16 20:54 ` [PATCH v8 13/13] MAINTAINERS: Update the file and documentation names in arch/x86 Moger, Babu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).