linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] n_tty: update comment for WAKEUP_CHARS define
@ 2018-12-29 12:48 Valentin Vidic
  2019-01-02  6:48 ` Jiri Slaby
  0 siblings, 1 reply; 3+ messages in thread
From: Valentin Vidic @ 2018-12-29 12:48 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: Jiri Slaby, linux-kernel, Valentin Vidic

Give a better descriptions of what WAKEUP_CHARS represents.

Signed-off-by: Valentin Vidic <Valentin.Vidic@CARNet.hr>
---
 drivers/tty/n_tty.c | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/drivers/tty/n_tty.c b/drivers/tty/n_tty.c
index 3ad460219fd6..1dfbd45746da 100644
--- a/drivers/tty/n_tty.c
+++ b/drivers/tty/n_tty.c
@@ -50,8 +50,10 @@
 #include <linux/ratelimit.h>
 #include <linux/vmalloc.h>
 
-
-/* number of characters left in xmit buffer before select has we have room */
+/*
+ * Until this number of characters is queued in the xmit buffer, select will
+ * return "we have room for writes".
+ */
 #define WAKEUP_CHARS 256
 
 /*
-- 
2.20.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] n_tty: update comment for WAKEUP_CHARS define
  2018-12-29 12:48 [PATCH] n_tty: update comment for WAKEUP_CHARS define Valentin Vidic
@ 2019-01-02  6:48 ` Jiri Slaby
  2019-01-02  9:50   ` Valentin Vidic
  0 siblings, 1 reply; 3+ messages in thread
From: Jiri Slaby @ 2019-01-02  6:48 UTC (permalink / raw)
  To: Valentin Vidic, Greg Kroah-Hartman; +Cc: linux-kernel

On 29. 12. 18, 13:48, Valentin Vidic wrote:
> Give a better descriptions of what WAKEUP_CHARS represents.
> 
> Signed-off-by: Valentin Vidic <Valentin.Vidic@CARNet.hr>

I am not a native speaker, but this is much better than the current text.

Acked-by: Jiri Slaby <jslaby@suse.cz>

BTW this text is copy&pasted from/to all the other WAKEUP_CHARS
locations. Care to fix them all?

> ---
>  drivers/tty/n_tty.c | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/tty/n_tty.c b/drivers/tty/n_tty.c
> index 3ad460219fd6..1dfbd45746da 100644
> --- a/drivers/tty/n_tty.c
> +++ b/drivers/tty/n_tty.c
> @@ -50,8 +50,10 @@
>  #include <linux/ratelimit.h>
>  #include <linux/vmalloc.h>
>  
> -
> -/* number of characters left in xmit buffer before select has we have room */
> +/*
> + * Until this number of characters is queued in the xmit buffer, select will
> + * return "we have room for writes".
> + */
>  #define WAKEUP_CHARS 256
>  
>  /*
> 

thanks,
-- 
js
suse labs

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] n_tty: update comment for WAKEUP_CHARS define
  2019-01-02  6:48 ` Jiri Slaby
@ 2019-01-02  9:50   ` Valentin Vidic
  0 siblings, 0 replies; 3+ messages in thread
From: Valentin Vidic @ 2019-01-02  9:50 UTC (permalink / raw)
  To: Jiri Slaby; +Cc: Greg Kroah-Hartman, linux-kernel

On Wed, Jan 02, 2019 at 07:48:42AM +0100, Jiri Slaby wrote:
> On 29. 12. 18, 13:48, Valentin Vidic wrote:
> > Give a better descriptions of what WAKEUP_CHARS represents.
> > 
> > Signed-off-by: Valentin Vidic <Valentin.Vidic@CARNet.hr>
> 
> I am not a native speaker, but this is much better than the current text.
> 
> Acked-by: Jiri Slaby <jslaby@suse.cz>
> 
> BTW this text is copy&pasted from/to all the other WAKEUP_CHARS
> locations. Care to fix them all?

Yes, I've seen other instances of WAKEUP_CHARS but they don't look like
the same thing, for example:

rocket_int.h:/* number of characters left in xmit buffer before we ask for more */
rocket_int.h:#define WAKEUP_CHARS 256

rocket.c:       if (info->xmit_cnt < WAKEUP_CHARS) {
rocket.c:               tty_wakeup(tty);

Maybe the instance in n_tty.c could use a better name instead?

-- 
Valentin

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-01-02  9:50 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-12-29 12:48 [PATCH] n_tty: update comment for WAKEUP_CHARS define Valentin Vidic
2019-01-02  6:48 ` Jiri Slaby
2019-01-02  9:50   ` Valentin Vidic

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).