linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Petr Mladek <pmladek@suse.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	linux-kernel@vger.kernel.org, rafael@kernel.org,
	linux-acpi@vger.kernel.org, devicetree@vger.kernel.org,
	Rob Herring <robh@kernel.org>
Subject: Re: [PATCH v2 3/6] device property: Add a function to obtain a node's prefix
Date: Wed, 27 Mar 2019 13:36:59 +0100	[thread overview]
Message-ID: <20190327123659.nna3hqcotnerptiz@pathway.suse.cz> (raw)
In-Reply-To: <20190326133248.2nrm5javjw4vd2yq@paasikivi.fi.intel.com>

On Tue 2019-03-26 15:32:48, Sakari Ailus wrote:
> Hi Andy,
> 
> On Tue, Mar 26, 2019 at 03:16:26PM +0200, Andy Shevchenko wrote:
> > On Tue, Mar 26, 2019 at 02:41:03PM +0200, Sakari Ailus wrote:
> > > The prefix is used for printing purpose before a node, and it also works
> > > as a separator between two nodes.
> > > 
> > 
> > One nit below.
> > 
> > > +static const char *
> > > +acpi_fwnode_get_name_prefix(const struct fwnode_handle *fwnode)
> > > +{
> > > +	struct fwnode_handle *parent;
> > > +
> > 
> > > +	parent = fwnode_get_parent(fwnode);
> > > +	/* Root node. */
> > 
> > I guess a comment could be easier to read if it goes before parent assignment
> > line.
> 
> Only if the comments are changed accordingly. What we're doing here is
> trying to figure out whether this is the root node. I can do that for v3.

IMHO, the comment in acpi_fwnode_get_name() is easier to understand:

/* Is this the root node? */

> > 
> > > +	if (!parent)
> > > +		return "";
> > > +
> > > +	parent = fwnode_get_next_parent(parent);
> > > +	/* Second node from the root; no prefix here either. */
> > 
> > Ditto.

/* Is this 2nd node from the root? */

> > > +	if (!parent)
> > > +		return "";
> > > +
> > > +	fwnode_handle_put(parent);
> > > +
> > > +	/* ACPI device or data node. */
> > > +	return ".";
> > > +}

Best Regards,
Petr

  reply	other threads:[~2019-03-27 12:37 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-26 12:41 [PATCH v2 0/6] Device property improvements, add %pfw format specifier Sakari Ailus
2019-03-26 12:41 ` [PATCH v2 1/6] device property: Add functions for accessing node's parents Sakari Ailus
2019-03-27 12:26   ` Petr Mladek
2019-03-27 14:20     ` Sakari Ailus
2019-03-28  9:38       ` Rafael J. Wysocki
2019-03-28 11:13         ` Sakari Ailus
2019-03-28 14:52           ` Rafael J. Wysocki
2019-03-29 13:15             ` Sakari Ailus
2019-03-29 14:15               ` Andy Shevchenko
2019-03-29 14:46                 ` Sakari Ailus
2019-03-29 23:00               ` Rafael J. Wysocki
2019-03-28 14:10       ` Petr Mladek
2019-03-29 13:04         ` Sakari Ailus
2019-03-29 14:14           ` Andy Shevchenko
2019-03-29 15:31             ` Sakari Ailus
2019-03-26 12:41 ` [PATCH v2 2/6] device property: Add fwnode_get_name for returning the name of a node Sakari Ailus
2019-03-28  9:45   ` Rafael J. Wysocki
2019-03-28 11:31     ` Sakari Ailus
2019-03-31  6:42   ` Rob Herring
2019-03-26 12:41 ` [PATCH v2 3/6] device property: Add a function to obtain a node's prefix Sakari Ailus
2019-03-26 13:16   ` Andy Shevchenko
2019-03-26 13:32     ` Sakari Ailus
2019-03-27 12:36       ` Petr Mladek [this message]
2019-03-28 11:43         ` Sakari Ailus
2019-03-31  6:42   ` Rob Herring
2019-03-26 12:41 ` [PATCH v2 4/6] lib/vsprintf: Remove support for %pF and %pf in favour of %pS and %ps Sakari Ailus
2019-03-26 12:41 ` [PATCH v2 5/6] lib/vsprintf: Make use of fwnode API to obtain node names and separators Sakari Ailus
2019-03-26 12:41 ` [PATCH v2 6/6] lib/vsprintf: Add %pfw conversion specifier for printing fwnode names Sakari Ailus
2019-03-26 13:11   ` Rasmus Villemoes
2019-03-26 13:24     ` Andy Shevchenko
2019-03-26 13:31       ` Sakari Ailus
2019-03-28 14:29       ` Petr Mladek
2019-03-29 13:10         ` Sakari Ailus
2019-03-26 20:18   ` Joe Perches
     [not found]     ` <20190328114845.giusyarjibvg5ru7@kekkonen.localdomain>
2019-03-28 11:51       ` Sakari Ailus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190327123659.nna3hqcotnerptiz@pathway.suse.cz \
    --to=pmladek@suse.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=robh@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).