linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Re: [PATCH v2 0/5] simple sort swap function improvements
       [not found] <19606671554056883@myt3-1179f584969c.qloud-c.yandex.net>
@ 2019-04-01  9:25 ` Andy Shevchenko
       [not found] ` <23051461554058370@iva6-3ac3de5fcc31.qloud-c.yandex.net>
       [not found] ` <14019281554057359@sas1-87f9feb8d943.qloud-c.yandex.net>
  2 siblings, 0 replies; 5+ messages in thread
From: Andy Shevchenko @ 2019-04-01  9:25 UTC (permalink / raw)
  To: Andrey Abramov, Linux Kernel Mailing List

On Sun, Mar 31, 2019 at 09:28:03PM +0300, Andrey Abramov wrote:
> This is the logical continuation of the "lib/sort & lib/list_sort:
> faster and smaller" series by George Spelvin (added to linux-next
> recently).
> 
> Since Spectre mitigations have made indirect function calls more
> expensive, and the previous patch series implements the default
> simple byte copies without them, an "optimized" custom swap
> function is now a waste of time as well as code.
> 
> Patches 1 to 4 replace trivial swap functions with the built-in
> (which is now much faster) and are grouped by subsystem.
> Being pure code deletion patches, they are sure to bring joy to
> Linus's heart.
> 
> Having reviewed all call sites, only three non-trivial swap
> functions remain:  arch/x86/kernel/unwind_orc.c,
> kernel/jump_label.c and lib/extable.c.
> 
> Patch #5 takes the opportunity to clean up a long-standing
> interface wart: the swap function's size parameter was an int,
> which doesn't match the size_t element size passed to sort()
> function itself.  So change it to size_t.
> 
> v1->v2: Only commit messages have changed to better explain
> 	the purpose of commits. (Thanks to George Spelvin and Greg KH)


Thanks for an update.

Hint:
scripts/get_maintainer.pl --git --git-min-percent=67 ...

(Note 67% magic value)

> 
> Andrey Abramov (5):
>   arch/arc: unwind.c: replace swap function with built-in one
>   powerpc: module_[32|64].c: replace swap function with built-in one
>   ocfs2: dir,refcounttree,xattr: replace swap functions with built-in
>     one
>   ubifs: find.c: replace swap function with built-in one
>   Lib: sort.h: replace int size with size_t size in the swap function
> 
>  arch/arc/kernel/unwind.c        | 20 ++------------------
>  arch/powerpc/kernel/module_32.c | 17 +----------------
>  arch/powerpc/kernel/module_64.c | 17 +----------------
>  arch/x86/kernel/unwind_orc.c    |  2 +-
>  fs/ocfs2/dir.c                  | 13 +------------
>  fs/ocfs2/refcounttree.c         | 13 +++----------
>  fs/ocfs2/xattr.c                | 15 +++------------
>  fs/ubifs/find.c                 |  9 +--------
>  include/linux/sort.h            |  2 +-
>  kernel/jump_label.c             |  2 +-
>  lib/extable.c                   |  2 +-
>  lib/sort.c                      |  6 +++---
>  12 files changed, 19 insertions(+), 99 deletions(-)
> 
> -- 
> 2.21.0
> 
> 

-- 
With Best Regards,
Andy Shevchenko



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 5/5] Lib: sort.h: replace int size with size_t size in the swap function
       [not found] ` <23051461554058370@iva6-3ac3de5fcc31.qloud-c.yandex.net>
@ 2019-04-01  9:35   ` Andy Shevchenko
  2019-04-01  9:56     ` George Spelvin
  0 siblings, 1 reply; 5+ messages in thread
From: Andy Shevchenko @ 2019-04-01  9:35 UTC (permalink / raw)
  To: Andrey Abramov
  Cc: vgupta, benh, paulus, mpe, tglx, mingo, bp, hpa, x86, mark,
	jlbec, richard, dedekind1, adrian.hunter, gregkh, naveen.n.rao,
	jpoimboe, Dave Chinner, darrick.wong, ard.biesheuvel,
	George Spelvin, linux-snps-arc, Linux Kernel Mailing List,
	linuxppc-dev, ocfs2-devel, linux-mtd, sfr, jannh, jslaby, peterz,
	yamada.masahiro, Rasmus Villemoes, Morton Andrew

On Sun, Mar 31, 2019 at 09:52:50PM +0300, Andrey Abramov wrote:
> Replace int type with size_t type of the size argument
> in the swap function, also affect all its dependencies.
> 
> It's always been weird that sort() takes a size_t element size,
> but passes an int size to (*swap)(). Not a bug because we don't
> sort objects >2GB large, but it's ugly.

Hmm... If (*swap)() is called recursively it means the change might increase
stack usage on 64-bit platforms.

Am I missing something?

> 
> Signed-off-by: Andrey Abramov <st5pub@yandex.ru>
> Reviewed by: George Spelvin <lkml@sdf.org>
> ---
>  arch/x86/kernel/unwind_orc.c | 2 +-
>  include/linux/sort.h         | 2 +-
>  kernel/jump_label.c          | 2 +-
>  lib/extable.c                | 2 +-
>  lib/sort.c                   | 6 +++---
>  5 files changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/arch/x86/kernel/unwind_orc.c b/arch/x86/kernel/unwind_orc.c
> index 89be1be1790c..1078c287198c 100644
> --- a/arch/x86/kernel/unwind_orc.c
> +++ b/arch/x86/kernel/unwind_orc.c
> @@ -176,7 +176,7 @@ static struct orc_entry *orc_find(unsigned long ip)
>  	return orc_ftrace_find(ip);
>  }
>  
> -static void orc_sort_swap(void *_a, void *_b, int size)
> +static void orc_sort_swap(void *_a, void *_b, size_t size)
>  {
>  	struct orc_entry *orc_a, *orc_b;
>  	struct orc_entry orc_tmp;
> diff --git a/include/linux/sort.h b/include/linux/sort.h
> index 2b99a5dd073d..aea39d552ff7 100644
> --- a/include/linux/sort.h
> +++ b/include/linux/sort.h
> @@ -6,6 +6,6 @@
>  
>  void sort(void *base, size_t num, size_t size,
>  	  int (*cmp)(const void *, const void *),
> -	  void (*swap)(void *, void *, int));
> +	  void (*swap)(void *, void *, size_t));
>  
>  #endif
> diff --git a/kernel/jump_label.c b/kernel/jump_label.c
> index bad96b476eb6..340b788571fb 100644
> --- a/kernel/jump_label.c
> +++ b/kernel/jump_label.c
> @@ -45,7 +45,7 @@ static int jump_label_cmp(const void *a, const void *b)
>  	return 0;
>  }
>  
> -static void jump_label_swap(void *a, void *b, int size)
> +static void jump_label_swap(void *a, void *b, size_t size)
>  {
>  	long delta = (unsigned long)a - (unsigned long)b;
>  	struct jump_entry *jea = a;
> diff --git a/lib/extable.c b/lib/extable.c
> index f54996fdd0b8..db2888342cd7 100644
> --- a/lib/extable.c
> +++ b/lib/extable.c
> @@ -28,7 +28,7 @@ static inline unsigned long ex_to_insn(const struct exception_table_entry *x)
>  #ifndef ARCH_HAS_RELATIVE_EXTABLE
>  #define swap_ex		NULL
>  #else
> -static void swap_ex(void *a, void *b, int size)
> +static void swap_ex(void *a, void *b, size_t size)
>  {
>  	struct exception_table_entry *x = a, *y = b, tmp;
>  	int delta = b - a;
> diff --git a/lib/sort.c b/lib/sort.c
> index 50855ea8c262..60fbbc29104a 100644
> --- a/lib/sort.c
> +++ b/lib/sort.c
> @@ -114,7 +114,7 @@ static void swap_bytes(void *a, void *b, size_t n)
>  	} while (n);
>  }
>  
> -typedef void (*swap_func_t)(void *a, void *b, int size);
> +typedef void (*swap_func_t)(void *a, void *b, size_t size);
>  
>  /*
>   * The values are arbitrary as long as they can't be confused with
> @@ -138,7 +138,7 @@ static void do_swap(void *a, void *b, size_t size, swap_func_t swap_func)
>  	else if (swap_func == SWAP_BYTES)
>  		swap_bytes(a, b, size);
>  	else
> -		swap_func(a, b, (int)size);
> +		swap_func(a, b, size);
>  }
>  
>  /**
> @@ -187,7 +187,7 @@ static size_t parent(size_t i, unsigned int lsbit, size_t size)
>   */
>  void sort(void *base, size_t num, size_t size,
>  	  int (*cmp_func)(const void *, const void *),
> -	  void (*swap_func)(void *, void *, int size))
> +	  void (*swap_func)(void *, void *, size_t size))
>  {
>  	/* pre-scale counters for performance */
>  	size_t n = num * size, a = (num/2) * size;
> -- 
> 2.21.0
> 
> 

-- 
With Best Regards,
Andy Shevchenko



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 5/5] Lib: sort.h: replace int size with size_t size in the swap function
  2019-04-01  9:35   ` [PATCH v2 5/5] Lib: sort.h: replace int size with size_t size in the swap function Andy Shevchenko
@ 2019-04-01  9:56     ` George Spelvin
  2019-04-01 10:28       ` Andy Shevchenko
  0 siblings, 1 reply; 5+ messages in thread
From: George Spelvin @ 2019-04-01  9:56 UTC (permalink / raw)
  To: andriy.shevchenko, st5pub
  Cc: adrian.hunter, ard.biesheuvel, benh, bp, darrick.wong, dchinner,
	dedekind1, gregkh, hpa, jannh, jlbec, jpoimboe, jslaby,
	linux-kernel, linux-mtd, linux-snps-arc, linuxppc-dev, lkml,
	mark, mingo, mpe, naveen.n.rao, ocfs2-devel, paulus, peterz,
	richard, sfr, tglx, vgupta, x86

On Mon, 1 Apr 2019 at 12:35:55 +0300, Andy Shevchenko wrote:
> Hmm... If (*swap)() is called recursively it means the change might increase
> stack usage on 64-bit platforms.
> 
> Am I missing something?

Under what conceivable circumstance would someone write a recursive
(*swap)() function?

You're technically right, but the precondition is more fantastical
than "if the U.K.'s parliament get their shit together before the
12th", so I have a hard time worrying about it.

But you did make me think of something: the whole reason swap()
takes a size argument is for the benefit of the (no longer existing)
generic swap functions.  All of the custom swap functions ignore
it.

So how about *deleting* the parameter instead?  That simplifies
everything.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 5/5] Lib: sort.h: replace int size with size_t size in the swap function
  2019-04-01  9:56     ` George Spelvin
@ 2019-04-01 10:28       ` Andy Shevchenko
  0 siblings, 0 replies; 5+ messages in thread
From: Andy Shevchenko @ 2019-04-01 10:28 UTC (permalink / raw)
  To: George Spelvin
  Cc: st5pub, adrian.hunter, ard.biesheuvel, benh, bp, darrick.wong,
	dchinner, dedekind1, gregkh, hpa, jannh, jlbec, jpoimboe, jslaby,
	linux-kernel, linux-mtd, linux-snps-arc, linuxppc-dev, mark,
	mingo, mpe, naveen.n.rao, ocfs2-devel, paulus, peterz, richard,
	sfr, tglx, vgupta, x86

On Mon, Apr 01, 2019 at 09:56:07AM +0000, George Spelvin wrote:
> On Mon, 1 Apr 2019 at 12:35:55 +0300, Andy Shevchenko wrote:
> > Hmm... If (*swap)() is called recursively it means the change might increase
> > stack usage on 64-bit platforms.
> > 
> > Am I missing something?
> 
> Under what conceivable circumstance would someone write a recursive
> (*swap)() function?
> 
> You're technically right, but the precondition is more fantastical
> than "if the U.K.'s parliament get their shit together before the
> 12th", so I have a hard time worrying about it.
> 
> But you did make me think of something: the whole reason swap()
> takes a size argument is for the benefit of the (no longer existing)
> generic swap functions.  All of the custom swap functions ignore
> it.
> 
> So how about *deleting* the parameter instead?  That simplifies
> everything.

I like this idea!

-- 
With Best Regards,
Andy Shevchenko



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 2/5] powerpc: module_[32|64].c: replace swap function with built-in one
       [not found] ` <14019281554057359@sas1-87f9feb8d943.qloud-c.yandex.net>
@ 2019-04-01 11:08   ` Michael Ellerman
  0 siblings, 0 replies; 5+ messages in thread
From: Michael Ellerman @ 2019-04-01 11:08 UTC (permalink / raw)
  To: Andrey Abramov, vgupta, benh, paulus, tglx, mingo, bp, hpa, x86,
	mark, jlbec, richard, dedekind1, adrian.hunter, gregkh,
	naveen.n.rao, jpoimboe, Dave Chinner, darrick.wong,
	ard.biesheuvel, George Spelvin, linux-snps-arc,
	Linux Kernel Mailing List, linuxppc-dev, ocfs2-devel, linux-mtd,
	sfr
  Cc: malat, npiggin, yamada.masahiro

Andrey Abramov <st5pub@yandex.ru> writes:
> Replace relaswap with built-in one, because relaswap
> does a simple byte to byte swap.

I replied to v1 with an ack, which stands, this is just a clarification.

> Since Spectre mitigations have made indirect function calls more
> expensive, and the default simple byte copies swap is implemented
> without them, an "optimized" custom swap function is now
> a waste of time as well as code.

Spectre mitigations don't necessarily slow down indirect function calls
on all arches or in all configurations on all arches, so that
justification is a bit dubious.

That's not really a problem for this patch, because the existing
overhead of the function call is probably already enough to rival the
cost of the 24 byte copy.

cheers

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2019-04-01 11:08 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <19606671554056883@myt3-1179f584969c.qloud-c.yandex.net>
2019-04-01  9:25 ` [PATCH v2 0/5] simple sort swap function improvements Andy Shevchenko
     [not found] ` <23051461554058370@iva6-3ac3de5fcc31.qloud-c.yandex.net>
2019-04-01  9:35   ` [PATCH v2 5/5] Lib: sort.h: replace int size with size_t size in the swap function Andy Shevchenko
2019-04-01  9:56     ` George Spelvin
2019-04-01 10:28       ` Andy Shevchenko
     [not found] ` <14019281554057359@sas1-87f9feb8d943.qloud-c.yandex.net>
2019-04-01 11:08   ` [PATCH v2 2/5] powerpc: module_[32|64].c: replace swap function with built-in one Michael Ellerman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).