linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Daniel Bristot de Oliveira <bristot@redhat.com>
Cc: linux-kernel@vger.kernel.org,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	"Steven Rostedt (VMware)" <rostedt@goodmis.org>,
	Jiri Kosina <jkosina@suse.cz>,
	Josh Poimboeuf <jpoimboe@redhat.com>,
	Chris von Recklinghausen <crecklin@redhat.com>,
	Jason Baron <jbaron@akamai.com>, Scott Wood <swood@redhat.com>,
	Marcelo Tosatti <mtosatti@redhat.com>,
	Clark Williams <williams@redhat.com>,
	x86@kernel.org
Subject: Re: [PATCH V5 1/7] jump_label: Add for_each_label_entry helper
Date: Mon, 15 Apr 2019 12:51:59 +0200	[thread overview]
Message-ID: <20190415105159.GI11158@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <708f1d88826965ef5735c372cc9a17bb80613856.1554106794.git.bristot@redhat.com>

On Mon, Apr 01, 2019 at 10:58:13AM +0200, Daniel Bristot de Oliveira wrote:
> Add a helper macro to make jump entry iteration code more readable.
> 
> Signed-off-by: Daniel Bristot de Oliveira <bristot@redhat.com>

> diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
> index 3e113a1fa0f1..7e91af98bbb1 100644
> --- a/include/linux/jump_label.h
> +++ b/include/linux/jump_label.h
> @@ -227,6 +227,9 @@ extern void static_key_disable(struct static_key *key);
>  extern void static_key_enable_cpuslocked(struct static_key *key);
>  extern void static_key_disable_cpuslocked(struct static_key *key);
>  
> +#define for_each_label_entry(key, entry, stop)				  \
> +	for (; (entry < stop) && (jump_entry_key(entry) == key); entry++)
> +

I don't really like this naming; most (all?) for_each_*() loops start
iteration and have the iteration variable as first argument.

This should maybe be called:

	for_each_jump_entry_by_key_cont(entry, stop, key)

and I realize that is a horrible name too.

  reply	other threads:[~2019-04-15 10:52 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-04-01  8:58 [PATCH V5 0/7] x86/jump_label: Bound IPIs sent when updating a static key Daniel Bristot de Oliveira
2019-04-01  8:58 ` [PATCH V5 1/7] jump_label: Add for_each_label_entry helper Daniel Bristot de Oliveira
2019-04-15 10:51   ` Peter Zijlstra [this message]
2019-04-15 11:29     ` Daniel Bristot de Oliveira
2019-04-01  8:58 ` [PATCH V5 2/7] jump_label: Add a jump_label_can_update() helper Daniel Bristot de Oliveira
2019-04-01  8:58 ` [PATCH V5 3/7] x86/jump_label: Add a __jump_label_set_jump_code() helper Daniel Bristot de Oliveira
2019-04-01  8:58 ` [PATCH V5 4/7] jump_label: Sort entries of the same key by the code Daniel Bristot de Oliveira
2019-04-15 10:55   ` Peter Zijlstra
2019-04-15 11:33     ` Daniel Bristot de Oliveira
2019-04-01  8:58 ` [PATCH V5 5/7] x86/alternative: Batch of patch operations Daniel Bristot de Oliveira
2019-04-15 11:35   ` Peter Zijlstra
2019-04-01  8:58 ` [PATCH V5 6/7] jump_label: Batch updates if arch supports it Daniel Bristot de Oliveira
2019-04-15 11:50   ` Peter Zijlstra
2019-04-01  8:58 ` [PATCH V5 7/7] x86/jump_label: Batch jump label updates Daniel Bristot de Oliveira
2019-04-15 11:54   ` Peter Zijlstra
2019-04-15 12:15     ` Daniel Bristot de Oliveira
2019-05-02 20:18     ` Daniel Bristot de Oliveira
2019-04-15  9:52 ` [PATCH V5 0/7] x86/jump_label: Bound IPIs sent when updating a static key Daniel Bristot de Oliveira

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190415105159.GI11158@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=bp@alien8.de \
    --cc=bristot@redhat.com \
    --cc=crecklin@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hpa@zytor.com \
    --cc=jbaron@akamai.com \
    --cc=jkosina@suse.cz \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhiramat@kernel.org \
    --cc=mingo@redhat.com \
    --cc=mtosatti@redhat.com \
    --cc=rostedt@goodmis.org \
    --cc=swood@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=williams@redhat.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).