linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH][next] IB/qib: Use struct_size() helper
@ 2019-05-29 15:13 Gustavo A. R. Silva
  2019-05-30 18:29 ` Dennis Dalessandro
  2019-05-30 18:43 ` Jason Gunthorpe
  0 siblings, 2 replies; 3+ messages in thread
From: Gustavo A. R. Silva @ 2019-05-29 15:13 UTC (permalink / raw)
  To: Dennis Dalessandro, Mike Marciniszyn, Doug Ledford, Jason Gunthorpe
  Cc: linux-rdma, linux-kernel, Gustavo A. R. Silva

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes, in particular in the
context in which this code is being used.

So, replace the following form:

sizeof(*pkt) + sizeof(pkt->addr[0])*n

with:

struct_size(pkt, addr, n)

Also, notice that variable size is unnecessary, hence it is removed.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 drivers/infiniband/hw/qib/qib_user_sdma.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/infiniband/hw/qib/qib_user_sdma.c b/drivers/infiniband/hw/qib/qib_user_sdma.c
index 0c204776263f..97649f64e09e 100644
--- a/drivers/infiniband/hw/qib/qib_user_sdma.c
+++ b/drivers/infiniband/hw/qib/qib_user_sdma.c
@@ -904,10 +904,11 @@ static int qib_user_sdma_queue_pkts(const struct qib_devdata *dd,
 		}
 
 		if (frag_size) {
-			int pktsize, tidsmsize, n;
+			int tidsmsize, n;
+			size_t pktsize;
 
 			n = npages*((2*PAGE_SIZE/frag_size)+1);
-			pktsize = sizeof(*pkt) + sizeof(pkt->addr[0])*n;
+			pktsize = struct_size(pkt, addr, n);
 
 			/*
 			 * Determine if this is tid-sdma or just sdma.
-- 
2.21.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] IB/qib: Use struct_size() helper
  2019-05-29 15:13 [PATCH][next] IB/qib: Use struct_size() helper Gustavo A. R. Silva
@ 2019-05-30 18:29 ` Dennis Dalessandro
  2019-05-30 18:43 ` Jason Gunthorpe
  1 sibling, 0 replies; 3+ messages in thread
From: Dennis Dalessandro @ 2019-05-30 18:29 UTC (permalink / raw)
  To: Gustavo A. R. Silva, Mike Marciniszyn, Doug Ledford, Jason Gunthorpe
  Cc: linux-rdma, linux-kernel

On 5/29/2019 11:13 AM, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
> 
> So, replace the following form:
> 
> sizeof(*pkt) + sizeof(pkt->addr[0])*n
> 
> with:
> 
> struct_size(pkt, addr, n)
> 
> Also, notice that variable size is unnecessary, hence it is removed.
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
> ---
>   drivers/infiniband/hw/qib/qib_user_sdma.c | 5 +++--
>   1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/infiniband/hw/qib/qib_user_sdma.c b/drivers/infiniband/hw/qib/qib_user_sdma.c
> index 0c204776263f..97649f64e09e 100644
> --- a/drivers/infiniband/hw/qib/qib_user_sdma.c
> +++ b/drivers/infiniband/hw/qib/qib_user_sdma.c
> @@ -904,10 +904,11 @@ static int qib_user_sdma_queue_pkts(const struct qib_devdata *dd,
>   		}
>   
>   		if (frag_size) {
> -			int pktsize, tidsmsize, n;
> +			int tidsmsize, n;
> +			size_t pktsize;
>   
>   			n = npages*((2*PAGE_SIZE/frag_size)+1);
> -			pktsize = sizeof(*pkt) + sizeof(pkt->addr[0])*n;
> +			pktsize = struct_size(pkt, addr, n);
>   
>   			/*
>   			 * Determine if this is tid-sdma or just sdma.
> 

Again, same minor objection but correct patch none the less.

Reviewed-by: Dennis Dalessandro <dennis.dalessandro@intel.com>

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] IB/qib: Use struct_size() helper
  2019-05-29 15:13 [PATCH][next] IB/qib: Use struct_size() helper Gustavo A. R. Silva
  2019-05-30 18:29 ` Dennis Dalessandro
@ 2019-05-30 18:43 ` Jason Gunthorpe
  1 sibling, 0 replies; 3+ messages in thread
From: Jason Gunthorpe @ 2019-05-30 18:43 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Dennis Dalessandro, Mike Marciniszyn, Doug Ledford, linux-rdma,
	linux-kernel

On Wed, May 29, 2019 at 10:13:26AM -0500, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
> 
> So, replace the following form:
> 
> sizeof(*pkt) + sizeof(pkt->addr[0])*n
> 
> with:
> 
> struct_size(pkt, addr, n)
> 
> Also, notice that variable size is unnecessary, hence it is removed.
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
> Reviewed-by: Dennis Dalessandro <dennis.dalessandro@intel.com>
> ---
>  drivers/infiniband/hw/qib/qib_user_sdma.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Applied to for-next, thanks

Jason

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-05-30 18:43 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-05-29 15:13 [PATCH][next] IB/qib: Use struct_size() helper Gustavo A. R. Silva
2019-05-30 18:29 ` Dennis Dalessandro
2019-05-30 18:43 ` Jason Gunthorpe

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).