linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] Revert "ASoC: core: use component driver name as component name"
@ 2019-05-31 10:34 Krzysztof Kozlowski
  2019-06-03 15:27 ` Mark Brown
  2019-06-03 18:02 ` Applied "Revert "ASoC: core: use component driver name as component name"" to the asoc tree Mark Brown
  0 siblings, 2 replies; 3+ messages in thread
From: Krzysztof Kozlowski @ 2019-05-31 10:34 UTC (permalink / raw)
  To: Liam Girdwood, Mark Brown, Jaroslav Kysela, Takashi Iwai,
	alsa-devel, linux-kernel
  Cc: Tzung-Bi Shih, Sylwester Nawrocki, Krzysztof Kozlowski

Using component driver as a name is not unique and it breaks audio in
certain configurations, e.g. Hardkernel Odroid XU3 board where following
components are registered:
 - "3830000.i2s" with driver name "snd_dmaengine_pcm"
 - "3830000.i2s-sec" with driver name "snd_dmaengine_pcm"
 - "3830000.i2s" with driver name "samsung-i2s"

This reverts commit b19671d6caf1ac393681864d5d85dda9fa99a448.

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>

---

Changes since v1:
1. Fix driver name in commit msg.
---
 sound/soc/soc-core.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 2d3520fca613..7abb017a83f3 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -3113,10 +3113,7 @@ static int snd_soc_component_initialize(struct snd_soc_component *component,
 {
 	struct snd_soc_dapm_context *dapm;
 
-	if (driver->name)
-		component->name = kstrdup(driver->name, GFP_KERNEL);
-	else
-		component->name = fmt_single_name(dev, &component->id);
+	component->name = fmt_single_name(dev, &component->id);
 	if (!component->name) {
 		dev_err(dev, "ASoC: Failed to allocate name\n");
 		return -ENOMEM;
-- 
2.7.4


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] Revert "ASoC: core: use component driver name as component name"
  2019-05-31 10:34 [PATCH v2] Revert "ASoC: core: use component driver name as component name" Krzysztof Kozlowski
@ 2019-06-03 15:27 ` Mark Brown
  2019-06-03 18:02 ` Applied "Revert "ASoC: core: use component driver name as component name"" to the asoc tree Mark Brown
  1 sibling, 0 replies; 3+ messages in thread
From: Mark Brown @ 2019-06-03 15:27 UTC (permalink / raw)
  To: Krzysztof Kozlowski
  Cc: Liam Girdwood, Jaroslav Kysela, Takashi Iwai, alsa-devel,
	linux-kernel, Tzung-Bi Shih, Sylwester Nawrocki

[-- Attachment #1: Type: text/plain, Size: 372 bytes --]

On Fri, May 31, 2019 at 12:34:02PM +0200, Krzysztof Kozlowski wrote:
> Using component driver as a name is not unique and it breaks audio in
> certain configurations, e.g. Hardkernel Odroid XU3 board where following
> components are registered:

Please use subject lines matching the style for the subsystem.  This
makes it easier for people to identify relevant patches.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Applied "Revert "ASoC: core: use component driver name as component name"" to the asoc tree
  2019-05-31 10:34 [PATCH v2] Revert "ASoC: core: use component driver name as component name" Krzysztof Kozlowski
  2019-06-03 15:27 ` Mark Brown
@ 2019-06-03 18:02 ` Mark Brown
  1 sibling, 0 replies; 3+ messages in thread
From: Mark Brown @ 2019-06-03 18:02 UTC (permalink / raw)
  To: Krzysztof Kozlowski
  Cc: alsa-devel, Jaroslav Kysela, Liam Girdwood, linux-kernel,
	Mark Brown, Sylwester Nawrocki, Takashi Iwai, Tzung-Bi Shih

The patch

   Revert "ASoC: core: use component driver name as component name"

has been applied to the asoc tree at

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-5.3

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.  

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

From 9d563eb95b81f32b9ffa4255033717484d50d06b Mon Sep 17 00:00:00 2001
From: Krzysztof Kozlowski <krzk@kernel.org>
Date: Fri, 31 May 2019 12:34:02 +0200
Subject: [PATCH] Revert "ASoC: core: use component driver name as component
 name"

Using component driver as a name is not unique and it breaks audio in
certain configurations, e.g. Hardkernel Odroid XU3 board where following
components are registered:
 - "3830000.i2s" with driver name "snd_dmaengine_pcm"
 - "3830000.i2s-sec" with driver name "snd_dmaengine_pcm"
 - "3830000.i2s" with driver name "samsung-i2s"

This reverts commit b19671d6caf1ac393681864d5d85dda9fa99a448.

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
 sound/soc/soc-core.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 2d3520fca613..7abb017a83f3 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -3113,10 +3113,7 @@ static int snd_soc_component_initialize(struct snd_soc_component *component,
 {
 	struct snd_soc_dapm_context *dapm;
 
-	if (driver->name)
-		component->name = kstrdup(driver->name, GFP_KERNEL);
-	else
-		component->name = fmt_single_name(dev, &component->id);
+	component->name = fmt_single_name(dev, &component->id);
 	if (!component->name) {
 		dev_err(dev, "ASoC: Failed to allocate name\n");
 		return -ENOMEM;
-- 
2.20.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-06-03 18:02 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-05-31 10:34 [PATCH v2] Revert "ASoC: core: use component driver name as component name" Krzysztof Kozlowski
2019-06-03 15:27 ` Mark Brown
2019-06-03 18:02 ` Applied "Revert "ASoC: core: use component driver name as component name"" to the asoc tree Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).