linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] PCI/ACPI: Rename _HPP to _HPX and move of ACPI-specific code from probe.c
@ 2019-08-27  9:49 Krzysztof Wilczynski
  2019-08-27  9:49 ` [PATCH 1/3] PCI/ACPI: Rename ACPI Hot Plug structs for Type 0, 1 and 2 from _HPP to _HPX Krzysztof Wilczynski
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: Krzysztof Wilczynski @ 2019-08-27  9:49 UTC (permalink / raw)
  To: Bjorn Helgaas
  Cc: Rafael J. Wysocki, Len Brown, linux-pci, linux-acpi, linux-kernel

This series of patches moves the ACPI-specific code currently included
as part of the drivers/pci/probe.c. First, the ACPI Hot Plug structs
for Type 0, 1 and 2, and any relevant variable names, structs, function
names, etc., will have their names changed to reflect that these are
related to _HPX rather than _HPP.  Second, all of the ACPI-specific
code will be moved to drivers/pci/pci-acpi.c for better organisation
and to keep ACPI-related code base together.  Third, remove the
now obsolete struct hotplug_program_ops from drivers/pci/pci-acpi.c.

Patches should be preferably merged in order as they build upon
one-another.

Related:
  https://lore.kernel.org/lkml/20190419220220.GI173520@google.com
  https://lore.kernel.org/lkml/20190307213834.5914-3-mr.nuke.me@gmail.com
  https://lore.kernel.org/lkml/20190307213834.5914-2-mr.nuke.me@gmail.com

Krzysztof Wilczynski (3):
  PCI/ACPI: Rename ACPI Hot Plug structs for Type 0, 1 and 2 from _HPP
    to _HPX
  PCI/ACPI: Move ACPI-specific Hot Plug programming functions to
    pci-acpi.c
  PCI/ACPI: Remove unnecessary struct hotplug_program_ops from
    pci-acpi.c

 drivers/pci/pci-acpi.c      | 410 +++++++++++++++++++++++++++++++++---
 drivers/pci/pci.h           |   9 +
 drivers/pci/probe.c         | 278 +-----------------------
 include/linux/pci_hotplug.h | 100 ---------
 4 files changed, 389 insertions(+), 408 deletions(-)

-- 
2.22.1


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2019-08-28 20:34 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-08-27  9:49 [PATCH 0/3] PCI/ACPI: Rename _HPP to _HPX and move of ACPI-specific code from probe.c Krzysztof Wilczynski
2019-08-27  9:49 ` [PATCH 1/3] PCI/ACPI: Rename ACPI Hot Plug structs for Type 0, 1 and 2 from _HPP to _HPX Krzysztof Wilczynski
2019-08-27  9:49 ` [PATCH 2/3] PCI/ACPI: Move ACPI-specific Hot Plug programming functions to pci-acpi.c Krzysztof Wilczynski
2019-08-27  9:49 ` [PATCH 3/3] PCI/ACPI: Remove unnecessary struct hotplug_program_ops from pci-acpi.c Krzysztof Wilczynski
2019-08-28 20:33 ` [PATCH 0/3] PCI/ACPI: Rename _HPP to _HPX and move of ACPI-specific code from probe.c Bjorn Helgaas

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).