linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Vinod Koul <vkoul@kernel.org>
To: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Cc: alsa-devel@alsa-project.org, tiwai@suse.de,
	gregkh@linuxfoundation.org, linux-kernel@vger.kernel.org,
	Ranjani Sridharan <ranjani.sridharan@linux.intel.com>,
	broonie@kernel.org, srinivas.kandagatla@linaro.org,
	jank@cadence.com, slawomir.blauciak@intel.com,
	Sanyog Kale <sanyog.r.kale@intel.com>,
	Bard liao <yung-chuan.liao@linux.intel.com>,
	Rander Wang <rander.wang@linux.intel.com>
Subject: Re: [alsa-devel] [PATCH 07/14] soundwire: add initial definitions for sdw_master_device
Date: Fri, 8 Nov 2019 09:34:27 +0530	[thread overview]
Message-ID: <20191108040427.GT952516@vkoul-mobl> (raw)
In-Reply-To: <9a8fb9ec-1ccb-4931-1ec6-bfae043e8c88@linux.intel.com>

On 04-11-19, 08:42, Pierre-Louis Bossart wrote:
> 
> 
> On 11/3/19 1:30 AM, Vinod Koul wrote:
> > On 23-10-19, 16:28, Pierre-Louis Bossart wrote:
> > > Since we want an explicit support for the SoundWire Master device, add
> > > the definitions, following the Grey Bus example.
> > > 
> > > Open: do we need to set a variable when dealing with the master uevent?
> > 
> > I dont think we want that or we need that!
> 
> In GreyBus there are events and variables set, not sure what they were used
> for. The code works without setting an event, but we'd need to make a
> conscious design decision, and I am not too sure what usersace would use the
> informatio for.
> 
> > 
> > And to prevent that rather than adding a variable, can you please
> > modify the device_type and use separate ones for master_device and
> > slave_device
> 
> sorry, I don't get the comment. There is only already a different device
> type
> 
> 
> struct bus_type sdw_bus_type = {
> 	.name = "soundwire",
> 	.match = sdw_bus_match,
> 	.uevent = sdw_uevent,

We can remove this

> };
> 
> struct device_type sdw_slave_type = {
> 	.name =		"sdw_slave",
> 	.release =	sdw_slave_release,

Add here:

        uevent = sdw_uevent,

> };
> 
> struct device_type sdw_md_type = {
> 	.name =		"soundwire_master",
> 	.release =	sdw_md_release,
> };

And not have here!

Problem solved!

-- 
~Vinod

  reply	other threads:[~2019-11-08  4:04 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-23 21:28 [PATCH 00/14] soundwire: intel: implement new ASoC interfaces Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 01/14] soundwire: renames to prepare support for master drivers/devices Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 02/14] soundwire: rename dev_to_sdw_dev macro Pierre-Louis Bossart
2019-11-03  5:28   ` Vinod Koul
2019-10-23 21:28 ` [PATCH 03/14] soundwire: rename drv_to_sdw_slave_driver macro Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 04/14] soundwire: bus_type: rename sdw_drv_ to sdw_slave_drv Pierre-Louis Bossart
2019-11-03  5:30   ` Vinod Koul
2019-11-04 14:34     ` [alsa-devel] " Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 05/14] soundwire: intel: rename res field as link_res Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 06/14] soundwire: add support for sdw_slave_type Pierre-Louis Bossart
2019-11-03  5:32   ` Vinod Koul
2019-11-04 14:35     ` [alsa-devel] " Pierre-Louis Bossart
2019-11-04 19:33   ` Cezary Rojewski
2019-11-04 19:41     ` [alsa-devel] " Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 07/14] soundwire: add initial definitions for sdw_master_device Pierre-Louis Bossart
2019-11-03  6:30   ` Vinod Koul
2019-11-04 14:42     ` [alsa-devel] " Pierre-Louis Bossart
2019-11-08  4:04       ` Vinod Koul [this message]
2019-11-08 14:41         ` Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 08/14] soundwire: intel: remove platform devices and provide new interface Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 09/14] soundwire: add device driver to sdw_md_driver Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 10/14] soundwire: intel: add prepare support in sdw dai driver Pierre-Louis Bossart
2019-11-04 19:45   ` Cezary Rojewski
2019-11-04 21:31     ` Pierre-Louis Bossart
2019-11-08  4:05       ` Vinod Koul
2019-10-23 21:28 ` [PATCH 11/14] soundwire: intel: add trigger " Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 12/14] soundwire: intel: add sdw_stream_setup helper for .startup callback Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 13/14] soundwire: intel: free all resources on hw_free() Pierre-Louis Bossart
2019-11-04 20:08   ` Cezary Rojewski
2019-11-04 21:46     ` [alsa-devel] " Pierre-Louis Bossart
2019-11-08  4:14       ` Vinod Koul
2019-11-08 14:39         ` Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 14/14] soundwire: intel_init: add implementation of sdw_intel_enable_irq() Pierre-Louis Bossart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191108040427.GT952516@vkoul-mobl \
    --to=vkoul@kernel.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jank@cadence.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=rander.wang@linux.intel.com \
    --cc=ranjani.sridharan@linux.intel.com \
    --cc=sanyog.r.kale@intel.com \
    --cc=slawomir.blauciak@intel.com \
    --cc=srinivas.kandagatla@linaro.org \
    --cc=tiwai@suse.de \
    --cc=yung-chuan.liao@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).