linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/2] staging: vt6656: Refactor the vnt_get_phy_field function
@ 2020-04-11 12:26 Oscar Carter
  2020-04-11 12:26 ` [PATCH v2 1/2] staging: vt6656: Refactor the assignment of the phy->signal variable Oscar Carter
  2020-04-11 12:26 ` [PATCH v2 2/2] staging: vt6656: Remove duplicate code for the phy->service assignment Oscar Carter
  0 siblings, 2 replies; 7+ messages in thread
From: Oscar Carter @ 2020-04-11 12:26 UTC (permalink / raw)
  To: Forest Bond, Greg Kroah-Hartman
  Cc: Oscar Carter, Malcolm Priestley, Quentin Deslandes,
	Amir Mahdi Ghorbanian, devel, linux-kernel

This patch series makes a refactor of the vnt_get_phy_field function
through two patches.

The first one refactors the assignment of the "phy->signal" variable
using a constant array with the correct values for every rate.

The second patch removes duplicate code for the assignment of the
"phy->service" variable by putting it outside the if-else statement due
to it's the same for the two branches.

Changelog v1 -> v2:
- Remove one dimension from the constant array for the "phy->signal"
  values and use an OR mask instead of the second array dimension as
  Malcolm Priestley has suggested.

Oscar Carter (2):
  staging: vt6656: Refactor the assignment of the phy->signal variable
  staging: vt6656: Remove duplicate code for the phy->service assignment

 drivers/staging/vt6656/baseband.c | 108 ++++++++----------------------
 1 file changed, 27 insertions(+), 81 deletions(-)

--
2.20.1


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-04-13 14:43 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-11 12:26 [PATCH v2 0/2] staging: vt6656: Refactor the vnt_get_phy_field function Oscar Carter
2020-04-11 12:26 ` [PATCH v2 1/2] staging: vt6656: Refactor the assignment of the phy->signal variable Oscar Carter
2020-04-13 12:56   ` Greg Kroah-Hartman
2020-04-13 14:25     ` Oscar Carter
2020-04-13 14:32       ` Greg Kroah-Hartman
2020-04-13 14:43         ` Oscar Carter
2020-04-11 12:26 ` [PATCH v2 2/2] staging: vt6656: Remove duplicate code for the phy->service assignment Oscar Carter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).