linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/5] devres: provide and use devm_krealloc()
@ 2020-06-26 16:55 Bartosz Golaszewski
  2020-06-26 16:55 ` [PATCH 1/5] devres: remove stray space from devm_kmalloc() definition Bartosz Golaszewski
                   ` (4 more replies)
  0 siblings, 5 replies; 7+ messages in thread
From: Bartosz Golaszewski @ 2020-06-26 16:55 UTC (permalink / raw)
  To: Jonathan Corbet, Greg Kroah-Hartman, Rafael J . Wysocki,
	Guenter Roeck, Jean Delvare
  Cc: linux-doc, linux-kernel, linux-hwmon, Bartosz Golaszewski

From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

Regular krealloc() obviously can't work with managed memory. This series
implements devm_krealloc() and adds the first user with hope that this
helper will be adopted by other drivers currently using non-managed
krealloc().

Some cosmetic changes to the code modified by main patches are included.

Bartosz Golaszewski (5):
  devres: remove stray space from devm_kmalloc() definition
  devres: move the size check from alloc_dr() into a separate function
  device: remove 'extern' attribute from function prototypes in device.h
  devres: provide devm_krealloc()
  hwmon: pmbus: use more devres helpers

 .../driver-api/driver-model/devres.rst        |   1 +
 drivers/base/devres.c                         |  58 ++++-
 drivers/hwmon/pmbus/pmbus_core.c              |  27 +--
 include/linux/device.h                        | 225 +++++++++---------
 4 files changed, 173 insertions(+), 138 deletions(-)

-- 
2.26.1


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-06-26 21:50 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-26 16:55 [PATCH 0/5] devres: provide and use devm_krealloc() Bartosz Golaszewski
2020-06-26 16:55 ` [PATCH 1/5] devres: remove stray space from devm_kmalloc() definition Bartosz Golaszewski
2020-06-26 16:55 ` [PATCH 2/5] devres: move the size check from alloc_dr() into a separate function Bartosz Golaszewski
2020-06-26 16:55 ` [PATCH 3/5] device: remove 'extern' attribute from function prototypes in device.h Bartosz Golaszewski
2020-06-26 16:55 ` [PATCH 4/5] devres: provide devm_krealloc() Bartosz Golaszewski
2020-06-26 16:55 ` [PATCH 5/5] hwmon: pmbus: use more devres helpers Bartosz Golaszewski
2020-06-26 21:50   ` Guenter Roeck

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).