linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] arm: dts: imx7: add QSPI
@ 2020-07-29  7:11 Matthias Schiffer
  2020-07-29  7:14 ` Matthias Schiffer
  0 siblings, 1 reply; 4+ messages in thread
From: Matthias Schiffer @ 2020-07-29  7:11 UTC (permalink / raw)
  To: Shawn Guo, Sascha Hauer
  Cc: Pengutronix Kernel Team, Fabio Estevam, NXP Linux Team,
	linux-arm-kernel, linux-kernel, Matthias Schiffer

In preparation for an update of the TQ-Systems TQMa7x/MBa7x DTS, add the
QSPI controller to imx7s.dtsi.

Based-on-patch-by: Han Xu <han.xu@nxp.com>
Signed-off-by: Matthias Schiffer <matthias.schiffer@ew.tq-group.com>
---

v2:
- renamed node and label
- reordered properties
(as suggested by Marco Felsch)


 arch/arm/boot/dts/imx7s.dtsi | 13 +++++++++++++
 1 file changed, 13 insertions(+)

diff --git a/arch/arm/boot/dts/imx7s.dtsi b/arch/arm/boot/dts/imx7s.dtsi
index 1cfaf410aa43..22e4c38223bd 100644
--- a/arch/arm/boot/dts/imx7s.dtsi
+++ b/arch/arm/boot/dts/imx7s.dtsi
@@ -1162,6 +1162,19 @@
 				status = "disabled";
 			};
 
+			qspi: qspi@30bb0000 {
+				compatible = "fsl,imx7d-qspi";
+				reg = <0x30bb0000 0x10000>, <0x60000000 0x10000000>;
+				reg-names = "QuadSPI", "QuadSPI-memory";
+				#address-cells = <1>;
+				#size-cells = <0>;
+				interrupts = <GIC_SPI 107 IRQ_TYPE_LEVEL_HIGH>;
+				clocks = <&clks IMX7D_QSPI_ROOT_CLK>,
+					<&clks IMX7D_QSPI_ROOT_CLK>;
+				clock-names = "qspi_en", "qspi";
+				status = "disabled";
+			};
+
 			sdma: sdma@30bd0000 {
 				compatible = "fsl,imx7d-sdma", "fsl,imx35-sdma";
 				reg = <0x30bd0000 0x10000>;
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] arm: dts: imx7: add QSPI
  2020-07-29  7:11 [PATCH v2] arm: dts: imx7: add QSPI Matthias Schiffer
@ 2020-07-29  7:14 ` Matthias Schiffer
  2020-07-29  7:58   ` Marco Felsch
  0 siblings, 1 reply; 4+ messages in thread
From: Matthias Schiffer @ 2020-07-29  7:14 UTC (permalink / raw)
  To: Marco Felsch
  Cc: Pengutronix Kernel Team, Fabio Estevam, NXP Linux Team,
	linux-arm-kernel, linux-kernel, Shawn Guo, Sascha Hauer

On Wed, 2020-07-29 at 09:11 +0200, Matthias Schiffer wrote:
> In preparation for an update of the TQ-Systems TQMa7x/MBa7x DTS, add
> the
> QSPI controller to imx7s.dtsi.
> 
> Based-on-patch-by: Han Xu <han.xu@nxp.com>
> Signed-off-by: Matthias Schiffer <matthias.schiffer@ew.tq-group.com>
> ---
> 
> v2:
> - renamed node and label
> - reordered properties
> (as suggested by Marco Felsch)

Ugh, I neglected to check for compile warnings after adjusting the node
name. This now gives the following warning:

arch/arm/boot/dts/imx7s.dtsi:1165.24-1176.6: Warning (spi_bus_bridge): 
/soc/bus@30800000/qspi@30bb0000: node name for SPI buses should be
'spi'

So I guess this should be called spi@ after all?


> 
> 
>  arch/arm/boot/dts/imx7s.dtsi | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
> 
> diff --git a/arch/arm/boot/dts/imx7s.dtsi
> b/arch/arm/boot/dts/imx7s.dtsi
> index 1cfaf410aa43..22e4c38223bd 100644
> --- a/arch/arm/boot/dts/imx7s.dtsi
> +++ b/arch/arm/boot/dts/imx7s.dtsi
> @@ -1162,6 +1162,19 @@
>  				status = "disabled";
>  			};
>  
> +			qspi: qspi@30bb0000 {
> +				compatible = "fsl,imx7d-qspi";
> +				reg = <0x30bb0000 0x10000>, <0x60000000
> 0x10000000>;
> +				reg-names = "QuadSPI", "QuadSPI-
> memory";
> +				#address-cells = <1>;
> +				#size-cells = <0>;
> +				interrupts = <GIC_SPI 107
> IRQ_TYPE_LEVEL_HIGH>;
> +				clocks = <&clks IMX7D_QSPI_ROOT_CLK>,
> +					<&clks IMX7D_QSPI_ROOT_CLK>;
> +				clock-names = "qspi_en", "qspi";
> +				status = "disabled";
> +			};
> +
>  			sdma: sdma@30bd0000 {
>  				compatible = "fsl,imx7d-sdma",
> "fsl,imx35-sdma";
>  				reg = <0x30bd0000 0x10000>;


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] arm: dts: imx7: add QSPI
  2020-07-29  7:14 ` Matthias Schiffer
@ 2020-07-29  7:58   ` Marco Felsch
  2020-07-29  8:39     ` Marco Felsch
  0 siblings, 1 reply; 4+ messages in thread
From: Marco Felsch @ 2020-07-29  7:58 UTC (permalink / raw)
  To: Matthias Schiffer
  Cc: Pengutronix Kernel Team, Fabio Estevam, NXP Linux Team,
	linux-arm-kernel, linux-kernel, Shawn Guo, Sascha Hauer

Hi Matthias,

On 20-07-29 09:14, Matthias Schiffer wrote:
> On Wed, 2020-07-29 at 09:11 +0200, Matthias Schiffer wrote:
> > In preparation for an update of the TQ-Systems TQMa7x/MBa7x DTS, add
> > the
> > QSPI controller to imx7s.dtsi.
> > 
> > Based-on-patch-by: Han Xu <han.xu@nxp.com>
> > Signed-off-by: Matthias Schiffer <matthias.schiffer@ew.tq-group.com>
> > ---
> > 
> > v2:
> > - renamed node and label
> > - reordered properties
> > (as suggested by Marco Felsch)
> 
> Ugh, I neglected to check for compile warnings after adjusting the node
> name. This now gives the following warning:
> 
> arch/arm/boot/dts/imx7s.dtsi:1165.24-1176.6: Warning (spi_bus_bridge): 
> /soc/bus@30800000/qspi@30bb0000: node name for SPI buses should be
> 'spi'
> 
> So I guess this should be called spi@ after all?

Unfortunately yes, this would cause a longer discussion but it still
seems wrong to me.

Regards,
  Marco

> > 
> > 
> >  arch/arm/boot/dts/imx7s.dtsi | 13 +++++++++++++
> >  1 file changed, 13 insertions(+)
> > 
> > diff --git a/arch/arm/boot/dts/imx7s.dtsi
> > b/arch/arm/boot/dts/imx7s.dtsi
> > index 1cfaf410aa43..22e4c38223bd 100644
> > --- a/arch/arm/boot/dts/imx7s.dtsi
> > +++ b/arch/arm/boot/dts/imx7s.dtsi
> > @@ -1162,6 +1162,19 @@
> >  				status = "disabled";
> >  			};
> >  
> > +			qspi: qspi@30bb0000 {
> > +				compatible = "fsl,imx7d-qspi";
> > +				reg = <0x30bb0000 0x10000>, <0x60000000
> > 0x10000000>;
> > +				reg-names = "QuadSPI", "QuadSPI-
> > memory";
> > +				#address-cells = <1>;
> > +				#size-cells = <0>;
> > +				interrupts = <GIC_SPI 107
> > IRQ_TYPE_LEVEL_HIGH>;
> > +				clocks = <&clks IMX7D_QSPI_ROOT_CLK>,
> > +					<&clks IMX7D_QSPI_ROOT_CLK>;
> > +				clock-names = "qspi_en", "qspi";
> > +				status = "disabled";
> > +			};
> > +
> >  			sdma: sdma@30bd0000 {
> >  				compatible = "fsl,imx7d-sdma",
> > "fsl,imx35-sdma";
> >  				reg = <0x30bd0000 0x10000>;
> 
> 

-- 
Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] arm: dts: imx7: add QSPI
  2020-07-29  7:58   ` Marco Felsch
@ 2020-07-29  8:39     ` Marco Felsch
  0 siblings, 0 replies; 4+ messages in thread
From: Marco Felsch @ 2020-07-29  8:39 UTC (permalink / raw)
  To: robh+dt, frowand.list
  Cc: Matthias Schiffer, Fabio Estevam, Sascha Hauer, linux-kernel,
	NXP Linux Team, Pengutronix Kernel Team, Shawn Guo,
	linux-arm-kernel

Added Rob and Frank.

Maybe they can explain us this behaviour.

On 20-07-29 09:58, Marco Felsch wrote:
> Hi Matthias,
> 
> On 20-07-29 09:14, Matthias Schiffer wrote:
> > On Wed, 2020-07-29 at 09:11 +0200, Matthias Schiffer wrote:
> > > In preparation for an update of the TQ-Systems TQMa7x/MBa7x DTS, add
> > > the
> > > QSPI controller to imx7s.dtsi.
> > > 
> > > Based-on-patch-by: Han Xu <han.xu@nxp.com>
> > > Signed-off-by: Matthias Schiffer <matthias.schiffer@ew.tq-group.com>
> > > ---
> > > 
> > > v2:
> > > - renamed node and label
> > > - reordered properties
> > > (as suggested by Marco Felsch)
> > 
> > Ugh, I neglected to check for compile warnings after adjusting the node
> > name. This now gives the following warning:
> > 
> > arch/arm/boot/dts/imx7s.dtsi:1165.24-1176.6: Warning (spi_bus_bridge): 
> > /soc/bus@30800000/qspi@30bb0000: node name for SPI buses should be
> > 'spi'
> > 
> > So I guess this should be called spi@ after all?
> 
> Unfortunately yes, this would cause a longer discussion but it still
> seems wrong to me.
> 
> Regards,
>   Marco
> 
> > > 
> > > 
> > >  arch/arm/boot/dts/imx7s.dtsi | 13 +++++++++++++
> > >  1 file changed, 13 insertions(+)
> > > 
> > > diff --git a/arch/arm/boot/dts/imx7s.dtsi
> > > b/arch/arm/boot/dts/imx7s.dtsi
> > > index 1cfaf410aa43..22e4c38223bd 100644
> > > --- a/arch/arm/boot/dts/imx7s.dtsi
> > > +++ b/arch/arm/boot/dts/imx7s.dtsi
> > > @@ -1162,6 +1162,19 @@
> > >  				status = "disabled";
> > >  			};
> > >  
> > > +			qspi: qspi@30bb0000 {
> > > +				compatible = "fsl,imx7d-qspi";
> > > +				reg = <0x30bb0000 0x10000>, <0x60000000
> > > 0x10000000>;
> > > +				reg-names = "QuadSPI", "QuadSPI-
> > > memory";
> > > +				#address-cells = <1>;
> > > +				#size-cells = <0>;
> > > +				interrupts = <GIC_SPI 107
> > > IRQ_TYPE_LEVEL_HIGH>;
> > > +				clocks = <&clks IMX7D_QSPI_ROOT_CLK>,
> > > +					<&clks IMX7D_QSPI_ROOT_CLK>;
> > > +				clock-names = "qspi_en", "qspi";
> > > +				status = "disabled";
> > > +			};
> > > +
> > >  			sdma: sdma@30bd0000 {
> > >  				compatible = "fsl,imx7d-sdma",
> > > "fsl,imx35-sdma";
> > >  				reg = <0x30bd0000 0x10000>;
> > 
> > 
> 
> -- 
> Pengutronix e.K.                           |                             |
> Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
> 31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
> Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |
> 
> 

-- 
Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-07-29  8:39 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-29  7:11 [PATCH v2] arm: dts: imx7: add QSPI Matthias Schiffer
2020-07-29  7:14 ` Matthias Schiffer
2020-07-29  7:58   ` Marco Felsch
2020-07-29  8:39     ` Marco Felsch

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).