linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH net-next v2 0/3] net: ptp: use common defines for PTP message types in further drivers
@ 2020-11-24  7:44 Christian Eggers
  2020-11-24  7:44 ` [PATCH net-next v2 1/3] net: phy: dp83640: use new PTP_MSGTYPE_SYNC define Christian Eggers
                   ` (4 more replies)
  0 siblings, 5 replies; 7+ messages in thread
From: Christian Eggers @ 2020-11-24  7:44 UTC (permalink / raw)
  To: Richard Cochran, Andrew Lunn, Heiner Kallweit, Jakub Kicinski
  Cc: Vladimir Oltean, Russell King, David S . Miller, netdev,
	linux-kernel, Christian Eggers

Changes in v2:
----------------
- resend, as v1 was sent before the prerequisites were merged
- removed mismatch between From: and Signed-off-by:
- [2/3] Reviewed-by: Ido Schimmel <idosch@nvidia.com>
- [3/3] Reviewed-by: Antoine Tenart <atenart@kernel.org>
- [3/3] removed dead email addresses from Cc:


This series replaces further driver internal enumeration / uses of magic
numbers with the newly introduced PTP_MSGTYPE_* defines.

On Friday, 20 November 2020, 23:39:10 CET, Vladimir Oltean wrote:
> On Fri, Nov 20, 2020 at 09:41:03AM +0100, Christian Eggers wrote:
> > This series introduces commen defines for PTP event messages. Driver
> > internal defines are removed and some uses of magic numbers are replaced
> > by the new defines.
> > [...]
> 
> I understand that you don't want to spend a lifetime on this, but I see
> that there are more drivers which you did not touch.
> 
> is_sync() in drivers/net/phy/dp83640.c can be made to
> 	return ptp_get_msgtype(hdr, type) == PTP_MSGTYPE_SYNC;
> 
> this can be removed from drivers/net/ethernet/mellanox/mlxsw/spectrum_ptp.h:
> enum {
> 	MLXSW_SP_PTP_MESSAGE_TYPE_SYNC,
> 	MLXSW_SP_PTP_MESSAGE_TYPE_DELAY_REQ,
> 	MLXSW_SP_PTP_MESSAGE_TYPE_PDELAY_REQ,
> 	MLXSW_SP_PTP_MESSAGE_TYPE_PDELAY_RESP,
> };
I think that I have found an addtional one in the Microsemi VSC85xx PHY driver.





^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-11-25 20:25 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-24  7:44 [PATCH net-next v2 0/3] net: ptp: use common defines for PTP message types in further drivers Christian Eggers
2020-11-24  7:44 ` [PATCH net-next v2 1/3] net: phy: dp83640: use new PTP_MSGTYPE_SYNC define Christian Eggers
2020-11-24  8:00   ` Kurt Kanzenbach
2020-11-24  7:44 ` [PATCH net-next v2 2/3] mlxsw: spectrum_ptp: use PTP wide message type definitions Christian Eggers
2020-11-24  7:44 ` [PATCH net-next v2 3/3] net: phy: mscc: use new PTP_MSGTYPE_* defines Christian Eggers
2020-11-24 13:39 ` [PATCH net-next v2 0/3] net: ptp: use common defines for PTP message types in further drivers Richard Cochran
2020-11-25 20:24 ` Jakub Kicinski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).