linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/2] docs: Make syscalls' helpers naming consistent
@ 2021-01-30  1:45 André Almeida
  2021-01-30  1:45 ` [PATCH 2/2] Documentation: admin-guide: Update kvm/xen config option André Almeida
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: André Almeida @ 2021-01-30  1:45 UTC (permalink / raw)
  To: corbet; +Cc: linux-doc, linux-kernel, André Almeida, Dominik Brodowski

The documentation explains the need to create internal syscalls' helpers,
and that they should be called `kern_xyzzy()`. However, the comment at
include/linux/syscall.h says that they should be named as
`ksys_xyzzy()`, and so are all the helpers declared bellow it. Change the
documentation to reflect this.

Cc: Dominik Brodowski <linux@dominikbrodowski.net>
Fixes: 819671ff849b ("syscalls: define and explain goal to not call syscalls in the kernel")
Signed-off-by: André Almeida <andrealmeid@collabora.com>
---
 Documentation/process/adding-syscalls.rst | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Documentation/process/adding-syscalls.rst b/Documentation/process/adding-syscalls.rst
index a3ecb236576c..61bdaec188ea 100644
--- a/Documentation/process/adding-syscalls.rst
+++ b/Documentation/process/adding-syscalls.rst
@@ -501,7 +501,7 @@ table, but not from elsewhere in the kernel.  If the syscall functionality is
 useful to be used within the kernel, needs to be shared between an old and a
 new syscall, or needs to be shared between a syscall and its compatibility
 variant, it should be implemented by means of a "helper" function (such as
-``kern_xyzzy()``).  This kernel function may then be called within the
+``ksys_xyzzy()``).  This kernel function may then be called within the
 syscall stub (``sys_xyzzy()``), the compatibility syscall stub
 (``compat_sys_xyzzy()``), and/or other kernel code.
 
-- 
2.30.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 2/2] Documentation: admin-guide: Update kvm/xen config option
  2021-01-30  1:45 [PATCH 1/2] docs: Make syscalls' helpers naming consistent André Almeida
@ 2021-01-30  1:45 ` André Almeida
  2021-01-30  7:18 ` [PATCH 1/2] docs: Make syscalls' helpers naming consistent Dominik Brodowski
  2021-02-04 21:48 ` Jonathan Corbet
  2 siblings, 0 replies; 4+ messages in thread
From: André Almeida @ 2021-01-30  1:45 UTC (permalink / raw)
  To: corbet; +Cc: linux-doc, linux-kernel, André Almeida

Since commit 9bba03d4473d ("kconfig: remove 'kvmconfig' and 'xenconfig'
shorthands") kvm/xen config shortcuts are not available anymore. Update
the file to reflect how they should be used, with the full filename.

Signed-off-by: André Almeida <andrealmeid@collabora.com>
---
 Documentation/admin-guide/README.rst | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/Documentation/admin-guide/README.rst b/Documentation/admin-guide/README.rst
index 261b7b4cca1f..35314b63008c 100644
--- a/Documentation/admin-guide/README.rst
+++ b/Documentation/admin-guide/README.rst
@@ -226,10 +226,11 @@ Configuring the kernel
                            all module options to built in (=y) options. You can
                            also preserve modules by LMC_KEEP.
 
-     "make kvmconfig"   Enable additional options for kvm guest kernel support.
+     "make kvm_guest.config"   Enable additional options for kvm guest kernel
+                               support.
 
-     "make xenconfig"   Enable additional options for xen dom0 guest kernel
-                        support.
+     "make xen.config"   Enable additional options for xen dom0 guest kernel
+                         support.
 
      "make tinyconfig"  Configure the tiniest possible kernel.
 
-- 
2.30.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] docs: Make syscalls' helpers naming consistent
  2021-01-30  1:45 [PATCH 1/2] docs: Make syscalls' helpers naming consistent André Almeida
  2021-01-30  1:45 ` [PATCH 2/2] Documentation: admin-guide: Update kvm/xen config option André Almeida
@ 2021-01-30  7:18 ` Dominik Brodowski
  2021-02-04 21:48 ` Jonathan Corbet
  2 siblings, 0 replies; 4+ messages in thread
From: Dominik Brodowski @ 2021-01-30  7:18 UTC (permalink / raw)
  To: André Almeida; +Cc: corbet, linux-doc, linux-kernel

On Fri, Jan 29, 2021 at 10:45:46PM -0300, André Almeida wrote:
> The documentation explains the need to create internal syscalls' helpers,
> and that they should be called `kern_xyzzy()`. However, the comment at
> include/linux/syscall.h says that they should be named as
> `ksys_xyzzy()`, and so are all the helpers declared bellow it. Change the
> documentation to reflect this.
> 
> Cc: Dominik Brodowski <linux@dominikbrodowski.net>
> Fixes: 819671ff849b ("syscalls: define and explain goal to not call syscalls in the kernel")
> Signed-off-by: André Almeida <andrealmeid@collabora.com>

Reviewed-by: Dominik Brodowski <linux@dominikbrodowski.net>

Thanks,
	Dominik

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] docs: Make syscalls' helpers naming consistent
  2021-01-30  1:45 [PATCH 1/2] docs: Make syscalls' helpers naming consistent André Almeida
  2021-01-30  1:45 ` [PATCH 2/2] Documentation: admin-guide: Update kvm/xen config option André Almeida
  2021-01-30  7:18 ` [PATCH 1/2] docs: Make syscalls' helpers naming consistent Dominik Brodowski
@ 2021-02-04 21:48 ` Jonathan Corbet
  2 siblings, 0 replies; 4+ messages in thread
From: Jonathan Corbet @ 2021-02-04 21:48 UTC (permalink / raw)
  To: André Almeida
  Cc: linux-doc, linux-kernel, André Almeida, Dominik Brodowski

André Almeida <andrealmeid@collabora.com> writes:

> The documentation explains the need to create internal syscalls' helpers,
> and that they should be called `kern_xyzzy()`. However, the comment at
> include/linux/syscall.h says that they should be named as
> `ksys_xyzzy()`, and so are all the helpers declared bellow it. Change the
> documentation to reflect this.
>
> Cc: Dominik Brodowski <linux@dominikbrodowski.net>
> Fixes: 819671ff849b ("syscalls: define and explain goal to not call syscalls in the kernel")
> Signed-off-by: André Almeida <andrealmeid@collabora.com>
> ---
>  Documentation/process/adding-syscalls.rst | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

I've applied both patches thanks (also did s/syscall.h/syscalls.h in the
above changelog).

jon

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-02-04 21:49 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-30  1:45 [PATCH 1/2] docs: Make syscalls' helpers naming consistent André Almeida
2021-01-30  1:45 ` [PATCH 2/2] Documentation: admin-guide: Update kvm/xen config option André Almeida
2021-01-30  7:18 ` [PATCH 1/2] docs: Make syscalls' helpers naming consistent Dominik Brodowski
2021-02-04 21:48 ` Jonathan Corbet

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).