linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro
@ 2021-05-14  8:11 YueHaibing
  2021-05-14 12:24 ` Mark Brown
  2021-05-18 16:31 ` Mark Brown
  0 siblings, 2 replies; 4+ messages in thread
From: YueHaibing @ 2021-05-14  8:11 UTC (permalink / raw)
  To: lgirdwood, broonie, perex, tiwai, kuninori.morimoto.gx
  Cc: alsa-devel, linux-kernel, YueHaibing

Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR,
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <yuehaibing@huawei.com>
---
 sound/soc/soc-core.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 1c0904acb935..2d969e31f37d 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -75,9 +75,9 @@ static ssize_t pmdown_time_show(struct device *dev,
 	return sprintf(buf, "%ld\n", rtd->pmdown_time);
 }
 
-static ssize_t pmdown_time_set(struct device *dev,
-			       struct device_attribute *attr,
-			       const char *buf, size_t count)
+static ssize_t pmdown_time_store(struct device *dev,
+				 struct device_attribute *attr,
+				 const char *buf, size_t count)
 {
 	struct snd_soc_pcm_runtime *rtd = dev_get_drvdata(dev);
 	int ret;
@@ -89,7 +89,7 @@ static ssize_t pmdown_time_set(struct device *dev,
 	return count;
 }
 
-static DEVICE_ATTR(pmdown_time, 0644, pmdown_time_show, pmdown_time_set);
+static DEVICE_ATTR_RW(pmdown_time);
 
 static struct attribute *soc_dev_attrs[] = {
 	&dev_attr_pmdown_time.attr,
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro
  2021-05-14  8:11 [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro YueHaibing
@ 2021-05-14 12:24 ` Mark Brown
  2021-05-16  2:39   ` YueHaibing
  2021-05-18 16:31 ` Mark Brown
  1 sibling, 1 reply; 4+ messages in thread
From: Mark Brown @ 2021-05-14 12:24 UTC (permalink / raw)
  To: YueHaibing
  Cc: lgirdwood, perex, tiwai, kuninori.morimoto.gx, alsa-devel, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 402 bytes --]

On Fri, May 14, 2021 at 04:11:00PM +0800, YueHaibing wrote:

> -static ssize_t pmdown_time_set(struct device *dev,
> -			       struct device_attribute *attr,
> -			       const char *buf, size_t count)
> +static ssize_t pmdown_time_store(struct device *dev,
> +				 struct device_attribute *attr,
> +				 const char *buf, size_t count)

This unrelated formatting change should be in a separate patch.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro
  2021-05-14 12:24 ` Mark Brown
@ 2021-05-16  2:39   ` YueHaibing
  0 siblings, 0 replies; 4+ messages in thread
From: YueHaibing @ 2021-05-16  2:39 UTC (permalink / raw)
  To: Mark Brown
  Cc: lgirdwood, perex, tiwai, kuninori.morimoto.gx, alsa-devel, linux-kernel

On 2021/5/14 20:24, Mark Brown wrote:
> On Fri, May 14, 2021 at 04:11:00PM +0800, YueHaibing wrote:
> 
>> -static ssize_t pmdown_time_set(struct device *dev,
>> -			       struct device_attribute *attr,
>> -			       const char *buf, size_t count)
>> +static ssize_t pmdown_time_store(struct device *dev,
>> +				 struct device_attribute *attr,
>> +				 const char *buf, size_t count)
> 
> This unrelated formatting change should be in a separate patch.

This change pmdown_time_set() to pmdown_time_store(), which trigger
checkpatch warning.

> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro
  2021-05-14  8:11 [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro YueHaibing
  2021-05-14 12:24 ` Mark Brown
@ 2021-05-18 16:31 ` Mark Brown
  1 sibling, 0 replies; 4+ messages in thread
From: Mark Brown @ 2021-05-18 16:31 UTC (permalink / raw)
  To: tiwai, YueHaibing, perex, lgirdwood, kuninori.morimoto.gx
  Cc: Mark Brown, alsa-devel, linux-kernel

On Fri, 14 May 2021 16:11:00 +0800, YueHaibing wrote:
> Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR,
> which makes the code a bit shorter and easier to read.

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[1/1] ASoC: soc-core: use DEVICE_ATTR_RO macro
      commit: 5a3f869c5b4d230b60ba0197c10506dd4ae30851

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-05-18 16:33 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-14  8:11 [PATCH -next] ASoC: soc-core: use DEVICE_ATTR_RO macro YueHaibing
2021-05-14 12:24 ` Mark Brown
2021-05-16  2:39   ` YueHaibing
2021-05-18 16:31 ` Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).