linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro
@ 2021-05-24 11:55 YueHaibing
  2021-05-27 11:16 ` Cezary Rojewski
  2021-06-02 16:16 ` Mark Brown
  0 siblings, 2 replies; 3+ messages in thread
From: YueHaibing @ 2021-05-24 11:55 UTC (permalink / raw)
  To: cezary.rojewski, pierre-louis.bossart, liam.r.girdwood, yang.jie,
	broonie, perex, tiwai, yuehaibing
  Cc: alsa-devel, linux-kernel

Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <yuehaibing@huawei.com>
---
 sound/soc/intel/skylake/skl-nhlt.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/sound/soc/intel/skylake/skl-nhlt.c b/sound/soc/intel/skylake/skl-nhlt.c
index 87c891c46291..64226072f0ee 100644
--- a/sound/soc/intel/skylake/skl-nhlt.c
+++ b/sound/soc/intel/skylake/skl-nhlt.c
@@ -149,8 +149,8 @@ int skl_nhlt_update_topology_bin(struct skl_dev *skl)
 	return 0;
 }
 
-static ssize_t skl_nhlt_platform_id_show(struct device *dev,
-			struct device_attribute *attr, char *buf)
+static ssize_t platform_id_show(struct device *dev,
+				struct device_attribute *attr, char *buf)
 {
 	struct pci_dev *pci = to_pci_dev(dev);
 	struct hdac_bus *bus = pci_get_drvdata(pci);
@@ -166,7 +166,7 @@ static ssize_t skl_nhlt_platform_id_show(struct device *dev,
 	return sprintf(buf, "%s\n", platform_id);
 }
 
-static DEVICE_ATTR(platform_id, 0444, skl_nhlt_platform_id_show, NULL);
+static DEVICE_ATTR_RO(platform_id);
 
 int skl_nhlt_create_sysfs(struct skl_dev *skl)
 {
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro
  2021-05-24 11:55 [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro YueHaibing
@ 2021-05-27 11:16 ` Cezary Rojewski
  2021-06-02 16:16 ` Mark Brown
  1 sibling, 0 replies; 3+ messages in thread
From: Cezary Rojewski @ 2021-05-27 11:16 UTC (permalink / raw)
  To: YueHaibing, pierre-louis.bossart, liam.r.girdwood, yang.jie,
	broonie, perex, tiwai
  Cc: alsa-devel, linux-kernel

On 2021-05-24 1:55 PM, YueHaibing wrote:
> Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
> 
> Signed-off-by: YueHaibing <yuehaibing@huawei.com>
> ---

Thanks for your input.

Reviewed-by: Cezary Rojewski <cezary.rojewski@intel.com>

Regards,
Czarek

>   sound/soc/intel/skylake/skl-nhlt.c | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/sound/soc/intel/skylake/skl-nhlt.c b/sound/soc/intel/skylake/skl-nhlt.c
> index 87c891c46291..64226072f0ee 100644
> --- a/sound/soc/intel/skylake/skl-nhlt.c
> +++ b/sound/soc/intel/skylake/skl-nhlt.c
> @@ -149,8 +149,8 @@ int skl_nhlt_update_topology_bin(struct skl_dev *skl)
>   	return 0;
>   }
>   
> -static ssize_t skl_nhlt_platform_id_show(struct device *dev,
> -			struct device_attribute *attr, char *buf)
> +static ssize_t platform_id_show(struct device *dev,
> +				struct device_attribute *attr, char *buf)
>   {
>   	struct pci_dev *pci = to_pci_dev(dev);
>   	struct hdac_bus *bus = pci_get_drvdata(pci);
> @@ -166,7 +166,7 @@ static ssize_t skl_nhlt_platform_id_show(struct device *dev,
>   	return sprintf(buf, "%s\n", platform_id);
>   }
>   
> -static DEVICE_ATTR(platform_id, 0444, skl_nhlt_platform_id_show, NULL);
> +static DEVICE_ATTR_RO(platform_id);
>   
>   int skl_nhlt_create_sysfs(struct skl_dev *skl)
>   {
> 

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro
  2021-05-24 11:55 [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro YueHaibing
  2021-05-27 11:16 ` Cezary Rojewski
@ 2021-06-02 16:16 ` Mark Brown
  1 sibling, 0 replies; 3+ messages in thread
From: Mark Brown @ 2021-06-02 16:16 UTC (permalink / raw)
  To: tiwai, yang.jie, perex, liam.r.girdwood, YueHaibing,
	cezary.rojewski, pierre-louis.bossart
  Cc: Mark Brown, alsa-devel, linux-kernel

On Mon, 24 May 2021 19:55:06 +0800, YueHaibing wrote:
> Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[1/1] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro
      commit: ae624a38be37e1a3127d5fa32c996e09974bb88d

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-06-02 16:17 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-24 11:55 [PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro YueHaibing
2021-05-27 11:16 ` Cezary Rojewski
2021-06-02 16:16 ` Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).