linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ARM: bL_switcher: use IS_ERR_OR_NULL() to simplify code
@ 2021-06-24  7:42 Tang Bin
  2021-06-24  9:23 ` Russell King (Oracle)
  0 siblings, 1 reply; 2+ messages in thread
From: Tang Bin @ 2021-06-24  7:42 UTC (permalink / raw)
  To: linux; +Cc: linux-arm-kernel, linux-kernel, Tang Bin

Use IS_ERR_OR_NULL() instead of IS_ERR() to simplify code.

Signed-off-by: Tang Bin <tangbin@cmss.chinamobile.com>
---
 arch/arm/common/bL_switcher.c | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

diff --git a/arch/arm/common/bL_switcher.c b/arch/arm/common/bL_switcher.c
index 9a9aa5354..b8e8e2567 100644
--- a/arch/arm/common/bL_switcher.c
+++ b/arch/arm/common/bL_switcher.c
@@ -352,11 +352,9 @@ int bL_switch_request_cb(unsigned int cpu, unsigned int new_cluster_id,
 
 	t = &bL_threads[cpu];
 
-	if (IS_ERR(t->task))
-		return PTR_ERR(t->task);
-	if (!t->task)
-		return -ESRCH;
-
+	if (IS_ERR_OR_NULL(t->task))
+		return t->task ? PTR_ERR(t->task) : -ESRCH;
+
 	spin_lock(&t->lock);
 	if (t->completer) {
 		spin_unlock(&t->lock);
-- 
2.20.1.windows.1




^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] ARM: bL_switcher: use IS_ERR_OR_NULL() to simplify code
  2021-06-24  7:42 [PATCH] ARM: bL_switcher: use IS_ERR_OR_NULL() to simplify code Tang Bin
@ 2021-06-24  9:23 ` Russell King (Oracle)
  0 siblings, 0 replies; 2+ messages in thread
From: Russell King (Oracle) @ 2021-06-24  9:23 UTC (permalink / raw)
  To: Tang Bin; +Cc: linux-arm-kernel, linux-kernel

On Thu, Jun 24, 2021 at 03:42:23PM +0800, Tang Bin wrote:
> diff --git a/arch/arm/common/bL_switcher.c b/arch/arm/common/bL_switcher.c
> index 9a9aa5354..b8e8e2567 100644
> --- a/arch/arm/common/bL_switcher.c
> +++ b/arch/arm/common/bL_switcher.c
> @@ -352,11 +352,9 @@ int bL_switch_request_cb(unsigned int cpu, unsigned int new_cluster_id,
>  
>  	t = &bL_threads[cpu];
>  
> -	if (IS_ERR(t->task))
> -		return PTR_ERR(t->task);
> -	if (!t->task)
> -		return -ESRCH;
> -
> +	if (IS_ERR_OR_NULL(t->task))
> +		return t->task ? PTR_ERR(t->task) : -ESRCH;
> +
>  	spin_lock(&t->lock);
>  	if (t->completer) {
>  		spin_unlock(&t->lock);

I don't think this improves the code. The original is more readable, and
readability is what we care about rather than code compactness.

-- 
RMK's Patch system: https://www.armlinux.org.uk/developer/patches/
FTTP is here! 40Mbps down 10Mbps up. Decent connectivity at last!

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-06-24  9:23 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-24  7:42 [PATCH] ARM: bL_switcher: use IS_ERR_OR_NULL() to simplify code Tang Bin
2021-06-24  9:23 ` Russell King (Oracle)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).