linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jonathan Cameron <Jonathan.Cameron@Huawei.com>
To: David Lechner <david@lechnology.com>
Cc: Jonathan Cameron <jic23@kernel.org>,
	William Breathitt Gray <vilhelm.gray@gmail.com>,
	<linux-stm32@st-md-mailman.stormreply.com>,
	<kernel@pengutronix.de>, <a.fatoum@pengutronix.de>,
	<kamel.bouhara@bootlin.com>, <gwendal@chromium.org>,
	<alexandre.belloni@bootlin.com>, <linux-iio@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>,
	<linux-arm-kernel@lists.infradead.org>, <syednwaris@gmail.com>,
	<patrick.havelange@essensium.com>, <fabrice.gasnier@st.com>,
	<mcoquelin.stm32@gmail.com>, <alexandre.torgue@st.com>,
	<o.rempel@pengutronix.de>, <jarkko.nikula@linux.intel.com>,
	Dan Carpenter <dan.carpenter@oracle.com>,
	Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Subject: Re: [PATCH v12 14/17] counter: Implement *_component_id sysfs attributes
Date: Mon, 12 Jul 2021 11:19:09 +0100	[thread overview]
Message-ID: <20210712111909.00004f72@Huawei.com> (raw)
In-Reply-To: <72d6513c-c7fc-c53d-b750-ebd2e8f3b848@lechnology.com>

On Sun, 11 Jul 2021 09:08:29 -0500
David Lechner <david@lechnology.com> wrote:

> On 7/11/21 8:28 AM, Jonathan Cameron wrote:
> > On Sat, 10 Jul 2021 12:06:53 -0500
> > David Lechner <david@lechnology.com> wrote:
> >   
> >> On 7/5/21 3:19 AM, William Breathitt Gray wrote:  
> >>> The Generic Counter chrdev interface expects users to supply component
> >>> IDs in order to select extensions for requests. In order for users to
> >>> know what component ID belongs to which extension this information must
> >>> be exposed. The *_component_id attribute provides a way for users to
> >>> discover what component ID belongs to which respective extension.
> >>>
> >>> Cc: David Lechner <david@lechnology.com>
> >>> Cc: Gwendal Grignou <gwendal@chromium.org>
> >>> Cc: Dan Carpenter <dan.carpenter@oracle.com>
> >>> Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
> >>> ---
> >>>    Documentation/ABI/testing/sysfs-bus-counter | 16 ++++++++++-
> >>>    drivers/counter/counter-sysfs.c             | 30 ++++++++++++++++-----
> >>>    2 files changed, 39 insertions(+), 7 deletions(-)
> >>>
> >>> diff --git a/Documentation/ABI/testing/sysfs-bus-counter b/Documentation/ABI/testing/sysfs-bus-counter
> >>> index 9809d8a47431..e0e99adb0ecc 100644
> >>> --- a/Documentation/ABI/testing/sysfs-bus-counter
> >>> +++ b/Documentation/ABI/testing/sysfs-bus-counter
> >>> @@ -203,12 +203,26 @@ Description:
> >>>    		both edges:
> >>>    			Any state transition.
> >>>    
> >>> +What:		/sys/bus/counter/devices/counterX/countY/ceiling_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/floor_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/count_mode_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/direction_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/enable_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/error_noise_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/prescaler_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/preset_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/countY/preset_enable_component_id
> >>>    What:		/sys/bus/counter/devices/counterX/countY/signalZ_action_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/signalY/cable_fault_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/signalY/cable_fault_enable_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/signalY/filter_clock_prescaler_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/signalY/index_polarity_component_id
> >>> +What:		/sys/bus/counter/devices/counterX/signalY/synchronous_mode_component_id  
> >>
> >> Could we just write a single line?
> >>
> >> What:		/sys/bus/counter/devices/counterX/signalY/<component>_component_id  
> > 
> > Not nice for grepping so I think it's better to call them out explicitly.
> > 
> > There has been a proposal to check this ABI doc against running kernels, and if we have
> > too many wild cards that becomes very difficult to do.
> > 
> > Jonathan
> >   
> >>  
> >>>    KernelVersion:	5.15  
> 
> Makes sense. Do we start a new group of similar names with the same
> description for each kernel release that includes new attributes then?

You've spotted one of the short comings of current format.  The scripts that
produce the html docs don't cope with multiple version numbers.

Mostly for IIO we've just been cynical and not had the correct kernel version for
new ABI when it's added. It's not ideal though.

The alternative, as you mention is to have a new block.  Perhaps we can have
that refer back to the existing one if the docs cover the new entries as well.

@Mauro:  Any suggestions for this?

Thanks

Jonathan


> 
> >>>    Contact:	linux-iio@vger.kernel.org
> >>>    Description:
> >>>    		Read-only attribute that indicates the component ID of the
> >>> -		respective Synapse of Count Y for Signal Z.
> >>> +		respective extension or Synapse.
> >>>      


  reply	other threads:[~2021-07-12 10:19 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-05  8:18 [PATCH v12 00/17] Introduce the Counter character device interface William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 01/17] counter: 104-quad-8: Return error when invalid mode during ceiling_write William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 02/17] counter: Return error code on invalid modes William Breathitt Gray
2021-07-09 17:40   ` David Lechner
2021-07-05  8:18 ` [PATCH v12 03/17] counter: Standardize to ERANGE for limit exceeded errors William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 04/17] counter: Rename counter_signal_value to counter_signal_level William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 05/17] counter: Rename counter_count_function to counter_function William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 06/17] counter: Internalize sysfs interface code William Breathitt Gray
2021-07-11  9:49   ` Syed Nayyar Waris
2021-07-11 11:42   ` Jonathan Cameron
2021-07-05  8:18 ` [PATCH v12 07/17] counter: Update counter.h comments to reflect sysfs internalization William Breathitt Gray
2021-07-09 17:49   ` David Lechner
2021-07-10  9:41     ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 08/17] docs: counter: Update " William Breathitt Gray
2021-07-09 17:56   ` David Lechner
2021-07-05  8:18 ` [PATCH v12 09/17] counter: Move counter enums to uapi header William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 10/17] counter: Add character device interface William Breathitt Gray
2021-07-10 19:37   ` David Lechner
2021-07-11 12:20   ` Jonathan Cameron
2021-07-12 10:28     ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 11/17] docs: counter: Document " William Breathitt Gray
2021-07-10 20:15   ` David Lechner
2021-07-11 10:41     ` William Breathitt Gray
2021-07-05  8:19 ` [PATCH v12 12/17] tools/counter: Create Counter tools William Breathitt Gray
2021-07-10 16:53   ` David Lechner
2021-07-11 11:28     ` William Breathitt Gray
2021-07-11 14:05       ` David Lechner
2021-07-11 13:22   ` Jonathan Cameron
2021-07-05  8:19 ` [PATCH v12 13/17] counter: Implement signalZ_action_component_id sysfs attribute William Breathitt Gray
2021-07-10 16:20   ` David Lechner
2021-07-05  8:19 ` [PATCH v12 14/17] counter: Implement *_component_id sysfs attributes William Breathitt Gray
2021-07-10 17:06   ` David Lechner
2021-07-11 13:28     ` Jonathan Cameron
2021-07-11 14:08       ` David Lechner
2021-07-12 10:19         ` Jonathan Cameron [this message]
2021-07-05  8:19 ` [PATCH v12 15/17] counter: Implement events_queue_size sysfs attribute William Breathitt Gray
2021-07-06  7:48   ` Dan Carpenter
2021-07-06 11:40   ` Jarkko Nikula
2021-07-10 10:25     ` William Breathitt Gray
2021-07-10 15:43       ` David Lechner
2021-07-10 16:08         ` David Lechner
2021-07-10 17:53           ` David Lechner
2021-07-11  9:12         ` William Breathitt Gray
2021-07-05  8:19 ` [PATCH v12 16/17] counter: 104-quad-8: Replace mutex with spinlock William Breathitt Gray
2021-07-05  8:19 ` [PATCH v12 17/17] counter: 104-quad-8: Add IRQ support for the ACCES 104-QUAD-8 William Breathitt Gray
2021-07-11 13:44   ` Jonathan Cameron
2021-07-12 10:59     ` William Breathitt Gray
2021-07-06 11:40 ` [PATCH v12 00/17] Introduce the Counter character device interface Jarkko Nikula
2021-07-07  0:28   ` William Breathitt Gray
2021-07-11 13:48 ` Jonathan Cameron
2021-07-12 10:48   ` William Breathitt Gray

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210712111909.00004f72@Huawei.com \
    --to=jonathan.cameron@huawei.com \
    --cc=a.fatoum@pengutronix.de \
    --cc=alexandre.belloni@bootlin.com \
    --cc=alexandre.torgue@st.com \
    --cc=dan.carpenter@oracle.com \
    --cc=david@lechnology.com \
    --cc=fabrice.gasnier@st.com \
    --cc=gwendal@chromium.org \
    --cc=jarkko.nikula@linux.intel.com \
    --cc=jic23@kernel.org \
    --cc=kamel.bouhara@bootlin.com \
    --cc=kernel@pengutronix.de \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=mchehab+huawei@kernel.org \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=o.rempel@pengutronix.de \
    --cc=patrick.havelange@essensium.com \
    --cc=syednwaris@gmail.com \
    --cc=vilhelm.gray@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).