linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH -next] sched: Use struct_size() helper in task_numa_group()
@ 2021-12-21 13:21 Xiu Jianfeng
  2022-01-06 16:39 ` Steven Rostedt
  0 siblings, 1 reply; 7+ messages in thread
From: Xiu Jianfeng @ 2021-12-21 13:21 UTC (permalink / raw)
  To: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, bristot
  Cc: linux-kernel

Make use of struct_size() helper instead of an open-coded calculation.
There is no functional change in this patch.

Link: https://github.com/KSPP/linux/issues/160
Signed-off-by: Xiu Jianfeng <xiujianfeng@huawei.com>
---
 kernel/sched/fair.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 095b0aa378df..265e37be0c92 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
 	int i;
 
 	if (unlikely(!deref_curr_numa_group(p))) {
-		unsigned int size = sizeof(struct numa_group) +
-				    NR_NUMA_HINT_FAULT_STATS *
-				    nr_node_ids * sizeof(unsigned long);
-
-		grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
+		grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
+			      GFP_KERNEL | __GFP_NOWARN);
 		if (!grp)
 			return;
 
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH -next] sched: Use struct_size() helper in task_numa_group()
  2021-12-21 13:21 [PATCH -next] sched: Use struct_size() helper in task_numa_group() Xiu Jianfeng
@ 2022-01-06 16:39 ` Steven Rostedt
  0 siblings, 0 replies; 7+ messages in thread
From: Steven Rostedt @ 2022-01-06 16:39 UTC (permalink / raw)
  To: Xiu Jianfeng
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	bsegall, mgorman, bristot, linux-kernel

On Tue, 21 Dec 2021 21:21:38 +0800
Xiu Jianfeng <xiujianfeng@huawei.com> wrote:

> Make use of struct_size() helper instead of an open-coded calculation.
> There is no functional change in this patch.

I'm all for this clean up, but...

> 
> Link: https://github.com/KSPP/linux/issues/160
> Signed-off-by: Xiu Jianfeng <xiujianfeng@huawei.com>
> ---
>  kernel/sched/fair.c | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
> 
> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> index 095b0aa378df..265e37be0c92 100644
> --- a/kernel/sched/fair.c
> +++ b/kernel/sched/fair.c
> @@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
>  	int i;
>  
>  	if (unlikely(!deref_curr_numa_group(p))) {
> -		unsigned int size = sizeof(struct numa_group) +
> -				    NR_NUMA_HINT_FAULT_STATS *
> -				    nr_node_ids * sizeof(unsigned long);
> -
> -		grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
> +		grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
> +			      GFP_KERNEL | __GFP_NOWARN);

Ug, the above is so ugly. Why remove the size variable?

		unsigned int size  = struct_size(grp, faults,
					         NR_NUMA_HINT_FAULT_STATS * nr_node_ids);

-- Steve


>  		if (!grp)
>  			return;
>  


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH -next] sched: Use struct_size() helper in task_numa_group()
  2022-01-10 16:06 ` Peter Zijlstra
@ 2022-01-10 16:11   ` Steven Rostedt
  0 siblings, 0 replies; 7+ messages in thread
From: Steven Rostedt @ 2022-01-10 16:11 UTC (permalink / raw)
  To: Peter Zijlstra
  Cc: Xiu Jianfeng, mingo, juri.lelli, vincent.guittot,
	dietmar.eggemann, bsegall, mgorman, bristot, gustavoars,
	linux-kernel, linux-hardening

On Mon, 10 Jan 2022 17:06:30 +0100
Peter Zijlstra <peterz@infradead.org> wrote:

> On Fri, Jan 07, 2022 at 10:52:12AM +0800, Xiu Jianfeng wrote:
> > Make use of struct_size() helper instead of an open-coded calculation.
> > There is no functional change in this patch.  
> 
> Why ?!? This makes something that was trivial to read into something
> weird.

Please take his last patch (which only modifies the update to size) and
makes it more robust.

  https://lore.kernel.org/all/20220110012354.144394-1-xiujianfeng@huawei.com/

Which is much easier to read.

We should really replace all open coded struct_size() code.

-- Steve

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH -next] sched: Use struct_size() helper in task_numa_group()
  2022-01-07  2:52 Xiu Jianfeng
  2022-01-07 14:36 ` Steven Rostedt
@ 2022-01-10 16:06 ` Peter Zijlstra
  2022-01-10 16:11   ` Steven Rostedt
  1 sibling, 1 reply; 7+ messages in thread
From: Peter Zijlstra @ 2022-01-10 16:06 UTC (permalink / raw)
  To: Xiu Jianfeng
  Cc: mingo, juri.lelli, vincent.guittot, dietmar.eggemann, rostedt,
	bsegall, mgorman, bristot, gustavoars, linux-kernel,
	linux-hardening

On Fri, Jan 07, 2022 at 10:52:12AM +0800, Xiu Jianfeng wrote:
> Make use of struct_size() helper instead of an open-coded calculation.
> There is no functional change in this patch.

Why ?!? This makes something that was trivial to read into something
weird.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH -next] sched: Use struct_size() helper in task_numa_group()
  2022-01-07 14:36 ` Steven Rostedt
@ 2022-01-10  1:20   ` xiujianfeng
  0 siblings, 0 replies; 7+ messages in thread
From: xiujianfeng @ 2022-01-10  1:20 UTC (permalink / raw)
  To: Steven Rostedt
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	bsegall, mgorman, bristot, gustavoars, linux-kernel,
	linux-hardening


在 2022/1/7 22:36, Steven Rostedt 写道:
> On Fri, 7 Jan 2022 10:52:12 +0800
> Xiu Jianfeng <xiujianfeng@huawei.com> wrote:
>
>> Make use of struct_size() helper instead of an open-coded calculation.
>> There is no functional change in this patch.
>>
>> Link: https://github.com/KSPP/linux/issues/160
>> Signed-off-by: Xiu Jianfeng <xiujianfeng@huawei.com>
>> ---
>>   kernel/sched/fair.c | 7 ++-----
>>   1 file changed, 2 insertions(+), 5 deletions(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index 095b0aa378df..265e37be0c92 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
>>   	int i;
>>   
>>   	if (unlikely(!deref_curr_numa_group(p))) {
>> -		unsigned int size = sizeof(struct numa_group) +
>> -				    NR_NUMA_HINT_FAULT_STATS *
>> -				    nr_node_ids * sizeof(unsigned long);
>> -
>> -		grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
>> +		grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
>> +			      GFP_KERNEL | __GFP_NOWARN);
> I just replied yesterday. Keep the size variable. The above is too much for
> a kzalloc().

thanks, I may missed your reply mail, I'll modify and resend this patch.

>
> -- Steve
>
>
>
>
>>   		if (!grp)
>>   			return;
>>   
> .

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH -next] sched: Use struct_size() helper in task_numa_group()
  2022-01-07  2:52 Xiu Jianfeng
@ 2022-01-07 14:36 ` Steven Rostedt
  2022-01-10  1:20   ` xiujianfeng
  2022-01-10 16:06 ` Peter Zijlstra
  1 sibling, 1 reply; 7+ messages in thread
From: Steven Rostedt @ 2022-01-07 14:36 UTC (permalink / raw)
  To: Xiu Jianfeng
  Cc: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	bsegall, mgorman, bristot, gustavoars, linux-kernel,
	linux-hardening

On Fri, 7 Jan 2022 10:52:12 +0800
Xiu Jianfeng <xiujianfeng@huawei.com> wrote:

> Make use of struct_size() helper instead of an open-coded calculation.
> There is no functional change in this patch.
> 
> Link: https://github.com/KSPP/linux/issues/160
> Signed-off-by: Xiu Jianfeng <xiujianfeng@huawei.com>
> ---
>  kernel/sched/fair.c | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
> 
> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> index 095b0aa378df..265e37be0c92 100644
> --- a/kernel/sched/fair.c
> +++ b/kernel/sched/fair.c
> @@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
>  	int i;
>  
>  	if (unlikely(!deref_curr_numa_group(p))) {
> -		unsigned int size = sizeof(struct numa_group) +
> -				    NR_NUMA_HINT_FAULT_STATS *
> -				    nr_node_ids * sizeof(unsigned long);
> -
> -		grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
> +		grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
> +			      GFP_KERNEL | __GFP_NOWARN);

I just replied yesterday. Keep the size variable. The above is too much for
a kzalloc().

-- Steve




>  		if (!grp)
>  			return;
>  


^ permalink raw reply	[flat|nested] 7+ messages in thread

* [PATCH -next] sched: Use struct_size() helper in task_numa_group()
@ 2022-01-07  2:52 Xiu Jianfeng
  2022-01-07 14:36 ` Steven Rostedt
  2022-01-10 16:06 ` Peter Zijlstra
  0 siblings, 2 replies; 7+ messages in thread
From: Xiu Jianfeng @ 2022-01-07  2:52 UTC (permalink / raw)
  To: mingo, peterz, juri.lelli, vincent.guittot, dietmar.eggemann,
	rostedt, bsegall, mgorman, bristot, gustavoars
  Cc: linux-kernel, linux-hardening

Make use of struct_size() helper instead of an open-coded calculation.
There is no functional change in this patch.

Link: https://github.com/KSPP/linux/issues/160
Signed-off-by: Xiu Jianfeng <xiujianfeng@huawei.com>
---
 kernel/sched/fair.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 095b0aa378df..265e37be0c92 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
 	int i;
 
 	if (unlikely(!deref_curr_numa_group(p))) {
-		unsigned int size = sizeof(struct numa_group) +
-				    NR_NUMA_HINT_FAULT_STATS *
-				    nr_node_ids * sizeof(unsigned long);
-
-		grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
+		grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
+			      GFP_KERNEL | __GFP_NOWARN);
 		if (!grp)
 			return;
 
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-01-10 16:11 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-21 13:21 [PATCH -next] sched: Use struct_size() helper in task_numa_group() Xiu Jianfeng
2022-01-06 16:39 ` Steven Rostedt
2022-01-07  2:52 Xiu Jianfeng
2022-01-07 14:36 ` Steven Rostedt
2022-01-10  1:20   ` xiujianfeng
2022-01-10 16:06 ` Peter Zijlstra
2022-01-10 16:11   ` Steven Rostedt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).