linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
@ 2022-03-29  7:53 Rebecca Mckeever
  2022-03-29 16:16 ` Alison Schofield
  0 siblings, 1 reply; 7+ messages in thread
From: Rebecca Mckeever @ 2022-03-29  7:53 UTC (permalink / raw)
  To: Larry Finger, Phillip Potter, Greg Kroah-Hartman, linux-staging,
	linux-kernel, outreachy

Align the if and else if branches of the conditional statement
to improve readability. Prevent bugs that could be introduced
if developers misread the code. Issue found by checkpatch.

Signed-off-by: Rebecca Mckeever <remckee0@gmail.com>
---
 drivers/staging/r8188eu/core/rtw_cmd.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
index 6eca30124ee8..ccc43c0ba433 100644
--- a/drivers/staging/r8188eu/core/rtw_cmd.c
+++ b/drivers/staging/r8188eu/core/rtw_cmd.c
@@ -1408,7 +1408,7 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
 		/* TODO: cancel timer and do timeout handler directly... */
 		/* need to make timeout handlerOS independent */
 		_set_timer(&pmlmepriv->scan_to_timer, 1);
-		} else if (pcmd->res != H2C_SUCCESS) {
+	} else if (pcmd->res != H2C_SUCCESS) {
 		_set_timer(&pmlmepriv->scan_to_timer, 1);
 	}
 
-- 
2.32.0


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
  2022-03-29  7:53 [PATCH] staging: r8188eu: fix suspect code indent for conditional statements Rebecca Mckeever
@ 2022-03-29 16:16 ` Alison Schofield
  2022-03-30  0:48   ` Rebecca Mckeever
  2022-03-30  6:28   ` Dan Carpenter
  0 siblings, 2 replies; 7+ messages in thread
From: Alison Schofield @ 2022-03-29 16:16 UTC (permalink / raw)
  To: Rebecca Mckeever
  Cc: Larry Finger, Phillip Potter, Greg Kroah-Hartman, linux-staging,
	linux-kernel, outreachy

On Tue, Mar 29, 2022 at 02:53:36AM -0500, Rebecca Mckeever wrote:
> Align the if and else if branches of the conditional statement
> to improve readability. Prevent bugs that could be introduced
> if developers misread the code. Issue found by checkpatch.

Thanks for the patch Rebecca!

Lots of stuff done right - passes chkp, compiles, patch is sent to
correct recipients, the commit message follows the format of the file.

Let's set a pattern here for all checkpatch related cleanups,
for you and others that follow.(Thanks for being the first ;))

Commit msg says 'what'. Commit log says 'why'. Acknowledge that
it was found using checkpatch in the commit log also. (In the future
you may be acknowledging use of other tools like sparse, coccinelle.)

Note that the 'why' is never that a tool reported an error. The 'why'
for these checkpatch reports is usually to follow the Linux Kernel
Coding Style.

'Fix' in the commit message is needlessly generic. Perhaps:
[PATCH] staging: r8188eu: align both branches of a conditional statement

Commit log: (what you have is fine in the log)
I usually paste in the checkpatch error explicitly so it can be grep'd
for. Something like:

Issue found by checkpatch:
WARNING: suspect code indent for conditional statements

Thanks,
Alison

> 
> Signed-off-by: Rebecca Mckeever <remckee0@gmail.com>
> ---
>  drivers/staging/r8188eu/core/rtw_cmd.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
> index 6eca30124ee8..ccc43c0ba433 100644
> --- a/drivers/staging/r8188eu/core/rtw_cmd.c
> +++ b/drivers/staging/r8188eu/core/rtw_cmd.c
> @@ -1408,7 +1408,7 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
>  		/* TODO: cancel timer and do timeout handler directly... */
>  		/* need to make timeout handlerOS independent */
>  		_set_timer(&pmlmepriv->scan_to_timer, 1);
> -		} else if (pcmd->res != H2C_SUCCESS) {
> +	} else if (pcmd->res != H2C_SUCCESS) {
>  		_set_timer(&pmlmepriv->scan_to_timer, 1);
>  	}
>  
> -- 
> 2.32.0
> 
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
  2022-03-29 16:16 ` Alison Schofield
@ 2022-03-30  0:48   ` Rebecca Mckeever
  2022-03-30  1:09     ` Alison Schofield
  2022-03-30  6:28   ` Dan Carpenter
  1 sibling, 1 reply; 7+ messages in thread
From: Rebecca Mckeever @ 2022-03-30  0:48 UTC (permalink / raw)
  To: Alison Schofield
  Cc: Larry Finger, Phillip Potter, Greg Kroah-Hartman, linux-staging,
	linux-kernel, outreachy

On Tue, Mar 29, 2022 at 09:16:32AM -0700, Alison Schofield wrote:
> On Tue, Mar 29, 2022 at 02:53:36AM -0500, Rebecca Mckeever wrote:
> > Align the if and else if branches of the conditional statement
> > to improve readability. Prevent bugs that could be introduced
> > if developers misread the code. Issue found by checkpatch.
> 
> Thanks for the patch Rebecca!
> 
> Lots of stuff done right - passes chkp, compiles, patch is sent to
> correct recipients, the commit message follows the format of the file.
> 
> Let's set a pattern here for all checkpatch related cleanups,
> for you and others that follow.(Thanks for being the first ;))
> 
> Commit msg says 'what'. Commit log says 'why'. Acknowledge that
> it was found using checkpatch in the commit log also. (In the future
> you may be acknowledging use of other tools like sparse, coccinelle.)
> 
> Note that the 'why' is never that a tool reported an error. The 'why'
> for these checkpatch reports is usually to follow the Linux Kernel
> Coding Style.
> 
> 'Fix' in the commit message is needlessly generic. Perhaps:
> [PATCH] staging: r8188eu: align both branches of a conditional statement
> 
> Commit log: (what you have is fine in the log)
> I usually paste in the checkpatch error explicitly so it can be grep'd
> for. Something like:
> 
> Issue found by checkpatch:
> WARNING: suspect code indent for conditional statements

There was a section of https://kernelnewbies.org/PatchPhilosophy that suggested
putting the warning message in the subject line. I thought it would be
redundant to also put it in the body. Is it a good practice to include the
warning message in both places?

> 
> Thanks,
> Alison
> 
> > 
> > Signed-off-by: Rebecca Mckeever <remckee0@gmail.com>
> > ---
> >  drivers/staging/r8188eu/core/rtw_cmd.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
> > index 6eca30124ee8..ccc43c0ba433 100644
> > --- a/drivers/staging/r8188eu/core/rtw_cmd.c
> > +++ b/drivers/staging/r8188eu/core/rtw_cmd.c
> > @@ -1408,7 +1408,7 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
> >  		/* TODO: cancel timer and do timeout handler directly... */
> >  		/* need to make timeout handlerOS independent */
> >  		_set_timer(&pmlmepriv->scan_to_timer, 1);
> > -		} else if (pcmd->res != H2C_SUCCESS) {
> > +	} else if (pcmd->res != H2C_SUCCESS) {
> >  		_set_timer(&pmlmepriv->scan_to_timer, 1);
> >  	}
> >  
> > -- 
> > 2.32.0
> > 
> > 
> 

Thanks,
Rebecca

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
  2022-03-30  0:48   ` Rebecca Mckeever
@ 2022-03-30  1:09     ` Alison Schofield
  0 siblings, 0 replies; 7+ messages in thread
From: Alison Schofield @ 2022-03-30  1:09 UTC (permalink / raw)
  To: Rebecca Mckeever
  Cc: Larry Finger, Phillip Potter, Greg Kroah-Hartman, linux-staging,
	linux-kernel, outreachy

On Tue, Mar 29, 2022 at 07:48:03PM -0500, Rebecca Mckeever wrote:
> On Tue, Mar 29, 2022 at 09:16:32AM -0700, Alison Schofield wrote:
> > On Tue, Mar 29, 2022 at 02:53:36AM -0500, Rebecca Mckeever wrote:
> > > Align the if and else if branches of the conditional statement
> > > to improve readability. Prevent bugs that could be introduced
> > > if developers misread the code. Issue found by checkpatch.
> > 
> > Thanks for the patch Rebecca!
> > 
> > Lots of stuff done right - passes chkp, compiles, patch is sent to
> > correct recipients, the commit message follows the format of the file.
> > 
> > Let's set a pattern here for all checkpatch related cleanups,
> > for you and others that follow.(Thanks for being the first ;))
> > 
> > Commit msg says 'what'. Commit log says 'why'. Acknowledge that
> > it was found using checkpatch in the commit log also. (In the future
> > you may be acknowledging use of other tools like sparse, coccinelle.)
> > 
> > Note that the 'why' is never that a tool reported an error. The 'why'
> > for these checkpatch reports is usually to follow the Linux Kernel
> > Coding Style.
> > 
> > 'Fix' in the commit message is needlessly generic. Perhaps:
> > [PATCH] staging: r8188eu: align both branches of a conditional statement
> > 
> > Commit log: (what you have is fine in the log)
> > I usually paste in the checkpatch error explicitly so it can be grep'd
> > for. Something like:
> > 
> > Issue found by checkpatch:
> > WARNING: suspect code indent for conditional statements
> 
> There was a section of https://kernelnewbies.org/PatchPhilosophy that suggested
> putting the warning message in the subject line. I thought it would be
> redundant to also put it in the body. Is it a good practice to include the
> warning message in both places?
> 
The commit msg should say what you did. If it happens to match the
warning message, that's fine. Think of the commit msg as directives
to a machine. 

This patch has already been applied :)
https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/commit/?h=staging-testing&id=20b4b3fb383b3a499b8b47daaf1d6325faa9cfe2

You can view contents of staging-testing here:
https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/log/?h=staging-testing

> > 
> > Thanks,
> > Alison
> > 
> > > 
> > > Signed-off-by: Rebecca Mckeever <remckee0@gmail.com>
> > > ---
> > >  drivers/staging/r8188eu/core/rtw_cmd.c | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > > 
> > > diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
> > > index 6eca30124ee8..ccc43c0ba433 100644
> > > --- a/drivers/staging/r8188eu/core/rtw_cmd.c
> > > +++ b/drivers/staging/r8188eu/core/rtw_cmd.c
> > > @@ -1408,7 +1408,7 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
> > >  		/* TODO: cancel timer and do timeout handler directly... */
> > >  		/* need to make timeout handlerOS independent */
> > >  		_set_timer(&pmlmepriv->scan_to_timer, 1);
> > > -		} else if (pcmd->res != H2C_SUCCESS) {
> > > +	} else if (pcmd->res != H2C_SUCCESS) {
> > >  		_set_timer(&pmlmepriv->scan_to_timer, 1);
> > >  	}
> > >  
> > > -- 
> > > 2.32.0
> > > 
> > > 
> > 
> 
> Thanks,
> Rebecca

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
  2022-03-29 16:16 ` Alison Schofield
  2022-03-30  0:48   ` Rebecca Mckeever
@ 2022-03-30  6:28   ` Dan Carpenter
  2022-03-31 12:06     ` Rebecca Mckeever
  1 sibling, 1 reply; 7+ messages in thread
From: Dan Carpenter @ 2022-03-30  6:28 UTC (permalink / raw)
  To: Alison Schofield
  Cc: Rebecca Mckeever, Larry Finger, Phillip Potter,
	Greg Kroah-Hartman, linux-staging, linux-kernel, outreachy

I don't really like the focus on commit message minutia...  :/
Basically everyone can understand the commit message.  There are one or
two maintainers who will fly into a rage when they see the word "fix"
in a commit message but I have a simple solution where I just never
email them again.  My time is too valuable for that nonsense.

We would have applied this patch as is.  Or I would normally have
written it like this:

[PATCH] staging: r8188eu: Delete a stray tab in rtw_survey_cmd_callback()

This code works fine, but the line is indented too far so it's confusing.
Delete a tab.

Signed-off-by: ...

I had reviewed this patch earlier and almost pointed out that both sides
of the if statement are the same except for the comment.  The "need to
make timeout handlerOS independent" comment is wrong.  I have not looked
at the details of the other comment.

I did not send my review comments because the patch was fine.  But what
we want is for the code to look more like this.

regards,
dan carpenter

diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
index 6eca30124ee8..dcf7b24f95a8 100644
--- a/drivers/staging/r8188eu/core/rtw_cmd.c
+++ b/drivers/staging/r8188eu/core/rtw_cmd.c
@@ -1404,11 +1404,8 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
 {
 	struct	mlme_priv *pmlmepriv = &padapter->mlmepriv;
 
-	if (pcmd->res == H2C_DROPPED) {
+	if (pcmd->res != H2C_SUCCESS) {
 		/* TODO: cancel timer and do timeout handler directly... */
-		/* need to make timeout handlerOS independent */
-		_set_timer(&pmlmepriv->scan_to_timer, 1);
-		} else if (pcmd->res != H2C_SUCCESS) {
 		_set_timer(&pmlmepriv->scan_to_timer, 1);
 	}
 

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
  2022-03-30  6:28   ` Dan Carpenter
@ 2022-03-31 12:06     ` Rebecca Mckeever
  2022-03-31 12:21       ` Dan Carpenter
  0 siblings, 1 reply; 7+ messages in thread
From: Rebecca Mckeever @ 2022-03-31 12:06 UTC (permalink / raw)
  To: Dan Carpenter
  Cc: Alison Schofield, Larry Finger, Phillip Potter,
	Greg Kroah-Hartman, linux-staging, linux-kernel, outreachy

Hi Dan,

On Wed, Mar 30, 2022 at 09:28:29AM +0300, Dan Carpenter wrote:
> I don't really like the focus on commit message minutia...  :/
> Basically everyone can understand the commit message.  There are one or
> two maintainers who will fly into a rage when they see the word "fix"
> in a commit message but I have a simple solution where I just never
> email them again.  My time is too valuable for that nonsense.
> 
> We would have applied this patch as is.  Or I would normally have
> written it like this:
> 
> [PATCH] staging: r8188eu: Delete a stray tab in rtw_survey_cmd_callback()
> 
> This code works fine, but the line is indented too far so it's confusing.
> Delete a tab.
> 
> Signed-off-by: ...
> 
> I had reviewed this patch earlier and almost pointed out that both sides
> of the if statement are the same except for the comment.  The "need to
> make timeout handlerOS independent" comment is wrong.  I have not looked
> at the details of the other comment.
> 
> I did not send my review comments because the patch was fine.  But what
> we want is for the code to look more like this.
> 
> regards,
> dan carpenter
> 
> diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
> index 6eca30124ee8..dcf7b24f95a8 100644
> --- a/drivers/staging/r8188eu/core/rtw_cmd.c
> +++ b/drivers/staging/r8188eu/core/rtw_cmd.c
> @@ -1404,11 +1404,8 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
>  {
>  	struct	mlme_priv *pmlmepriv = &padapter->mlmepriv;
>  
> -	if (pcmd->res == H2C_DROPPED) {
> +	if (pcmd->res != H2C_SUCCESS) {
>  		/* TODO: cancel timer and do timeout handler directly... */
> -		/* need to make timeout handlerOS independent */
> -		_set_timer(&pmlmepriv->scan_to_timer, 1);
> -		} else if (pcmd->res != H2C_SUCCESS) {
>  		_set_timer(&pmlmepriv->scan_to_timer, 1);
>  	}
>  

Is it okay if I submit a patch to implement your suggestion? I would
include a "Suggested-by" tag.

Thanks,
Rebecca

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] staging: r8188eu: fix suspect code indent for conditional statements
  2022-03-31 12:06     ` Rebecca Mckeever
@ 2022-03-31 12:21       ` Dan Carpenter
  0 siblings, 0 replies; 7+ messages in thread
From: Dan Carpenter @ 2022-03-31 12:21 UTC (permalink / raw)
  To: Rebecca Mckeever
  Cc: Alison Schofield, Larry Finger, Phillip Potter,
	Greg Kroah-Hartman, linux-staging, linux-kernel, outreachy

On Thu, Mar 31, 2022 at 07:06:00AM -0500, Rebecca Mckeever wrote:
> > diff --git a/drivers/staging/r8188eu/core/rtw_cmd.c b/drivers/staging/r8188eu/core/rtw_cmd.c
> > index 6eca30124ee8..dcf7b24f95a8 100644
> > --- a/drivers/staging/r8188eu/core/rtw_cmd.c
> > +++ b/drivers/staging/r8188eu/core/rtw_cmd.c
> > @@ -1404,11 +1404,8 @@ void rtw_survey_cmd_callback(struct adapter *padapter,  struct cmd_obj *pcmd)
> >  {
> >  	struct	mlme_priv *pmlmepriv = &padapter->mlmepriv;
> >  
> > -	if (pcmd->res == H2C_DROPPED) {
> > +	if (pcmd->res != H2C_SUCCESS) {
> >  		/* TODO: cancel timer and do timeout handler directly... */
> > -		/* need to make timeout handlerOS independent */
> > -		_set_timer(&pmlmepriv->scan_to_timer, 1);
> > -		} else if (pcmd->res != H2C_SUCCESS) {
> >  		_set_timer(&pmlmepriv->scan_to_timer, 1);
> >  	}
> >  
> 
> Is it okay if I submit a patch to implement your suggestion? I would
> include a "Suggested-by" tag.

Yes, that's always okay.

I would probably send it as one patch, but I suggest you would be better
off sending it as two uncontroversial patches.  patch 1: delete the
"handlerOS independent" comment.  Patch2: combine both sides of the if
statement.

regards,
dan carpenter

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-03-31 12:22 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-03-29  7:53 [PATCH] staging: r8188eu: fix suspect code indent for conditional statements Rebecca Mckeever
2022-03-29 16:16 ` Alison Schofield
2022-03-30  0:48   ` Rebecca Mckeever
2022-03-30  1:09     ` Alison Schofield
2022-03-30  6:28   ` Dan Carpenter
2022-03-31 12:06     ` Rebecca Mckeever
2022-03-31 12:21       ` Dan Carpenter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).