linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v6 0/8] scsi: libsas: sas address comparison refactor
@ 2022-09-28  7:01 Jason Yan
  2022-09-28  7:01 ` [PATCH v6 1/8] scsi: libsas: introduce sas address comparison helpers Jason Yan
                   ` (9 more replies)
  0 siblings, 10 replies; 22+ messages in thread
From: Jason Yan @ 2022-09-28  7:01 UTC (permalink / raw)
  To: martin.petersen, jejb
  Cc: linux-scsi, linux-kernel, hare, hch, bvanassche, john.garry,
	jinpu.wang, damien.lemoal, Jason Yan

Sas address conversion and comparison is widely used in libsas and
drivers. However they are all opencoded and to avoid the line spill over
80 columns, are mostly split into multi-lines.

To make the code easier to read, introduce some helpers with clearer
semantics and replace the opencoded segments with them.

v5->v6:
  Return error coding style update suggested by Damien.

v4->v5:
  Rename sas_find_attached_phy() to sas_find_attached_phy_id().
  Return error code from sas_find_attached_phy_id() directly.
  Add review tags from John and Damien.

v3->v4:
  Fix comparison typo.
  Fix test condition error in sas_check_parent_topology() of patch #6.

v2->v3:
  Rename sas_phy_addr_same() to sas_phy_addr_match().
  Rearrange patches, move patch #6 to #1 and directly use the helper
  	sas_phy_match_dev_addr() in sas_find_attached_phy().
  Add some review tags from Jack Wang.

v1->v2:
  First factor out sas_find_attached_phy() and replace LLDDs's code
  	with it.
  Remove three too simple helpers.
  Rename the helpers with 'sas_' prefix.

Jason Yan (8):
  scsi: libsas: introduce sas address comparison helpers
  scsi: libsas: introduce sas_find_attached_phy_id() helper
  scsi: pm8001: use sas_find_attached_phy_id() instead of open coded
  scsi: mvsas: use sas_find_attached_phy_id() instead of open coded
  scsi: hisi_sas: use sas_find_attathed_phy_id() instead of open coded
  scsi: libsas: use sas_phy_match_dev_addr() instead of open coded
  scsi: libsas: use sas_phy_addr_match() instead of open coded
  scsi: libsas: use sas_phy_match_port_addr() instead of open coded

 drivers/scsi/hisi_sas/hisi_sas_main.c | 14 ++--------
 drivers/scsi/libsas/sas_expander.c    | 40 ++++++++++++++++-----------
 drivers/scsi/libsas/sas_internal.h    | 17 ++++++++++++
 drivers/scsi/mvsas/mv_sas.c           | 17 ++++--------
 drivers/scsi/pm8001/pm8001_sas.c      | 18 ++++--------
 include/scsi/libsas.h                 |  2 ++
 6 files changed, 57 insertions(+), 51 deletions(-)

-- 
2.31.1


^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2022-10-22  3:53 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-09-28  7:01 [PATCH v6 0/8] scsi: libsas: sas address comparison refactor Jason Yan
2022-09-28  7:01 ` [PATCH v6 1/8] scsi: libsas: introduce sas address comparison helpers Jason Yan
2022-09-28  7:25   ` Johannes Thumshirn
2022-09-28  7:01 ` [PATCH v6 2/8] scsi: libsas: introduce sas_find_attached_phy_id() helper Jason Yan
2022-09-28  7:26   ` Johannes Thumshirn
2022-09-28  7:01 ` [PATCH v6 3/8] scsi: pm8001: use sas_find_attached_phy_id() instead of open coded Jason Yan
2022-09-28  7:02   ` Damien Le Moal
2022-09-28  7:29     ` Jason Yan
2022-09-28  7:27   ` Johannes Thumshirn
2022-09-28  7:01 ` [PATCH v6 4/8] scsi: mvsas: " Jason Yan
2022-09-28  7:27   ` Johannes Thumshirn
2022-09-28  7:01 ` [PATCH v6 5/8] scsi: hisi_sas: use sas_find_attathed_phy_id() " Jason Yan
2022-09-28  7:27   ` Johannes Thumshirn
2022-09-28  7:58   ` John Garry
2022-09-28  7:01 ` [PATCH v6 6/8] scsi: libsas: use sas_phy_match_dev_addr() " Jason Yan
2022-09-28  7:37   ` Johannes Thumshirn
2022-09-28  7:01 ` [PATCH v6 7/8] scsi: libsas: use sas_phy_addr_match() " Jason Yan
2022-09-28  7:38   ` Johannes Thumshirn
2022-09-28  7:01 ` [PATCH v6 8/8] scsi: libsas: use sas_phy_match_port_addr() " Jason Yan
2022-09-28  7:38   ` Johannes Thumshirn
2022-10-18  3:28 ` [PATCH v6 0/8] scsi: libsas: sas address comparison refactor Martin K. Petersen
2022-10-22  3:52 ` Martin K. Petersen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).