linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v4 00/13] Add support for IIO devices in ASoC
@ 2023-06-14  7:48 Herve Codina
  2023-06-14  7:48 ` [PATCH v4 01/13] ASoC: dt-bindings: Add audio-iio-aux Herve Codina
                   ` (12 more replies)
  0 siblings, 13 replies; 26+ messages in thread
From: Herve Codina @ 2023-06-14  7:48 UTC (permalink / raw)
  To: Herve Codina, Liam Girdwood, Mark Brown, Rob Herring,
	Krzysztof Kozlowski, Conor Dooley, Jonathan Cameron,
	Lars-Peter Clausen, Jaroslav Kysela, Takashi Iwai,
	Kuninori Morimoto, Andy Shevchenko
  Cc: alsa-devel, devicetree, linux-kernel, linux-iio,
	Christophe Leroy, Thomas Petazzoni

Several weeks ago, I sent a series [1] for adding a potentiometer as an
auxiliary device in ASoC. The feedback was that the potentiometer should
be directly handled in IIO (as other potentiometers) and something more
generic should be present in ASoC in order to have a binding to import
some IIO devices into sound cards.

The series related to the IIO potentiometer device is already applied.

This series introduces audio-iio-aux. Its goal is to offer the binding
between IIO and ASoC.
It exposes attached IIO devices as ASoC auxiliary devices and allows to
control them through mixer controls.

On my system, the IIO device is a potentiometer and it is present in an
amplifier design present in the audio path.

Compare to the previous iteration
  https://lore.kernel.org/linux-kernel/20230612122926.107333-1-herve.codina@bootlin.com/
This v4 series mainly:
 - Fixes headers inclusion
 - Removes unneeded variable initialization
 - Adds a missing error check
 - Fixes typos

Best regards,
Hervé

[1] https://lore.kernel.org/linux-kernel/20230203111422.142479-1-herve.codina@bootlin.com/
[2] https://lore.kernel.org/linux-kernel/20230421085245.302169-1-herve.codina@bootlin.com/

Changes v3 -> v4
  - Patches 1, 2
    No changes.

  - Patches 3, 4, 5
    Add 'Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>'.

  - Patch 6 (new in v4)
    Fix headers inclusion order.

  - Patch 7 (patch 6 in v3)
    Add a comment related to __must_be_array()
    Use __array[0] of *__array

  - Patch 8 (patch 7 in v3)
    Fix minmax.h inclusion order.
    Add 'Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>'.

  - Patch 9 (patch 8 in v3)
    Add 'Suggested-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>'.
    Add 'Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>'.

  - Patch 10 (patch 9 in v3)
    Add 'Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>'.

  - Patch 11 (patch 10 in v3)
    Fix a typo.
    Add	'Suggested-by: Andy Shevchenko <andy.shevchenko@gmail.com>'.
    Add	'Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>'.

  - Patch 12 (patch 11 in v3)
    Fix typos in the commit log.
    Fix headers inclusion order.
    Removed unneeded variable initialization.
    Replace {0} by {}.
    Use struct device *dev in probe().
    Check an error on the snd-control-invert-range property read.

  - Patch 13 (patch12 in v3)
    No changes.

Changes v2 -> v3
  - Patches 1, 2
    No changes.

  - Patch 3, 4
    Add 'Acked-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>'.

  - Patch 5 (new in v3)
    Removed the 'unused' variable and check the null pointer when used.

  - Patch 6 (new in v3)
    Introduce {min,max}_array().

  - Patch 7 (new in v3)
    Use max_array() in iio_channel_read_max().

  - Patch 8 (new in v3)
    Replace a FIXME comment by a TODO one.

  - Patch 9 (patch 5 in v2)
    Removed the 'unused' variable and check the null pointer when used.
    Use min_array().
    Remplace a FIXME comment by a TODO one.

  - Patch 10 (patch 6 in v2)
    Convert existing macros to return a compound litteral instead of
    adding a new helper.

  - Patch 11 (patch 7 in v2)
    Remove the file name from the C file header.
    Use directly converted DAPM macros.
    Replace <linux/module.h> by <linux/mod_devicetable.h>.
    Add <linux/platform_device.h>.
    Be sure that min <= max. Swap values if it is not the case.
    Move the bool structure member after the int ones.
    Remove unneeded assignements.
    Use dev_err_probe() when relevant.
    Use str_on_off().
    Use static_assert() instead of BUILD_BUG_ON().
    Remove unneeded comma and blank line.
    Use device_property_*() instead of the OF API.

  - patch 8 available in v2 removed as already applied

  - Patch 12 (patch 9 in v2)
    Use devm_add_action_or_reset().
    Call simple_populate_aux() from simple_parse_of().

Changes v1 -> v2
  - Patch 1
    Rename simple-iio-aux to audio-iio-aux
    Rename invert to snd-control-invert-range
    Remove the /schemas/iio/iio-consumer.yaml reference
    Remove the unneeded '|' after description

  - Patch 2 (new in v2)
    Introduce the simple-audio-card additional-devs subnode

  - Patch 3 (new in v2)
    Check err before switch() in iio_channel_read_max()

  - Patch 4 (new in v2)
    Fix raw reads and raw writes documentation

  - Patch 5 (patch 2 in v1)
    Check err before switch() in iio_channel_read_min()
    Fix documentation

  - Patch 6 (path 3 in v1)
    No changes

  - Patch 7 (patch 4 in v1)
    Rename simple-iio-aux to audio-iio-aux
    Rename invert to snd-control-invert-range
    Remove the mask usage from audio_iio_aux_{get,put}_volsw helpers
    Use directly PTR_ERR() in dev_err_probe() parameter
    Remove the '!!' construction
    Remove of_match_ptr()

  - Patch 8 (new in v2)
    Add a missing of_node_put() in the simple-card driver

  - Patch 9 (new in v2)
    Handle additional-devs in the simple-card driver

Herve Codina (13):
  ASoC: dt-bindings: Add audio-iio-aux
  ASoC: dt-bindings: simple-card: Add additional-devs subnode
  iio: inkern: Check error explicitly in iio_channel_read_max()
  iio: consumer.h: Fix raw values documentation notes
  iio: inkern: Remove the 'unused' variable usage in
    iio_channel_read_max()
  iio: inkern: Fix headers inclusion order
  minmax: Introduce {min,max}_array()
  iio: inkern: Use max_array() to get the maximum value from an array
  iio: inkern: Replace a FIXME comment by a TODO one
  iio: inkern: Add a helper to query an available minimum raw value
  ASoC: soc-dapm.h: Convert macros to return a compound literal
  ASoC: codecs: Add support for the generic IIO auxiliary devices
  ASoC: simple-card: Handle additional devices

 .../bindings/sound/audio-iio-aux.yaml         |  64 ++++
 .../bindings/sound/simple-card.yaml           |  53 +++
 drivers/iio/inkern.c                          |  86 ++++-
 include/linux/iio/consumer.h                  |  37 +-
 include/linux/minmax.h                        |  36 ++
 include/sound/soc-dapm.h                      | 138 ++++---
 sound/soc/codecs/Kconfig                      |  12 +
 sound/soc/codecs/Makefile                     |   2 +
 sound/soc/codecs/audio-iio-aux.c              | 338 ++++++++++++++++++
 sound/soc/generic/simple-card.c               |  46 ++-
 10 files changed, 741 insertions(+), 71 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/sound/audio-iio-aux.yaml
 create mode 100644 sound/soc/codecs/audio-iio-aux.c

-- 
2.40.1


^ permalink raw reply	[flat|nested] 26+ messages in thread

end of thread, other threads:[~2023-06-16 12:42 UTC | newest]

Thread overview: 26+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-06-14  7:48 [PATCH v4 00/13] Add support for IIO devices in ASoC Herve Codina
2023-06-14  7:48 ` [PATCH v4 01/13] ASoC: dt-bindings: Add audio-iio-aux Herve Codina
2023-06-14  7:48 ` [PATCH v4 02/13] ASoC: dt-bindings: simple-card: Add additional-devs subnode Herve Codina
2023-06-14  7:48 ` [PATCH v4 03/13] iio: inkern: Check error explicitly in iio_channel_read_max() Herve Codina
2023-06-14  7:48 ` [PATCH v4 04/13] iio: consumer.h: Fix raw values documentation notes Herve Codina
2023-06-14  7:48 ` [PATCH v4 05/13] iio: inkern: Remove the 'unused' variable usage in iio_channel_read_max() Herve Codina
2023-06-14  7:48 ` [PATCH v4 06/13] iio: inkern: Fix headers inclusion order Herve Codina
2023-06-14  8:58   ` Andy Shevchenko
2023-06-14  7:48 ` [PATCH v4 07/13] minmax: Introduce {min,max}_array() Herve Codina
2023-06-14  9:02   ` Andy Shevchenko
2023-06-14  9:42     ` Herve Codina
2023-06-14 11:51       ` Andy Shevchenko
2023-06-14 20:34         ` Herve Codina
2023-06-14 22:05           ` Andy Shevchenko
2023-06-15  9:35             ` Herve Codina
2023-06-15 13:51               ` Andy Shevchenko
2023-06-16  9:08               ` David Laight
2023-06-16 11:48                 ` Herve Codina
2023-06-16 12:42                   ` David Laight
2023-06-14  7:48 ` [PATCH v4 08/13] iio: inkern: Use max_array() to get the maximum value from an array Herve Codina
2023-06-14  9:03   ` Andy Shevchenko
2023-06-14  7:49 ` [PATCH v4 09/13] iio: inkern: Replace a FIXME comment by a TODO one Herve Codina
2023-06-14  7:49 ` [PATCH v4 10/13] iio: inkern: Add a helper to query an available minimum raw value Herve Codina
2023-06-14  7:49 ` [PATCH v4 11/13] ASoC: soc-dapm.h: Convert macros to return a compound literal Herve Codina
2023-06-14  7:49 ` [PATCH v4 12/13] ASoC: codecs: Add support for the generic IIO auxiliary devices Herve Codina
2023-06-14  7:49 ` [PATCH v4 13/13] ASoC: simple-card: Handle additional devices Herve Codina

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).