linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Daniel Lezcano <daniel.lezcano@linaro.org>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
	Viresh Kumar <viresh.kumar@linaro.org>,
	Eduardo Valentin <edubezval@gmail.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"open list:CPU FREQUENCY SCALING FRAMEWORK" 
	<linux-pm@vger.kernel.org>
Subject: Re: [PATCH 1/6] cpufreq: Use existing stub functions instead of IS_ENABLED macro
Date: Mon, 24 Jun 2019 11:30:07 +0200	[thread overview]
Message-ID: <2097869.93pjHihJNk@kreacher> (raw)
In-Reply-To: <b817a599-6564-b3d0-9c91-59c3fd5b5eb1@linaro.org>

On Monday, June 24, 2019 11:22:19 AM CEST Daniel Lezcano wrote:
> On 22/06/2019 11:12, Rafael J. Wysocki wrote:
> > On Fri, Jun 21, 2019 at 3:23 PM Daniel Lezcano
> > <daniel.lezcano@linaro.org> wrote:
> >>
> >> The functions stub already exist for the condition the IS_ENABLED
> >> is trying to avoid.
> >>
> >> Remove the IS_ENABLED macros as they are pointless.
> > 
> > AFAICS, the IS_ENABLED checks are an optimization to avoid generating
> > pointless code (including a branch) in case CONFIG_CPU_THERMAL is not
> > set.
> > 
> > Why do you think that it is not useful?
> 
> I agree but I'm not a big fan of IS_ENABLED macros in the code when it
> is possible to avoid them.
> 
> What about adding a stub for that like:

Well,

> #ifdef CPU_THERMAL
> static inline int cpufreq_is_cooling_dev(struct cpufreq_driver *drv)
> {
> 	return drv->flags & CPUFREQ_IS_COOLING_DEV;
> }
> #else
> static inline int cpufreq_is_cooling_dev(struct cpufreq_driver *drv)
> {
> 	return 0;
> }
> #endif

This may as well be defined as

static inline int cpufreq_is_cooling_dev(struct cpufreq_driver *drv)
{
	return IS_ENABLED(CPU_THERMAL) && drv->flags & CPUFREQ_IS_COOLING_DEV;
}

which is fewer lines of code.

And I would call it something like cpufreq_thermal_control_enabled().




  reply	other threads:[~2019-06-24  9:30 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-21 13:22 [PATCH 1/6] cpufreq: Use existing stub functions instead of IS_ENABLED macro Daniel Lezcano
2019-06-21 13:22 ` [PATCH 2/6] thermal/drivers/cpu_cooling: Unregister with the policy Daniel Lezcano
2019-06-24  6:03   ` Viresh Kumar
2019-06-24  7:30     ` Daniel Lezcano
2019-06-24  7:37       ` Viresh Kumar
2019-06-24  7:45         ` Daniel Lezcano
2019-06-24  9:39           ` Viresh Kumar
2019-06-21 13:22 ` [PATCH 3/6] cpufreq/drivers/arm_big_little: Remove cooling device usage Daniel Lezcano
2019-06-24  6:04   ` Viresh Kumar
2019-06-21 13:23 ` [PATCH 4/6] cpufreq: " Daniel Lezcano
2019-06-24  6:05   ` Viresh Kumar
2019-06-21 13:23 ` [PATCH 5/6] thermal/drivers/imx: " Daniel Lezcano
2019-06-24  6:06   ` Viresh Kumar
2019-06-21 13:23 ` [PATCH 6/6] thermal/drivers/ti: " Daniel Lezcano
2019-06-24  6:06   ` Viresh Kumar
2019-06-22  9:12 ` [PATCH 1/6] cpufreq: Use existing stub functions instead of IS_ENABLED macro Rafael J. Wysocki
2019-06-24  9:22   ` Daniel Lezcano
2019-06-24  9:30     ` Rafael J. Wysocki [this message]
2019-06-24  9:37       ` Daniel Lezcano
2019-06-24  8:53 ` Daniel Lezcano
2019-06-24  9:00   ` Rafael J. Wysocki
2019-06-24  9:07     ` Daniel Lezcano
2019-06-24  9:08   ` Viresh Kumar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2097869.93pjHihJNk@kreacher \
    --to=rjw@rjwysocki.net \
    --cc=daniel.lezcano@linaro.org \
    --cc=edubezval@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=viresh.kumar@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).