linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Randy Dunlap <rdunlap@infradead.org>
To: paulmck@linux.vnet.ibm.com, Joe Perches <joe@perches.com>
Cc: Josh Triplett <josh@joshtriplett.org>,
	Steven Rostedt <rostedt@goodmis.org>,
	Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
	Lai Jiangshan <jiangshanlai@gmail.com>,
	Davidlohr Bueso <dave@stgolabs.net>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 18/18] rcu: Use pr_fmt to prefix "rcu: " to logging output
Date: Mon, 14 May 2018 13:52:48 -0700	[thread overview]
Message-ID: <2b66d372-dac9-0fad-af44-bfa84d996985@infradead.org> (raw)
In-Reply-To: <20180514202910.GI26088@linux.vnet.ibm.com>

On 05/14/2018 01:29 PM, Paul E. McKenney wrote:
> On Thu, May 10, 2018 at 08:45:44AM -0700, Joe Perches wrote:
>> Use a consistent logging prefix for all rcu related output.
>>
>> Signed-off-by: Joe Perches <joe@perches.com>
> 
> I took parts of this (thank you!) but have concerns about other parts.
> 
>> ---
>>  kernel/rcu/rcu_segcblist.c |  2 ++
>>  kernel/rcu/rcuperf.c       | 10 ++++---
>>  kernel/rcu/rcutorture.c    | 46 +++++++++++++++----------------
>>  kernel/rcu/srcutiny.c      |  2 ++
>>  kernel/rcu/srcutree.c      |  5 +++-
>>  kernel/rcu/tiny.c          |  3 +++
>>  kernel/rcu/tree.c          |  8 +++---
>>  kernel/rcu/tree_plugin.h   | 67 +++++++++++++++++++++++++++-------------------
>>  kernel/rcu/update.c        | 19 ++++++++-----
>>  9 files changed, 96 insertions(+), 66 deletions(-)
>>

>> diff --git a/kernel/rcu/rcutorture.c b/kernel/rcu/rcutorture.c
>> index 648e1c25707d..45d98ff0d5b8 100644
>> --- a/kernel/rcu/rcutorture.c
>> +++ b/kernel/rcu/rcutorture.c
>> @@ -22,6 +22,7 @@
>>   *
>>   * See also:  Documentation/RCU/torture.txt
>>   */
>> +
>>  #include <linux/types.h>
>>  #include <linux/kernel.h>
>>  #include <linux/init.h>
>> @@ -908,7 +909,7 @@ rcu_torture_writer(void *arg)
>>  	VERBOSE_TOROUT_STRING("rcu_torture_writer task started");
>>  	if (!can_expedite)
>>  		pr_alert("%s" TORTURE_FLAG
>> -			 " GP expediting controlled from boot/sysfs for %s.\n",
>> +			 " GP expediting controlled from boot/sysfs for %s\n",
>>  			 torture_type, cur_ops->name);
>>
>>  	/* Initialize synctype[] array.  If none set, take default. */
>> @@ -916,27 +917,27 @@ rcu_torture_writer(void *arg)
>>  		gp_cond1 = gp_exp1 = gp_normal1 = gp_sync1 = true;
>>  	if (gp_cond1 && cur_ops->get_state && cur_ops->cond_sync) {
>>  		synctype[nsynctypes++] = RTWS_COND_GET;
>> -		pr_info("%s: Testing conditional GPs.\n", __func__);
>> +		pr_info("%s: Testing conditional GPs\n", __func__);
>>  	} else if (gp_cond && (!cur_ops->get_state || !cur_ops->cond_sync)) {
>> -		pr_alert("%s: gp_cond without primitives.\n", __func__);
>> +		pr_alert("%s: gp_cond without primitives\n", __func__);
>>  	}
>>  	if (gp_exp1 && cur_ops->exp_sync) {
>>  		synctype[nsynctypes++] = RTWS_EXP_SYNC;
>> -		pr_info("%s: Testing expedited GPs.\n", __func__);
>> +		pr_info("%s: Testing expedited GPs\n", __func__);
>>  	} else if (gp_exp && !cur_ops->exp_sync) {
>> -		pr_alert("%s: gp_exp without primitives.\n", __func__);
>> +		pr_alert("%s: gp_exp without primitives\n", __func__);

Unlike some of the others, the one above is not a sentence, so it doesn't
_need_ a period ... except for consistency.

But I don't care either way. :)

>>  	}
>>  	if (gp_normal1 && cur_ops->deferred_free) {
>>  		synctype[nsynctypes++] = RTWS_DEF_FREE;
>> -		pr_info("%s: Testing asynchronous GPs.\n", __func__);
>> +		pr_info("%s: Testing asynchronous GPs\n", __func__);
>>  	} else if (gp_normal && !cur_ops->deferred_free) {
>> -		pr_alert("%s: gp_normal without primitives.\n", __func__);
>> +		pr_alert("%s: gp_normal without primitives\n", __func__);
>>  	}
>>  	if (gp_sync1 && cur_ops->sync) {
>>  		synctype[nsynctypes++] = RTWS_SYNC;
>> -		pr_info("%s: Testing normal GPs.\n", __func__);
>> +		pr_info("%s: Testing normal GPs\n", __func__);
>>  	} else if (gp_sync && !cur_ops->sync) {
>> -		pr_alert("%s: gp_sync without primitives.\n", __func__);
>> +		pr_alert("%s: gp_sync without primitives\n", __func__);








-- 
~Randy

  parent reply	other threads:[~2018-05-14 20:53 UTC|newest]

Thread overview: 70+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-10 15:45 [PATCH 00/18] Convert default pr_fmt from empty to KBUILD_MODNAME Joe Perches
2018-05-10 15:45 ` [PATCH 01/18] kernel: Use pr_fmt Joe Perches
2018-05-10 16:14   ` Paul Moore
2018-05-10 19:05   ` Kees Cook
2018-05-13 19:17   ` Jessica Yu
2018-05-14 13:38   ` Masami Hiramatsu
2018-05-14 18:06   ` Paul E. McKenney
2018-05-14 18:59   ` Paul Moore
2018-05-10 15:45 ` [PATCH 02/18] lib: " Joe Perches
2018-05-10 15:45 ` [PATCH 03/18] printk: Convert pr_fmt from blank define to KBUILD_MODNAME Joe Perches
2018-05-10 16:28   ` Steven Rostedt
2018-05-11 21:39     ` [PATCH] ring_buffer: Update logging to use single line output Joe Perches
2018-07-12  2:57       ` Steven Rostedt
2018-07-12  4:42         ` Joe Perches
2018-07-12 13:00           ` Steven Rostedt
2018-05-11  1:51   ` [PATCH 03/18] printk: Convert pr_fmt from blank define to KBUILD_MODNAME Sergey Senozhatsky
2018-05-11  1:57     ` Joe Perches
2018-05-11  2:12       ` Joe Perches
2018-05-11  2:24       ` Sergey Senozhatsky
2018-05-11  2:23     ` Sergey Senozhatsky
2018-05-11  2:33       ` Joe Perches
2018-05-11  2:41         ` Sergey Senozhatsky
2018-05-11  2:57           ` Joe Perches
2018-05-18  8:42   ` Petr Mladek
2018-05-18  9:10     ` Joe Perches
2018-05-18 20:29       ` Andy Shevchenko
2018-05-19  2:05         ` Joe Perches
2018-05-19 18:27           ` Andy Shevchenko
2018-05-10 15:45 ` [PATCH 04/18] x86: Remove pr_fmt duplicate logging prefixes Joe Perches
2018-05-13 19:27   ` [tip:x86/cleanups] " tip-bot for Joe Perches
2018-05-17 18:27     ` Borislav Petkov
2018-05-17 18:43       ` Joe Perches
2018-05-17 19:14         ` Thomas Gleixner
2019-02-21  6:25         ` Bjorn Helgaas
2018-05-10 15:45 ` [PATCH 05/18] x86/mtrr: Rename main.c to mtrr.c and remove duplicate prefixes Joe Perches
2018-05-13 19:28   ` [tip:x86/cleanups] " tip-bot for Joe Perches
2018-05-10 15:45 ` [PATCH 06/18] net: Remove pr_fmt duplicate logging prefixes Joe Perches
2018-05-10 15:45 ` [PATCH 07/18] blk-mq: " Joe Perches
2018-05-10 15:45 ` [PATCH 08/18] random: " Joe Perches
2018-05-10 15:45 ` [PATCH 09/18] ptp: " Joe Perches
2018-05-10 19:35   ` Richard Cochran
2018-05-10 15:45 ` [PATCH 10/18] efifb: " Joe Perches
2018-05-10 15:45 ` [PATCH 11/18] proc: " Joe Perches
2018-05-10 15:45 ` [PATCH 12/18] uprobes: " Joe Perches
2018-05-10 15:45 ` [PATCH 13/18] printk: " Joe Perches
2018-05-11  1:54   ` Sergey Senozhatsky
2018-05-18  8:43   ` Petr Mladek
2018-05-10 15:45 ` [PATCH 14/18] lib/mpi: " Joe Perches
2018-05-10 15:45 ` [PATCH 15/18] security: " Joe Perches
2018-05-10 16:15   ` Paul Moore
2018-05-10 15:45 ` [PATCH 16/18] aoe: " Joe Perches
2018-05-10 15:45 ` [PATCH 17/18] security: encrypted-keys: " Joe Perches
2018-05-10 18:09   ` James Morris
2018-05-10 15:45 ` [PATCH 18/18] rcu: Use pr_fmt to prefix "rcu: " to logging output Joe Perches
2018-05-14 20:29   ` Paul E. McKenney
2018-05-14 20:37     ` Andy Shevchenko
2018-05-14 21:08       ` Paul E. McKenney
2018-05-14 20:52     ` Randy Dunlap [this message]
2018-05-14 21:05       ` Paul E. McKenney
2018-05-14 21:41     ` Joe Perches
2018-05-14 22:24       ` Paul E. McKenney
2018-05-14 22:54         ` Joe Perches
2018-05-14 23:58           ` Paul E. McKenney
2018-05-15  0:23             ` Joe Perches
2018-05-15  0:32               ` Paul E. McKenney
2018-05-15  1:22                 ` Joe Perches
2018-05-15  3:41                   ` Paul E. McKenney
2018-05-15 19:28                 ` Paul E. McKenney
2018-05-15 21:11                   ` Joe Perches
2018-05-15 21:23                     ` Paul E. McKenney

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2b66d372-dac9-0fad-af44-bfa84d996985@infradead.org \
    --to=rdunlap@infradead.org \
    --cc=dave@stgolabs.net \
    --cc=jiangshanlai@gmail.com \
    --cc=joe@perches.com \
    --cc=josh@joshtriplett.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=paulmck@linux.vnet.ibm.com \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).