linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: Rob Herring <robh@kernel.org>
Cc: x86@kernel.org, linux-kernel@vger.kernel.org,
	Fenghua Yu <fenghua.yu@intel.com>,
	Reinette Chatre <reinette.chatre@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	Jamie Iles <jamie@nuviainc.com>,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	lcherian@marvell.com, bobo.shaobowang@huawei.com,
	tan.shaopeng@fujitsu.com
Subject: Re: [PATCH v3 21/21] x86/resctrl: Make resctrl_arch_rmid_read() return values in bytes
Date: Mon, 4 Apr 2022 17:36:02 +0100	[thread overview]
Message-ID: <30d85009-f4be-25b1-7eb8-eea4b3058e27@arm.com> (raw)
In-Reply-To: <YjuOWpqLfiP4u2AT@robh.at.kernel.org>

Hi Rob,

On 3/23/22 21:17, Rob Herring wrote:
> On Thu, Feb 17, 2022 at 06:21:10PM +0000, James Morse wrote:
>> resctrl_arch_rmid_read() returns a value in chunks, as read from the
>> hardware. This needs scaling to bytes by mon_scale, as provided by
>> the architecture code.
>>
>> Now that resctrl_arch_rmid_read() performs the overflow and corrections
>> itself, it may as well return a value in bytes directly. This allows
>> the accesses to the architecture specific 'hw' structure to be removed.
>>
>> Move the mon_scale conversion into resctrl_arch_rmid_read().
>> mbm_bw_count() is updated to calculate bandwidth from bytes.

>> diff --git a/arch/x86/kernel/cpu/resctrl/monitor.c b/arch/x86/kernel/cpu/resctrl/monitor.c
>> index 3a6555f49720..437e7db77f93 100644
>> --- a/arch/x86/kernel/cpu/resctrl/monitor.c
>> +++ b/arch/x86/kernel/cpu/resctrl/monitor.c
>> @@ -211,10 +211,11 @@ int resctrl_arch_rmid_read(struct rdt_resource *r, struct rdt_domain *d,
>>   	if (am) {
>>   		am->chunks += mbm_overflow_count(am->prev_msr, msr_val,
>>   						 hw_res->mbm_width);
>> -		*val = get_corrected_mbm_count(rmid, am->chunks);
>> +		chunks = get_corrected_mbm_count(rmid, am->chunks);
>> +		*val = chunks * hw_res->mon_scale;
> 
> This can be moved out of the if/else if you make the following change:
> 
>>   		am->prev_msr = msr_val;
>>   	} else {
>> -		*val = msr_val;
>> +		*val = msr_val * hw_res->mon_scale;
> 
> chunks = msr_val;
> 
>>   	}

Sure, I guess it makes sense to only set *val in one place.

>>   
>>   	return 0;
>> @@ -400,15 +397,14 @@ static u64 __mon_event_count(u32 rmid, struct rmid_read *rr)
>>    */
>>   static void mbm_bw_count(u32 rmid, struct rmid_read *rr)
>>   {
>> -	struct rdt_hw_resource *hw_res = resctrl_to_arch_res(rr->r);
>>   	struct mbm_state *m = &rr->d->mbm_local[rmid];
>> -	u64 cur_bw, chunks, cur_chunks;
>> +	u64 cur_bw, bytes, cur_bytes;
>>   
>> -	cur_chunks = rr->val;
>> -	chunks = cur_chunks - m->prev_bw_chunks;
>> -	m->prev_bw_chunks = cur_chunks;
>> +	cur_bytes = rr->val;
>> +	bytes = cur_bytes - m->prev_bw_bytes;
>> +	m->prev_bw_bytes = cur_bytes;
>>   
>> -	cur_bw = (chunks * hw_res->mon_scale) >> 20;
>> +	cur_bw = bytes >> 20;
> 
> 'bytes / SZ_1M' would be more readable and any decent compiler should
> optimize a power of 2 divide. But maybe that's a separate change as
> there are other cases of bytes to MB.

I agree its more readable. As I've touched this one, I'll change it.


Thanks,

James

  reply	other threads:[~2022-04-04 21:23 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-02-17 18:20 [PATCH v3 00/21] x86/resctrl: Make resctrl_arch_rmid_read() return values in bytes James Morse
2022-02-17 18:20 ` [PATCH v3 01/21] x86/resctrl: Kill off alloc_enabled James Morse
2022-03-16 21:48   ` Reinette Chatre
2022-02-17 18:20 ` [PATCH v3 02/21] x86/resctrl: Merge mon_capable and mon_enabled James Morse
2022-02-17 18:20 ` [PATCH v3 03/21] x86/resctrl: Add domain online callback for resctrl work James Morse
2022-02-17 18:20 ` [PATCH v3 04/21] x86/resctrl: Group struct rdt_hw_domain cleanup James Morse
2022-02-17 18:20 ` [PATCH v3 05/21] x86/resctrl: Add domain offline callback for resctrl work James Morse
2022-02-17 18:20 ` [PATCH v3 06/21] x86/resctrl: Remove set_mba_sc()s control array re-initialisation James Morse
2022-02-17 18:20 ` [PATCH v3 07/21] x86/resctrl: Create mba_sc configuration in the rdt_domain James Morse
2022-03-05  0:26   ` Reinette Chatre
2022-03-30 16:43     ` James Morse
2022-03-16 21:50   ` Reinette Chatre
2022-03-30 16:43     ` James Morse
2022-04-01 22:54       ` Reinette Chatre
2022-04-04 16:35         ` James Morse
2022-04-04 20:43           ` Reinette Chatre
2022-02-17 18:20 ` [PATCH v3 08/21] x86/resctrl: Switch over to the resctrl mbps_val list James Morse
2022-02-17 18:20 ` [PATCH v3 09/21] x86/resctrl: Remove architecture copy of mbps_val James Morse
2022-02-17 18:20 ` [PATCH v3 10/21] x86/resctrl: Abstract and use supports_mba_mbps() James Morse
2022-02-17 18:21 ` [PATCH v3 11/21] x86/resctrl: Allow update_mba_bw() to update controls directly James Morse
2022-02-17 18:21 ` [PATCH v3 12/21] x86/resctrl: Calculate bandwidth from the previous __mon_event_count() chunks James Morse
2022-03-05  0:27   ` Reinette Chatre
2022-03-30 16:44     ` James Morse
2022-02-17 18:21 ` [PATCH v3 13/21] x86/recstrl: Add per-rmid arch private storage for overflow and chunks James Morse
2022-03-16 21:50   ` Reinette Chatre
2022-02-17 18:21 ` [PATCH v3 14/21] x86/recstrl: Allow per-rmid arch private storage to be reset James Morse
2022-03-16 21:50   ` Reinette Chatre
2022-02-17 18:21 ` [PATCH v3 15/21] x86/resctrl: Abstract __rmid_read() James Morse
2022-03-16 21:52   ` Reinette Chatre
2022-03-30 16:44     ` James Morse
2022-02-17 18:21 ` [PATCH v3 16/21] x86/resctrl: Pass the required parameters into resctrl_arch_rmid_read() James Morse
2022-03-23 20:58   ` Rob Herring
2022-03-30 16:45     ` James Morse
2022-02-17 18:21 ` [PATCH v3 17/21] x86/resctrl: Move mbm_overflow_count() " James Morse
2022-02-17 18:21 ` [PATCH v3 18/21] x86/resctrl: Move get_corrected_mbm_count() " James Morse
2022-02-17 18:21 ` [PATCH v3 19/21] x86/resctrl: Rename and change the units of resctrl_cqm_threshold James Morse
2022-03-17 17:00   ` Reinette Chatre
2022-03-30 16:45     ` James Morse
2022-04-01 22:55       ` Reinette Chatre
2022-02-17 18:21 ` [PATCH v3 20/21] x86/resctrl: Add resctrl_rmid_realloc_limit to abstract x86's boot_cpu_data James Morse
2022-02-17 18:21 ` [PATCH v3 21/21] x86/resctrl: Make resctrl_arch_rmid_read() return values in bytes James Morse
2022-03-23 21:17   ` Rob Herring
2022-04-04 16:36     ` James Morse [this message]
2022-03-07 12:56 ` [PATCH v3 00/21] " Jamie Iles
2022-04-04 16:36   ` James Morse
2022-03-15  6:41 ` Xin Hao
2022-04-04 16:36   ` James Morse
2022-03-15  8:16 ` tan.shaopeng
2022-04-04 16:35   ` James Morse

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=30d85009-f4be-25b1-7eb8-eea4b3058e27@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=jamie@nuviainc.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=reinette.chatre@intel.com \
    --cc=robh@kernel.org \
    --cc=scott@os.amperecomputing.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).