linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/
@ 2012-01-06 14:01 Hillf Danton
  2012-01-10  3:01 ` KAMEZAWA Hiroyuki
  2012-01-10  5:40 ` Rik van Riel
  0 siblings, 2 replies; 4+ messages in thread
From: Hillf Danton @ 2012-01-06 14:01 UTC (permalink / raw)
  To: linux-mm
  Cc: LKML, Andrew Morton, KAMEZAWA Hiroyuki, David Rientjes, Hillf Danton

With tons of reclaim_mode(defined as one field of struct scan_control) already
in the file, it is clearer to rename it when setting up the isolation mode.


Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
Cc: David Rientjes <rientjes@google.com>
Cc: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Hillf Danton <dhillf@gmail.com>
---

--- a/mm/vmscan.c	Thu Dec 29 20:20:16 2011
+++ b/mm/vmscan.c	Fri Jan  6 21:53:48 2012
@@ -1541,7 +1541,7 @@ shrink_inactive_list(unsigned long nr_to
 	unsigned long nr_file;
 	unsigned long nr_dirty = 0;
 	unsigned long nr_writeback = 0;
-	isolate_mode_t reclaim_mode = ISOLATE_INACTIVE;
+	isolate_mode_t isolate_mode = ISOLATE_INACTIVE;
 	struct zone *zone = mz->zone;

 	while (unlikely(too_many_isolated(zone, file, sc))) {
@@ -1554,20 +1554,20 @@ shrink_inactive_list(unsigned long nr_to

 	set_reclaim_mode(priority, sc, false);
 	if (sc->reclaim_mode & RECLAIM_MODE_LUMPYRECLAIM)
-		reclaim_mode |= ISOLATE_ACTIVE;
+		isolate_mode |= ISOLATE_ACTIVE;

 	lru_add_drain();

 	if (!sc->may_unmap)
-		reclaim_mode |= ISOLATE_UNMAPPED;
+		isolate_mode |= ISOLATE_UNMAPPED;
 	if (!sc->may_writepage)
-		reclaim_mode |= ISOLATE_CLEAN;
+		isolate_mode |= ISOLATE_CLEAN;

 	spin_lock_irq(&zone->lru_lock);

 	nr_taken = isolate_pages(nr_to_scan, mz, &page_list,
 				 &nr_scanned, sc->order,
-				 reclaim_mode, 0, file);
+				 isolate_mode, 0, file);
 	if (global_reclaim(sc)) {
 		zone->pages_scanned += nr_scanned;
 		if (current_is_kswapd())
@@ -1705,21 +1705,21 @@ static void shrink_active_list(unsigned
 	struct page *page;
 	struct zone_reclaim_stat *reclaim_stat = get_reclaim_stat(mz);
 	unsigned long nr_rotated = 0;
-	isolate_mode_t reclaim_mode = ISOLATE_ACTIVE;
+	isolate_mode_t isolate_mode = ISOLATE_ACTIVE;
 	struct zone *zone = mz->zone;

 	lru_add_drain();

 	if (!sc->may_unmap)
-		reclaim_mode |= ISOLATE_UNMAPPED;
+		isolate_mode |= ISOLATE_UNMAPPED;
 	if (!sc->may_writepage)
-		reclaim_mode |= ISOLATE_CLEAN;
+		isolate_mode |= ISOLATE_CLEAN;

 	spin_lock_irq(&zone->lru_lock);

 	nr_taken = isolate_pages(nr_pages, mz, &l_hold,
 				 &pgscanned, sc->order,
-				 reclaim_mode, 1, file);
+				 isolate_mode, 1, file);

 	if (global_reclaim(sc))
 		zone->pages_scanned += pgscanned;

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/
  2012-01-06 14:01 [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/ Hillf Danton
@ 2012-01-10  3:01 ` KAMEZAWA Hiroyuki
  2012-01-10  5:06   ` KOSAKI Motohiro
  2012-01-10  5:40 ` Rik van Riel
  1 sibling, 1 reply; 4+ messages in thread
From: KAMEZAWA Hiroyuki @ 2012-01-10  3:01 UTC (permalink / raw)
  To: Hillf Danton; +Cc: linux-mm, LKML, Andrew Morton, David Rientjes

On Fri, 6 Jan 2012 22:01:03 +0800
Hillf Danton <dhillf@gmail.com> wrote:

> With tons of reclaim_mode(defined as one field of struct scan_control) already
> in the file, it is clearer to rename it when setting up the isolation mode.
> 
> 
> Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
> Cc: David Rientjes <rientjes@google.com>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Signed-off-by: Hillf Danton <dhillf@gmail.com>

I like this.
Acked-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/
  2012-01-10  3:01 ` KAMEZAWA Hiroyuki
@ 2012-01-10  5:06   ` KOSAKI Motohiro
  0 siblings, 0 replies; 4+ messages in thread
From: KOSAKI Motohiro @ 2012-01-10  5:06 UTC (permalink / raw)
  To: KAMEZAWA Hiroyuki
  Cc: Hillf Danton, linux-mm, LKML, Andrew Morton, David Rientjes

2012/1/9 KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>:
> On Fri, 6 Jan 2012 22:01:03 +0800
> Hillf Danton <dhillf@gmail.com> wrote:
>
>> With tons of reclaim_mode(defined as one field of struct scan_control) already
>> in the file, it is clearer to rename it when setting up the isolation mode.
>>
>>
>> Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
>> Cc: David Rientjes <rientjes@google.com>
>> Cc: Andrew Morton <akpm@linux-foundation.org>
>> Signed-off-by: Hillf Danton <dhillf@gmail.com>
>
> I like this.
> Acked-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>

I'm ok too.
Acked-by: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/
  2012-01-06 14:01 [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/ Hillf Danton
  2012-01-10  3:01 ` KAMEZAWA Hiroyuki
@ 2012-01-10  5:40 ` Rik van Riel
  1 sibling, 0 replies; 4+ messages in thread
From: Rik van Riel @ 2012-01-10  5:40 UTC (permalink / raw)
  To: Hillf Danton
  Cc: linux-mm, LKML, Andrew Morton, KAMEZAWA Hiroyuki, David Rientjes

On 01/06/2012 09:01 AM, Hillf Danton wrote:
> With tons of reclaim_mode(defined as one field of struct scan_control) already
> in the file, it is clearer to rename it when setting up the isolation mode.
>
>
> Cc: KAMEZAWA Hiroyuki<kamezawa.hiroyu@jp.fujitsu.com>
> Cc: David Rientjes<rientjes@google.com>
> Cc: Andrew Morton<akpm@linux-foundation.org>
> Signed-off-by: Hillf Danton<dhillf@gmail.com>

Reviewed-by: Rik van Riel<riel@redhat.com>

-- 
All rights reversed

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2012-01-10  5:40 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-01-06 14:01 [PATCH] mm: vmscan: cleanup with s/reclaim_mode/isolate_mode/ Hillf Danton
2012-01-10  3:01 ` KAMEZAWA Hiroyuki
2012-01-10  5:06   ` KOSAKI Motohiro
2012-01-10  5:40 ` Rik van Riel

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).