linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail()
@ 2022-03-31 22:16 Jakob Koschel
  2022-03-31 22:16 ` [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable Jakob Koschel
  2022-04-12  9:40 ` [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Chao Yu
  0 siblings, 2 replies; 5+ messages in thread
From: Jakob Koschel @ 2022-03-31 22:16 UTC (permalink / raw)
  To: Jaegeuk Kim
  Cc: Chao Yu, linux-f2fs-devel, linux-kernel, Mike Rapoport,
	Brian Johannesmeyer, Cristiano Giuffrida, Bos, H.J.,
	Jakob Koschel

In preparation to limit the scope of a list iterator to the list
traversal loop, use a dedicated pointer to point to the found element
[1].

If no break is hit or the list is empty, 'next' will be NULL and
list_move_tail() should be called explicitly on the head directly.

Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
Signed-off-by: Jakob Koschel <jakobkoschel@gmail.com>
---
 fs/f2fs/segment.c | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
index 22dfeb991529..81ef2c3d08e5 100644
--- a/fs/f2fs/segment.c
+++ b/fs/f2fs/segment.c
@@ -4175,16 +4175,20 @@ static void release_sit_entry_set(struct sit_entry_set *ses)
 static void adjust_sit_entry_set(struct sit_entry_set *ses,
 						struct list_head *head)
 {
-	struct sit_entry_set *next = ses;
+	struct sit_entry_set *next = NULL, *iter = ses;
 
 	if (list_is_last(&ses->set_list, head))
 		return;
 
-	list_for_each_entry_continue(next, head, set_list)
-		if (ses->entry_cnt <= next->entry_cnt)
+	list_for_each_entry_continue(iter, head, set_list)
+		if (ses->entry_cnt <= iter->entry_cnt) {
+			next = iter;
+			list_move_tail(&ses->set_list, &iter->set_list);
 			break;
+		}
 
-	list_move_tail(&ses->set_list, &next->set_list);
+	if (!next)
+		list_move_tail(&ses->set_list, head);
 }
 
 static void add_sit_entry(unsigned int segno, struct list_head *head)

base-commit: d888c83fcec75194a8a48ccd283953bdba7b2550
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable
  2022-03-31 22:16 [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Jakob Koschel
@ 2022-03-31 22:16 ` Jakob Koschel
  2022-04-12  9:41   ` Chao Yu
  2022-04-12  9:40 ` [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Chao Yu
  1 sibling, 1 reply; 5+ messages in thread
From: Jakob Koschel @ 2022-03-31 22:16 UTC (permalink / raw)
  To: Jaegeuk Kim
  Cc: Chao Yu, linux-f2fs-devel, linux-kernel, Mike Rapoport,
	Brian Johannesmeyer, Cristiano Giuffrida, Bos, H.J.,
	Jakob Koschel

To move the list iterator variable into the list_for_each_entry_*()
macro in the future it should be avoided to use the list iterator
variable after the loop body.

To *never* use the list iterator variable after the loop it was
concluded to use a separate iterator variable instead of a
found boolean [1].

This removes the need to use a found variable and simply checking if
the variable was set, can determine if the break/goto was hit.

Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
Signed-off-by: Jakob Koschel <jakobkoschel@gmail.com>
---
 fs/f2fs/segment.c | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)

diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
index 81ef2c3d08e5..037164bf40a6 100644
--- a/fs/f2fs/segment.c
+++ b/fs/f2fs/segment.c
@@ -1666,33 +1666,32 @@ static unsigned int __wait_discard_cmd_range(struct f2fs_sb_info *sbi,
 	struct discard_cmd_control *dcc = SM_I(sbi)->dcc_info;
 	struct list_head *wait_list = (dpolicy->type == DPOLICY_FSTRIM) ?
 					&(dcc->fstrim_list) : &(dcc->wait_list);
-	struct discard_cmd *dc, *tmp;
-	bool need_wait;
+	struct discard_cmd *dc = NULL, *iter, *tmp;
 	unsigned int trimmed = 0;
 
 next:
-	need_wait = false;
+	dc = NULL;
 
 	mutex_lock(&dcc->cmd_lock);
-	list_for_each_entry_safe(dc, tmp, wait_list, list) {
-		if (dc->lstart + dc->len <= start || end <= dc->lstart)
+	list_for_each_entry_safe(iter, tmp, wait_list, list) {
+		if (iter->lstart + iter->len <= start || end <= iter->lstart)
 			continue;
-		if (dc->len < dpolicy->granularity)
+		if (iter->len < dpolicy->granularity)
 			continue;
-		if (dc->state == D_DONE && !dc->ref) {
-			wait_for_completion_io(&dc->wait);
-			if (!dc->error)
-				trimmed += dc->len;
-			__remove_discard_cmd(sbi, dc);
+		if (iter->state == D_DONE && !iter->ref) {
+			wait_for_completion_io(&iter->wait);
+			if (!iter->error)
+				trimmed += iter->len;
+			__remove_discard_cmd(sbi, iter);
 		} else {
-			dc->ref++;
-			need_wait = true;
+			iter->ref++;
+			dc = iter;
 			break;
 		}
 	}
 	mutex_unlock(&dcc->cmd_lock);
 
-	if (need_wait) {
+	if (dc) {
 		trimmed += __wait_one_discard_bio(sbi, dc);
 		goto next;
 	}
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail()
  2022-03-31 22:16 [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Jakob Koschel
  2022-03-31 22:16 ` [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable Jakob Koschel
@ 2022-04-12  9:40 ` Chao Yu
  2022-04-12 11:02   ` Jakob Koschel
  1 sibling, 1 reply; 5+ messages in thread
From: Chao Yu @ 2022-04-12  9:40 UTC (permalink / raw)
  To: Jakob Koschel, Jaegeuk Kim
  Cc: linux-f2fs-devel, linux-kernel, Mike Rapoport,
	Brian Johannesmeyer, Cristiano Giuffrida, Bos, H.J.

On 2022/4/1 6:16, Jakob Koschel wrote:
> In preparation to limit the scope of a list iterator to the list
> traversal loop, use a dedicated pointer to point to the found element
> [1].
> 
> If no break is hit or the list is empty, 'next' will be NULL and
> list_move_tail() should be called explicitly on the head directly.
> 
> Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
> Signed-off-by: Jakob Koschel <jakobkoschel@gmail.com>
> ---
>   fs/f2fs/segment.c | 12 ++++++++----
>   1 file changed, 8 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
> index 22dfeb991529..81ef2c3d08e5 100644
> --- a/fs/f2fs/segment.c
> +++ b/fs/f2fs/segment.c
> @@ -4175,16 +4175,20 @@ static void release_sit_entry_set(struct sit_entry_set *ses)
>   static void adjust_sit_entry_set(struct sit_entry_set *ses,
>   						struct list_head *head)
>   {
> -	struct sit_entry_set *next = ses;
> +	struct sit_entry_set *next = NULL, *iter = ses;
>   
>   	if (list_is_last(&ses->set_list, head))
>   		return;
>   
> -	list_for_each_entry_continue(next, head, set_list)
> -		if (ses->entry_cnt <= next->entry_cnt)
> +	list_for_each_entry_continue(iter, head, set_list)
> +		if (ses->entry_cnt <= iter->entry_cnt) {
> +			next = iter;
> +			list_move_tail(&ses->set_list, &iter->set_list);
>   			break;

return;

> +		}
>   
> -	list_move_tail(&ses->set_list, &next->set_list);
> +	if (!next)
> +		list_move_tail(&ses->set_list, head);

list_move_tail(&ses->set_list, head);

Then we don't need @next variable, right?

Thanks,

>   }
>   
>   static void add_sit_entry(unsigned int segno, struct list_head *head)
> 
> base-commit: d888c83fcec75194a8a48ccd283953bdba7b2550

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable
  2022-03-31 22:16 ` [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable Jakob Koschel
@ 2022-04-12  9:41   ` Chao Yu
  0 siblings, 0 replies; 5+ messages in thread
From: Chao Yu @ 2022-04-12  9:41 UTC (permalink / raw)
  To: Jakob Koschel, Jaegeuk Kim
  Cc: linux-f2fs-devel, linux-kernel, Mike Rapoport,
	Brian Johannesmeyer, Cristiano Giuffrida, Bos, H.J.

On 2022/4/1 6:16, Jakob Koschel wrote:
> To move the list iterator variable into the list_for_each_entry_*()
> macro in the future it should be avoided to use the list iterator
> variable after the loop body.
> 
> To *never* use the list iterator variable after the loop it was
> concluded to use a separate iterator variable instead of a
> found boolean [1].
> 
> This removes the need to use a found variable and simply checking if
> the variable was set, can determine if the break/goto was hit.
> 
> Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
> Signed-off-by: Jakob Koschel <jakobkoschel@gmail.com>

Reviewed-by: Chao Yu <chao@kernel.org>

Thanks,

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail()
  2022-04-12  9:40 ` [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Chao Yu
@ 2022-04-12 11:02   ` Jakob Koschel
  0 siblings, 0 replies; 5+ messages in thread
From: Jakob Koschel @ 2022-04-12 11:02 UTC (permalink / raw)
  To: Chao Yu
  Cc: Jaegeuk Kim, Linux F2FS Dev Mailing List, LKML, Mike Rapoport,
	Brian Johannesmeyer, Cristiano Giuffrida, Bos, H.J.



> On 12. Apr 2022, at 11:40, Chao Yu <chao@kernel.org> wrote:
> 
> On 2022/4/1 6:16, Jakob Koschel wrote:
>> In preparation to limit the scope of a list iterator to the list
>> traversal loop, use a dedicated pointer to point to the found element
>> [1].
>> If no break is hit or the list is empty, 'next' will be NULL and
>> list_move_tail() should be called explicitly on the head directly.
>> Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
>> Signed-off-by: Jakob Koschel <jakobkoschel@gmail.com>
>> ---
>> fs/f2fs/segment.c | 12 ++++++++----
>> 1 file changed, 8 insertions(+), 4 deletions(-)
>> diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
>> index 22dfeb991529..81ef2c3d08e5 100644
>> --- a/fs/f2fs/segment.c
>> +++ b/fs/f2fs/segment.c
>> @@ -4175,16 +4175,20 @@ static void release_sit_entry_set(struct sit_entry_set *ses)
>> static void adjust_sit_entry_set(struct sit_entry_set *ses,
>> 						struct list_head *head)
>> {
>> -	struct sit_entry_set *next = ses;
>> +	struct sit_entry_set *next = NULL, *iter = ses;
>> 	if (list_is_last(&ses->set_list, head))
>> 		return;
>> -	list_for_each_entry_continue(next, head, set_list)
>> -		if (ses->entry_cnt <= next->entry_cnt)
>> +	list_for_each_entry_continue(iter, head, set_list)
>> +		if (ses->entry_cnt <= iter->entry_cnt) {
>> +			next = iter;
>> +			list_move_tail(&ses->set_list, &iter->set_list);
>> 			break;
> 
> return;
> 
>> +		}
>> -	list_move_tail(&ses->set_list, &next->set_list);
>> +	if (!next)
>> +		list_move_tail(&ses->set_list, head);
> 
> list_move_tail(&ses->set_list, head);
> 
> Then we don't need @next variable, right?

Of course yes, good spot! I'll fix and resend a v2 in the next days.
Thanks for the input.

> 
> Thanks,
> 
>> }
>> static void add_sit_entry(unsigned int segno, struct list_head *head)
>> base-commit: d888c83fcec75194a8a48ccd283953bdba7b2550


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2022-04-12 12:09 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-03-31 22:16 [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Jakob Koschel
2022-03-31 22:16 ` [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable Jakob Koschel
2022-04-12  9:41   ` Chao Yu
2022-04-12  9:40 ` [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Chao Yu
2022-04-12 11:02   ` Jakob Koschel

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).