linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/3] CCF fixes/cleanup for per-user series
@ 2015-02-06 19:42 Stephen Boyd
  2015-02-06 19:42 ` [PATCH v2 1/3] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF Stephen Boyd
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Stephen Boyd @ 2015-02-06 19:42 UTC (permalink / raw)
  To: Mike Turquette, Stephen Boyd
  Cc: linux-kernel, Sylwester Nawrocki, Alban Browaeys, Tomeu Vizoso

Here are some fixes from yesterdays's dive into the fallout from the
per-user constraints patches. We should do a final sweep later
to rename local variables with type struct clk_core to core.

Changes from v1:
 * Picked up tags
 * Dropped clk.h include in last patch
 * Handled IS_ERR() retrurn from __clk_create_clk() in clkdev in first patch
 * Removed dead comment in last patch

Stephen Boyd (3):
  clkdev: Always allocate a struct clk and call __clk_get() w/ CCF
  clk: Rename child_node to clks_node to avoid confusion
  clk: Replace of_clk_get_by_clkspec() with of_clk_get_from_provider()

 drivers/clk/clk-conf.c |  7 +++---
 drivers/clk/clk.c      | 60 +++++++++++++++++++++++++++-----------------------
 drivers/clk/clk.h      | 22 ++++++++++++++----
 drivers/clk/clkdev.c   | 57 ++++++++++-------------------------------------
 4 files changed, 66 insertions(+), 80 deletions(-)

-- 
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2015-03-12  0:36 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-02-06 19:42 [PATCH v2 0/3] CCF fixes/cleanup for per-user series Stephen Boyd
2015-02-06 19:42 ` [PATCH v2 1/3] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF Stephen Boyd
2015-02-11  3:08   ` Mike Turquette
2015-02-06 19:42 ` [PATCH v2 2/3] clk: Rename child_node to clks_node to avoid confusion Stephen Boyd
2015-03-12  0:35   ` Stephen Boyd
2015-02-06 19:42 ` [PATCH v2 3/3] clk: Replace of_clk_get_by_clkspec() with of_clk_get_from_provider() Stephen Boyd
2015-03-12  0:35   ` Stephen Boyd

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).