linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code
@ 2019-10-31 14:09 zhong jiang
  2019-11-01  9:13 ` Maxime Ripard
  0 siblings, 1 reply; 5+ messages in thread
From: zhong jiang @ 2019-10-31 14:09 UTC (permalink / raw)
  To: broonie, lgirdwood; +Cc: perex, tiwai, mripard, zhongjiang, linux-kernel

It is better to use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR.

Signed-off-by: zhong jiang <zhongjiang@huawei.com>
---
 sound/soc/sunxi/sun4i-i2s.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/sound/soc/sunxi/sun4i-i2s.c b/sound/soc/sunxi/sun4i-i2s.c
index d0a8d58..72012a6 100644
--- a/sound/soc/sunxi/sun4i-i2s.c
+++ b/sound/soc/sunxi/sun4i-i2s.c
@@ -1174,10 +1174,8 @@ static int sun4i_i2s_init_regmap_fields(struct device *dev,
 	i2s->field_fmt_sr =
 			devm_regmap_field_alloc(dev, i2s->regmap,
 						i2s->variant->field_fmt_sr);
-	if (IS_ERR(i2s->field_fmt_sr))
-		return PTR_ERR(i2s->field_fmt_sr);
 
-	return 0;
+	return PTR_ERR_OR_ZERO(i2s->field_fmt_sr);
 }
 
 static int sun4i_i2s_probe(struct platform_device *pdev)
-- 
1.7.12.4


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code
  2019-10-31 14:09 [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code zhong jiang
@ 2019-11-01  9:13 ` Maxime Ripard
  2019-11-01 11:55   ` zhong jiang
  0 siblings, 1 reply; 5+ messages in thread
From: Maxime Ripard @ 2019-11-01  9:13 UTC (permalink / raw)
  To: zhong jiang; +Cc: broonie, lgirdwood, perex, tiwai, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 938 bytes --]

On Thu, Oct 31, 2019 at 10:09:39PM +0800, zhong jiang wrote:
> It is better to use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR.
>
> Signed-off-by: zhong jiang <zhongjiang@huawei.com>
> ---
>  sound/soc/sunxi/sun4i-i2s.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/sound/soc/sunxi/sun4i-i2s.c b/sound/soc/sunxi/sun4i-i2s.c
> index d0a8d58..72012a6 100644
> --- a/sound/soc/sunxi/sun4i-i2s.c
> +++ b/sound/soc/sunxi/sun4i-i2s.c
> @@ -1174,10 +1174,8 @@ static int sun4i_i2s_init_regmap_fields(struct device *dev,
>  	i2s->field_fmt_sr =
>  			devm_regmap_field_alloc(dev, i2s->regmap,
>  						i2s->variant->field_fmt_sr);
> -	if (IS_ERR(i2s->field_fmt_sr))
> -		return PTR_ERR(i2s->field_fmt_sr);
>
> -	return 0;
> +	return PTR_ERR_OR_ZERO(i2s->field_fmt_sr);

I don't find it "better". This couples the error handling and the
success case, and it makes it harder to extend in the future.

Maxime

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code
  2019-11-01  9:13 ` Maxime Ripard
@ 2019-11-01 11:55   ` zhong jiang
  2019-11-01 14:53     ` Maxime Ripard
  0 siblings, 1 reply; 5+ messages in thread
From: zhong jiang @ 2019-11-01 11:55 UTC (permalink / raw)
  To: Maxime Ripard; +Cc: broonie, lgirdwood, perex, tiwai, linux-kernel

On 2019/11/1 17:13, Maxime Ripard wrote:
> On Thu, Oct 31, 2019 at 10:09:39PM +0800, zhong jiang wrote:
>> It is better to use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR.
>>
>> Signed-off-by: zhong jiang <zhongjiang@huawei.com>
>> ---
>>  sound/soc/sunxi/sun4i-i2s.c | 4 +---
>>  1 file changed, 1 insertion(+), 3 deletions(-)
>>
>> diff --git a/sound/soc/sunxi/sun4i-i2s.c b/sound/soc/sunxi/sun4i-i2s.c
>> index d0a8d58..72012a6 100644
>> --- a/sound/soc/sunxi/sun4i-i2s.c
>> +++ b/sound/soc/sunxi/sun4i-i2s.c
>> @@ -1174,10 +1174,8 @@ static int sun4i_i2s_init_regmap_fields(struct device *dev,
>>  	i2s->field_fmt_sr =
>>  			devm_regmap_field_alloc(dev, i2s->regmap,
>>  						i2s->variant->field_fmt_sr);
>> -	if (IS_ERR(i2s->field_fmt_sr))
>> -		return PTR_ERR(i2s->field_fmt_sr);
>>
>> -	return 0;
>> +	return PTR_ERR_OR_ZERO(i2s->field_fmt_sr);
> I don't find it "better". This couples the error handling and the
> success case, and it makes it harder to extend in the future.
PTR_ERR_OR_ZERO has implemented the if(IS_ERR(...)) + PTR_ERR. It is 
feasible to replace it and more readable at least now. 

As you said,  PTR_ERR_OR_ZERO should be removed ? :-( 

Thanks,
zhong jiang


> Maxime



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code
  2019-11-01 11:55   ` zhong jiang
@ 2019-11-01 14:53     ` Maxime Ripard
  2019-11-02 14:45       ` zhong jiang
  0 siblings, 1 reply; 5+ messages in thread
From: Maxime Ripard @ 2019-11-01 14:53 UTC (permalink / raw)
  To: zhong jiang; +Cc: broonie, lgirdwood, perex, tiwai, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 1368 bytes --]

On Fri, Nov 01, 2019 at 07:55:42PM +0800, zhong jiang wrote:
> On 2019/11/1 17:13, Maxime Ripard wrote:
> > On Thu, Oct 31, 2019 at 10:09:39PM +0800, zhong jiang wrote:
> >> It is better to use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR.
> >>
> >> Signed-off-by: zhong jiang <zhongjiang@huawei.com>
> >> ---
> >>  sound/soc/sunxi/sun4i-i2s.c | 4 +---
> >>  1 file changed, 1 insertion(+), 3 deletions(-)
> >>
> >> diff --git a/sound/soc/sunxi/sun4i-i2s.c b/sound/soc/sunxi/sun4i-i2s.c
> >> index d0a8d58..72012a6 100644
> >> --- a/sound/soc/sunxi/sun4i-i2s.c
> >> +++ b/sound/soc/sunxi/sun4i-i2s.c
> >> @@ -1174,10 +1174,8 @@ static int sun4i_i2s_init_regmap_fields(struct device *dev,
> >>  	i2s->field_fmt_sr =
> >>  			devm_regmap_field_alloc(dev, i2s->regmap,
> >>  						i2s->variant->field_fmt_sr);
> >> -	if (IS_ERR(i2s->field_fmt_sr))
> >> -		return PTR_ERR(i2s->field_fmt_sr);
> >>
> >> -	return 0;
> >> +	return PTR_ERR_OR_ZERO(i2s->field_fmt_sr);
> > I don't find it "better". This couples the error handling and the
> > success case, and it makes it harder to extend in the future.
>
> PTR_ERR_OR_ZERO has implemented the if(IS_ERR(...)) + PTR_ERR. It is
> feasible to replace it and more readable at least now.
>
> As you said,  PTR_ERR_OR_ZERO should be removed ? :-(

No, I'm saying that in this context, this change isn't necessary.

Maxime

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code
  2019-11-01 14:53     ` Maxime Ripard
@ 2019-11-02 14:45       ` zhong jiang
  0 siblings, 0 replies; 5+ messages in thread
From: zhong jiang @ 2019-11-02 14:45 UTC (permalink / raw)
  To: Maxime Ripard; +Cc: broonie, lgirdwood, perex, tiwai, linux-kernel

On 2019/11/1 22:53, Maxime Ripard wrote:
> On Fri, Nov 01, 2019 at 07:55:42PM +0800, zhong jiang wrote:
>> On 2019/11/1 17:13, Maxime Ripard wrote:
>>> On Thu, Oct 31, 2019 at 10:09:39PM +0800, zhong jiang wrote:
>>>> It is better to use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR.
>>>>
>>>> Signed-off-by: zhong jiang <zhongjiang@huawei.com>
>>>> ---
>>>>  sound/soc/sunxi/sun4i-i2s.c | 4 +---
>>>>  1 file changed, 1 insertion(+), 3 deletions(-)
>>>>
>>>> diff --git a/sound/soc/sunxi/sun4i-i2s.c b/sound/soc/sunxi/sun4i-i2s.c
>>>> index d0a8d58..72012a6 100644
>>>> --- a/sound/soc/sunxi/sun4i-i2s.c
>>>> +++ b/sound/soc/sunxi/sun4i-i2s.c
>>>> @@ -1174,10 +1174,8 @@ static int sun4i_i2s_init_regmap_fields(struct device *dev,
>>>>  	i2s->field_fmt_sr =
>>>>  			devm_regmap_field_alloc(dev, i2s->regmap,
>>>>  						i2s->variant->field_fmt_sr);
>>>> -	if (IS_ERR(i2s->field_fmt_sr))
>>>> -		return PTR_ERR(i2s->field_fmt_sr);
>>>>
>>>> -	return 0;
>>>> +	return PTR_ERR_OR_ZERO(i2s->field_fmt_sr);
>>> I don't find it "better". This couples the error handling and the
>>> success case, and it makes it harder to extend in the future.
>> PTR_ERR_OR_ZERO has implemented the if(IS_ERR(...)) + PTR_ERR. It is
>> feasible to replace it and more readable at least now.
>>
>> As you said,  PTR_ERR_OR_ZERO should be removed ? :-(
> No, I'm saying that in this context, this change isn't necessary.
I am not an expert in the field.  It depends on you.
> Maxime



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2019-11-02 14:45 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-31 14:09 [PATCH] ASoC: sun4i: Use PTR_ERR_OR_ZERO to simplify the code zhong jiang
2019-11-01  9:13 ` Maxime Ripard
2019-11-01 11:55   ` zhong jiang
2019-11-01 14:53     ` Maxime Ripard
2019-11-02 14:45       ` zhong jiang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).