linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/23] Rid W=1 warnings in MTD
@ 2020-11-02 11:53 Lee Jones
  2020-11-02 11:53 ` [PATCH 01/23] mtd: mtdpart: Fix misdocumented function parameter 'mtd' Lee Jones
                   ` (23 more replies)
  0 siblings, 24 replies; 37+ messages in thread
From: Lee Jones @ 2020-11-02 11:53 UTC (permalink / raw)
  To: vigneshr; +Cc: linux-kernel, Lee Jones

This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.

Lee Jones (23):
  mtd: mtdpart: Fix misdocumented function parameter 'mtd'
  mtd: devices: phram: File headers are not good candidates for
    kernel-doc
  mtd: nand: onenand: onenand_base: Fix expected kernel-doc formatting
  mtd: devices: docg3: Fix kernel-doc 'bad line' and 'excessive doc'
    issues
  mtd: mtdcore: Fix misspelled function parameter 'section'
  mtd: nand: onenand: onenand_bbt: Fix expected kernel-doc formatting
  mtd: spi-nor: controllers: hisi-sfc: Demote non-conformant kernel-doc
  mtd: ubi: build: Document 'ubi_num' in struct mtd_dev_param
  mtd: nand: spi: toshiba: Demote non-conformant kernel-doc header
  mtd: ubi: kapi: Correct documentation for 'ubi_leb_read_sg's 'sgl'
    parameter
  mtd: ubi: eba: Fix a couple of misdocumentation issues
  mtd: ubi: wl: Fix a couple of kernel-doc issues
  mtd: nand: raw: brcmnand: brcmnand: Demote non-conformant kernel-doc
    headers
  mtd: ubi: gluebi: Fix misnamed function parameter documentation
  mtd: nand: raw: diskonchip: Marking unused variables as
    __always_unused
  mtd: nand: raw: cafe_nand: Remove superfluous param doc and add
    another
  mtd: nand: raw: s3c2410: Add documentation for 2 missing struct
    members
  mtd: nand: raw: omap_elm: Finish half populated function header,
    demote empty ones
  mtd: nand: raw: omap2: Fix a bunch of kernel-doc misdemeanours
  mtd: nand: raw: sunxi_nand: Document 'sunxi_nfc's 'caps' member
  mtd: nand: raw: arasan-nand-controller: Document 'anfc_op's 'buf'
    member
  mtd: nand: onenand: onenand_base: Fix some kernel-doc misdemeanours
  mtd: devices: powernv_flash: Add function names to headers and fix
    'dev'

 drivers/mtd/devices/docg3.c                   |   5 +-
 drivers/mtd/devices/phram.c                   |   2 +-
 drivers/mtd/devices/powernv_flash.c           |   6 +-
 drivers/mtd/mtdcore.c                         |   2 +-
 drivers/mtd/mtdpart.c                         |   2 +-
 drivers/mtd/nand/onenand/onenand_base.c       | 444 +++++++++---------
 drivers/mtd/nand/onenand/onenand_bbt.c        |  32 +-
 drivers/mtd/nand/raw/arasan-nand-controller.c |   1 +
 drivers/mtd/nand/raw/brcmnand/brcmnand.c      |   6 +-
 drivers/mtd/nand/raw/cafe_nand.c              |   2 +-
 drivers/mtd/nand/raw/diskonchip.c             |   4 +-
 drivers/mtd/nand/raw/omap2.c                  |  18 +-
 drivers/mtd/nand/raw/omap_elm.c               |   7 +-
 drivers/mtd/nand/raw/s3c2410.c                |   4 +-
 drivers/mtd/nand/raw/sunxi_nand.c             |   1 +
 drivers/mtd/nand/spi/toshiba.c                |   2 +-
 drivers/mtd/spi-nor/controllers/hisi-sfc.c    |   2 +-
 drivers/mtd/ubi/build.c                       |   1 +
 drivers/mtd/ubi/eba.c                         |   3 +-
 drivers/mtd/ubi/gluebi.c                      |   2 +-
 drivers/mtd/ubi/kapi.c                        |   2 +-
 drivers/mtd/ubi/wl.c                          |   3 +-
 22 files changed, 279 insertions(+), 272 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 37+ messages in thread

end of thread, other threads:[~2020-11-06 14:33 UTC | newest]

Thread overview: 37+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-02 11:53 [PATCH 00/23] Rid W=1 warnings in MTD Lee Jones
2020-11-02 11:53 ` [PATCH 01/23] mtd: mtdpart: Fix misdocumented function parameter 'mtd' Lee Jones
2020-11-02 11:53 ` [PATCH 02/23] mtd: devices: phram: File headers are not good candidates for kernel-doc Lee Jones
2020-11-02 11:53 ` [PATCH 03/23] mtd: nand: onenand: onenand_base: Fix expected kernel-doc formatting Lee Jones
2020-11-02 12:33   ` Miquel Raynal
2020-11-02 11:53 ` [PATCH 04/23] mtd: devices: docg3: Fix kernel-doc 'bad line' and 'excessive doc' issues Lee Jones
2020-11-02 12:34   ` Miquel Raynal
2020-11-02 11:53 ` [PATCH 05/23] mtd: mtdcore: Fix misspelled function parameter 'section' Lee Jones
2020-11-02 11:53 ` [PATCH 06/23] mtd: nand: onenand: onenand_bbt: Fix expected kernel-doc formatting Lee Jones
2020-11-02 11:53 ` [PATCH 07/23] mtd: spi-nor: controllers: hisi-sfc: Demote non-conformant kernel-doc Lee Jones
2020-11-06 13:37   ` Vignesh Raghavendra
2020-11-02 11:53 ` [PATCH 08/23] mtd: ubi: build: Document 'ubi_num' in struct mtd_dev_param Lee Jones
2020-11-02 11:53 ` [PATCH 09/23] mtd: nand: spi: toshiba: Demote non-conformant kernel-doc header Lee Jones
2020-11-02 12:29   ` Frieder Schrempf
2020-11-02 11:53 ` [PATCH 10/23] mtd: ubi: kapi: Correct documentation for 'ubi_leb_read_sg's 'sgl' parameter Lee Jones
2020-11-02 11:53 ` [PATCH 11/23] mtd: ubi: eba: Fix a couple of misdocumentation issues Lee Jones
2020-11-02 11:53 ` [PATCH 12/23] mtd: ubi: wl: Fix a couple of kernel-doc issues Lee Jones
2020-11-02 11:53 ` [PATCH 13/23] mtd: nand: raw: brcmnand: brcmnand: Demote non-conformant kernel-doc headers Lee Jones
2020-11-04  3:38   ` Florian Fainelli
2020-11-02 11:53 ` [PATCH 14/23] mtd: ubi: gluebi: Fix misnamed function parameter documentation Lee Jones
2020-11-02 11:53 ` [PATCH 15/23] mtd: nand: raw: diskonchip: Marking unused variables as __always_unused Lee Jones
2020-11-02 11:53 ` [PATCH 16/23] mtd: nand: raw: cafe_nand: Remove superfluous param doc and add another Lee Jones
2020-11-02 11:54 ` [PATCH 17/23] mtd: nand: raw: s3c2410: Add documentation for 2 missing struct members Lee Jones
2020-11-02 12:41   ` Krzysztof Kozlowski
2020-11-02 11:54 ` [PATCH 18/23] mtd: nand: raw: omap_elm: Finish half populated function header, demote empty ones Lee Jones
2020-11-02 11:54 ` [PATCH 19/23] mtd: nand: raw: omap2: Fix a bunch of kernel-doc misdemeanours Lee Jones
2020-11-02 12:44   ` Miquel Raynal
2020-11-02 11:54 ` [PATCH 20/23] mtd: nand: raw: sunxi_nand: Document 'sunxi_nfc's 'caps' member Lee Jones
2020-11-02 12:48   ` Miquel Raynal
2020-11-02 11:54 ` [PATCH 21/23] mtd: nand: raw: arasan-nand-controller: Document 'anfc_op's 'buf' member Lee Jones
2020-11-02 11:54 ` [PATCH 22/23] mtd: nand: onenand: onenand_base: Fix some kernel-doc misdemeanours Lee Jones
2020-11-02 12:51   ` Miquel Raynal
2020-11-02 11:54 ` [PATCH 23/23] mtd: devices: powernv_flash: Add function names to headers and fix 'dev' Lee Jones
2020-11-02 12:52   ` Miquel Raynal
2020-11-06 13:32 ` [PATCH 00/23] Rid W=1 warnings in MTD Lee Jones
2020-11-06 13:44   ` Miquel Raynal
2020-11-06 14:33     ` Lee Jones

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).