linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Masahiro Yamada <yamada.masahiro@socionext.com>,
	linux-mtd@lists.infradead.org,
	Miquel Raynal <miquel.raynal@bootlin.com>
Cc: Boris Brezillon <bbrezillon@kernel.org>,
	Brian Norris <computersforpeace@gmail.com>,
	linux-kernel@vger.kernel.org, Marek Vasut <marek.vasut@gmail.com>,
	Richard Weinberger <richard@nod.at>,
	David Woodhouse <dwmw2@infradead.org>
Subject: Re: [PATCH 07/11] mtd: rawnand: denali: use bool type instead of int where appropriate
Date: Fri, 08 Feb 2019 01:23:37 -0800	[thread overview]
Message-ID: <7e1121479b38e98949b44c9fba91dee3adf97b99.camel@perches.com> (raw)
In-Reply-To: <1549613335-30319-8-git-send-email-yamada.masahiro@socionext.com>

On Fri, 2019-02-08 at 17:08 +0900, Masahiro Yamada wrote:
> Use 'bool' type for some function arguments.
> 
>  - write (write or read?)
>  - raw (the raw access mode or not?)
> 
> It is true that denali_nand_info::dma_avail is also boolean, but
> I am keeping it as 'int' because 'scripts/checkpatch --strict' would
> report the following:
> 
> CHECK: Avoid using bool structure members because of possible alignment issues
>   - see: https://lkml.org/lkml/2017/11/21/384
> 
> I do not think it is a matter here, but I am sticking to the suggestion.

just fyi: that suggestion has been removed by:

commit 7967656ffbfa493f5546c0f18bf8a28f702c4baa
Author: Jason Gunthorpe <jgg@ziepe.ca>
Date:   Fri Jan 18 15:50:47 2019 -0700

    coding-style: Clarify the expectations around bool
    
    There has been some confusion since checkpatch started warning about bool
    use in structures, and people have been avoiding using it.
    
    Many people feel there is still a legitimate place for bool in structures,
    so provide some guidance on bool usage derived from the entire thread that
    spawned the checkpatch warning.
    
    Link: https://lkml.kernel.org/r/CA+55aFwVZk1OfB9T2v014PTAKFhtVan_Zj2dOjnCy3x




  reply	other threads:[~2019-02-08  9:23 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-02-08  8:08 [PATCH 00/11] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups Masahiro Yamada
2019-02-08  8:08 ` [PATCH 01/11] mtd: rawnand: denali: use nand_chip pointer more for internal functions Masahiro Yamada
2019-02-08  8:08 ` [PATCH 02/11] mtd: rawnand: denali: refactor syndrome layout handling for raw access Masahiro Yamada
2019-02-08  8:08 ` [PATCH 03/11] mtd: rawnand: denali: remove unneeded casts in denali_{read,write}_pio Masahiro Yamada
2019-02-08  8:08 ` [PATCH 04/11] mtd: rawnand: denali: switch over to ->exec_op() from legacy hooks Masahiro Yamada
2019-02-08  9:49   ` Masahiro Yamada
2019-02-08  8:08 ` [PATCH 05/11] mtd: rawnand: denali: rename irq_status to irq_stat Masahiro Yamada
2019-02-08 21:57   ` Miquel Raynal
2019-02-11  1:15     ` Masahiro Yamada
2019-02-08  8:08 ` [PATCH 06/11] mtd: rawnand: denali: use more precise timeout for NAND_OP_WAITRDT_INSTR Masahiro Yamada
2019-02-08 22:05   ` Miquel Raynal
2019-02-11  1:26     ` Masahiro Yamada
2019-02-08  8:08 ` [PATCH 07/11] mtd: rawnand: denali: use bool type instead of int where appropriate Masahiro Yamada
2019-02-08  9:23   ` Joe Perches [this message]
2019-02-08  9:33     ` Masahiro Yamada
2019-02-08 22:11     ` Miquel Raynal
2019-02-08  8:08 ` [PATCH 08/11] mtd: rawnand: denali_pci: rename goto labels Masahiro Yamada
2019-02-08  8:08 ` [PATCH 09/11] mtd: rawnand: denali: decouple controller and NAND chips Masahiro Yamada
2019-02-08  8:08 ` [PATCH 10/11] mtd: rawnand: denali: remove DENALI_NR_BANKS macro Masahiro Yamada
2019-02-08  8:08 ` [PATCH 11/11] mtd: rawnand: denali: clean up coding style Masahiro Yamada
2019-02-08 21:55 ` [PATCH 00/11] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups Miquel Raynal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7e1121479b38e98949b44c9fba91dee3adf97b99.camel@perches.com \
    --to=joe@perches.com \
    --cc=bbrezillon@kernel.org \
    --cc=computersforpeace@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=marek.vasut@gmail.com \
    --cc=miquel.raynal@bootlin.com \
    --cc=richard@nod.at \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).