linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCHv2] OMAP: Serial: Define OMAP uart MDR1 register definitions
@ 2010-11-11 14:13 Emeltchenko Andrei
  2010-11-11 16:02 ` Kevin Hilman
  0 siblings, 1 reply; 4+ messages in thread
From: Emeltchenko Andrei @ 2010-11-11 14:13 UTC (permalink / raw)
  To: linux-omap, linux-kernel

From: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>

Define MDR1 register serial definitions used in serial and
bluetooth drivers. Remove magic numbers there.
*v2	added OMAP keyword

Signed-off-by: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>
---
 include/linux/serial_reg.h |   12 ++++++++++++
 1 files changed, 12 insertions(+), 0 deletions(-)

diff --git a/include/linux/serial_reg.h b/include/linux/serial_reg.h
index c7a0ce1..6f38234 100644
--- a/include/linux/serial_reg.h
+++ b/include/linux/serial_reg.h
@@ -341,5 +341,17 @@
 #define UART_OMAP_SYSS		0x16	/* System status register */
 #define UART_OMAP_WER		0x17	/* Wake-up enable register */
 
+/*
+ * These are the definitions for the MDR1 register
+ */
+#define UART_OMAP_MDR1_16X_MODE		0x00	/* UART 16x mode */
+#define UART_OMAP_MDR1_SIR_MODE		0x01	/* SIR mode */
+#define UART_OMAP_MDR1_16X_ABAUD_MODE	0x02	/* UART 16x auto-baud */
+#define UART_OMAP_MDR1_13X_MODE		0x03	/* UART 13x mode */
+#define UART_OMAP_MDR1_MIR_MODE		0x04	/* MIR mode */
+#define UART_OMAP_MDR1_FIR_MODE		0x05	/* FIR mode */
+#define UART_OMAP_MDR1_CIR_MODE		0x06	/* CIR mode */
+#define UART_OMAP_MDR1_DISABLE		0x07	/* Disable (default state) */
+
 #endif /* _LINUX_SERIAL_REG_H */
 
-- 
1.7.0.4


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCHv2] OMAP: Serial: Define OMAP uart MDR1 register definitions
  2010-11-11 14:13 [PATCHv2] OMAP: Serial: Define OMAP uart MDR1 register definitions Emeltchenko Andrei
@ 2010-11-11 16:02 ` Kevin Hilman
  2010-11-12  7:51   ` Andrei Emeltchenko
  0 siblings, 1 reply; 4+ messages in thread
From: Kevin Hilman @ 2010-11-11 16:02 UTC (permalink / raw)
  To: Emeltchenko Andrei; +Cc: linux-omap, linux-kernel

Emeltchenko Andrei <Andrei.Emeltchenko.news@gmail.com> writes:

> From: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>
>
> Define MDR1 register serial definitions used in serial and
> bluetooth drivers. Remove magic numbers there.

Remove magic numbers where?  This patch doesn't remove anything.

> *v2	added OMAP keyword

This info should go after the '---' as it is not needed in the final
git history.

Kevin

> Signed-off-by: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>
> ---
>  include/linux/serial_reg.h |   12 ++++++++++++
>  1 files changed, 12 insertions(+), 0 deletions(-)
>
> diff --git a/include/linux/serial_reg.h b/include/linux/serial_reg.h
> index c7a0ce1..6f38234 100644
> --- a/include/linux/serial_reg.h
> +++ b/include/linux/serial_reg.h
> @@ -341,5 +341,17 @@
>  #define UART_OMAP_SYSS		0x16	/* System status register */
>  #define UART_OMAP_WER		0x17	/* Wake-up enable register */
>  
> +/*
> + * These are the definitions for the MDR1 register
> + */
> +#define UART_OMAP_MDR1_16X_MODE		0x00	/* UART 16x mode */
> +#define UART_OMAP_MDR1_SIR_MODE		0x01	/* SIR mode */
> +#define UART_OMAP_MDR1_16X_ABAUD_MODE	0x02	/* UART 16x auto-baud */
> +#define UART_OMAP_MDR1_13X_MODE		0x03	/* UART 13x mode */
> +#define UART_OMAP_MDR1_MIR_MODE		0x04	/* MIR mode */
> +#define UART_OMAP_MDR1_FIR_MODE		0x05	/* FIR mode */
> +#define UART_OMAP_MDR1_CIR_MODE		0x06	/* CIR mode */
> +#define UART_OMAP_MDR1_DISABLE		0x07	/* Disable (default state) */
> +
>  #endif /* _LINUX_SERIAL_REG_H */

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCHv2] OMAP: Serial: Define OMAP uart MDR1 register definitions
  2010-11-11 16:02 ` Kevin Hilman
@ 2010-11-12  7:51   ` Andrei Emeltchenko
  2010-11-12 20:25     ` Kevin Hilman
  0 siblings, 1 reply; 4+ messages in thread
From: Andrei Emeltchenko @ 2010-11-12  7:51 UTC (permalink / raw)
  To: Kevin Hilman; +Cc: linux-omap, linux-kernel

Hi,

On Thu, Nov 11, 2010 at 6:02 PM, Kevin Hilman
<khilman@deeprootsystems.com> wrote:
> Emeltchenko Andrei <Andrei.Emeltchenko.news@gmail.com> writes:
>
>> From: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>
>>
>> Define MDR1 register serial definitions used in serial and
>> bluetooth drivers. Remove magic numbers there.
>
> Remove magic numbers where?  This patch doesn't remove anything.

We have code which is not yet upstream, it will come through Bluetooth
subtree at some point, I am also going to remove magic in
omapX/serial.c drivers in the next patches.

Do you think I need to add those patches?

>
>> *v2   added OMAP keyword
>
> This info should go after the '---' as it is not needed in the final
> git history.

OK, will remove it.

>
> Kevin
>
>> Signed-off-by: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>
>> ---
>>  include/linux/serial_reg.h |   12 ++++++++++++
>>  1 files changed, 12 insertions(+), 0 deletions(-)
>>
>> diff --git a/include/linux/serial_reg.h b/include/linux/serial_reg.h
>> index c7a0ce1..6f38234 100644
>> --- a/include/linux/serial_reg.h
>> +++ b/include/linux/serial_reg.h
>> @@ -341,5 +341,17 @@
>>  #define UART_OMAP_SYSS               0x16    /* System status register */
>>  #define UART_OMAP_WER                0x17    /* Wake-up enable register */
>>
>> +/*
>> + * These are the definitions for the MDR1 register
>> + */
>> +#define UART_OMAP_MDR1_16X_MODE              0x00    /* UART 16x mode */
>> +#define UART_OMAP_MDR1_SIR_MODE              0x01    /* SIR mode */
>> +#define UART_OMAP_MDR1_16X_ABAUD_MODE        0x02    /* UART 16x auto-baud */
>> +#define UART_OMAP_MDR1_13X_MODE              0x03    /* UART 13x mode */
>> +#define UART_OMAP_MDR1_MIR_MODE              0x04    /* MIR mode */
>> +#define UART_OMAP_MDR1_FIR_MODE              0x05    /* FIR mode */
>> +#define UART_OMAP_MDR1_CIR_MODE              0x06    /* CIR mode */
>> +#define UART_OMAP_MDR1_DISABLE               0x07    /* Disable (default state) */
>> +
>>  #endif /* _LINUX_SERIAL_REG_H */
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCHv2] OMAP: Serial: Define OMAP uart MDR1 register definitions
  2010-11-12  7:51   ` Andrei Emeltchenko
@ 2010-11-12 20:25     ` Kevin Hilman
  0 siblings, 0 replies; 4+ messages in thread
From: Kevin Hilman @ 2010-11-12 20:25 UTC (permalink / raw)
  To: Andrei Emeltchenko; +Cc: linux-omap, linux-kernel

Andrei Emeltchenko <andrei.emeltchenko.news@gmail.com> writes:

> Hi,
>
> On Thu, Nov 11, 2010 at 6:02 PM, Kevin Hilman
> <khilman@deeprootsystems.com> wrote:
>> Emeltchenko Andrei <Andrei.Emeltchenko.news@gmail.com> writes:
>>
>>> From: Andrei Emeltchenko <andrei.emeltchenko@nokia.com>
>>>
>>> Define MDR1 register serial definitions used in serial and
>>> bluetooth drivers. Remove magic numbers there.
>>
>> Remove magic numbers where?  This patch doesn't remove anything.
>
> We have code which is not yet upstream, it will come through Bluetooth
> subtree at some point, I am also going to remove magic in
> omapX/serial.c drivers in the next patches.
>
> Do you think I need to add those patches?

Not necessarly, but the comment should be a little more clear.
Something "subsequent patches will remove...."

Kevin


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2010-11-12 20:25 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-11-11 14:13 [PATCHv2] OMAP: Serial: Define OMAP uart MDR1 register definitions Emeltchenko Andrei
2010-11-11 16:02 ` Kevin Hilman
2010-11-12  7:51   ` Andrei Emeltchenko
2010-11-12 20:25     ` Kevin Hilman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).