linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc()
@ 2022-01-25 17:01 Gustavo A. R. Silva
  2022-01-26  7:54 ` Ido Schimmel
  2022-01-26 10:55 ` Petr Machata
  0 siblings, 2 replies; 3+ messages in thread
From: Gustavo A. R. Silva @ 2022-01-25 17:01 UTC (permalink / raw)
  To: Ido Schimmel, Petr Machata, David S. Miller, Jakub Kicinski
  Cc: netdev, linux-kernel, Gustavo A. R. Silva, linux-hardening

Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows that,
in the worst scenario, could lead to heap overflows.

Also, address the following sparse warnings:
drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure

Link: https://github.com/KSPP/linux/issues/174
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
index a9fff8adc75e..d20e794e01ca 100644
--- a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
+++ b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
@@ -213,7 +213,6 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
 	struct mlxsw_sp1_kvdl_part *part;
 	bool need_update = true;
 	unsigned int nr_entries;
-	size_t usage_size;
 	u64 resource_size;
 	int err;
 
@@ -225,8 +224,8 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
 	}
 
 	nr_entries = div_u64(resource_size, info->alloc_size);
-	usage_size = BITS_TO_LONGS(nr_entries) * sizeof(unsigned long);
-	part = kzalloc(sizeof(*part) + usage_size, GFP_KERNEL);
+	part = kzalloc(struct_size(part, usage, BITS_TO_LONGS(nr_entries)),
+		       GFP_KERNEL);
 	if (!part)
 		return ERR_PTR(-ENOMEM);
 
-- 
2.27.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc()
  2022-01-25 17:01 [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc() Gustavo A. R. Silva
@ 2022-01-26  7:54 ` Ido Schimmel
  2022-01-26 10:55 ` Petr Machata
  1 sibling, 0 replies; 3+ messages in thread
From: Ido Schimmel @ 2022-01-26  7:54 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Ido Schimmel, Petr Machata, David S. Miller, Jakub Kicinski,
	netdev, linux-kernel, linux-hardening

On Tue, Jan 25, 2022 at 11:01:28AM -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
> 
> Also, address the following sparse warnings:
> drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure
> 
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Reviewed-by: Ido Schimmel <idosch@nvidia.com>

Thanks

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc()
  2022-01-25 17:01 [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc() Gustavo A. R. Silva
  2022-01-26  7:54 ` Ido Schimmel
@ 2022-01-26 10:55 ` Petr Machata
  1 sibling, 0 replies; 3+ messages in thread
From: Petr Machata @ 2022-01-26 10:55 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Ido Schimmel, Petr Machata, David S. Miller, Jakub Kicinski,
	netdev, linux-kernel, linux-hardening


"Gustavo A. R. Silva" <gustavoars@kernel.org> writes:

> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
> ---
>  drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> index a9fff8adc75e..d20e794e01ca 100644
> --- a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> +++ b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> @@ -213,7 +213,6 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
>  	struct mlxsw_sp1_kvdl_part *part;
>  	bool need_update = true;
>  	unsigned int nr_entries;
> -	size_t usage_size;
>  	u64 resource_size;
>  	int err;
>  
> @@ -225,8 +224,8 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
>  	}
>  
>  	nr_entries = div_u64(resource_size, info->alloc_size);
> -	usage_size = BITS_TO_LONGS(nr_entries) * sizeof(unsigned long);
> -	part = kzalloc(sizeof(*part) + usage_size, GFP_KERNEL);
> +	part = kzalloc(struct_size(part, usage, BITS_TO_LONGS(nr_entries)),
> +		       GFP_KERNEL);
>  	if (!part)
>  		return ERR_PTR(-ENOMEM);

Reviewed-by: Petr Machata <petrm@nvidia.com>

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-01-26 10:57 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-25 17:01 [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc() Gustavo A. R. Silva
2022-01-26  7:54 ` Ido Schimmel
2022-01-26 10:55 ` Petr Machata

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).