linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH] scsi: storvsc: Fix validation for unsolicited incoming packets
@ 2021-09-28 16:37 Andrea Parri (Microsoft)
  2021-09-28 22:05 ` Haiyang Zhang
  0 siblings, 1 reply; 4+ messages in thread
From: Andrea Parri (Microsoft) @ 2021-09-28 16:37 UTC (permalink / raw)
  To: linux-kernel, linux-hyperv, linux-scsi
  Cc: K . Y . Srinivasan, Haiyang Zhang, Stephen Hemminger, Wei Liu,
	James E . J . Bottomley, Martin K . Petersen, Michael Kelley,
	Andrea Parri (Microsoft),
	Dexuan Cui

The validation on the length of incoming packets performed in
storvsc_on_channel_callback() does not apply to "unsolicited"
packets with ID of 0 sent by Hyper-V.  Adjust the validation
by handling such unsolicited packets separately.

Fixes: 91b1b640b834b2 ("scsi: storvsc: Validate length of incoming packet in storvsc_on_channel_callback()")
Reported-by: Dexuan Cui <decui@microsoft.com>
Signed-off-by: Andrea Parri (Microsoft) <parri.andrea@gmail.com>
---
The (new) bound, VSTOR_MIN_UNSOL_PKT_SIZE, was "empirically
derived" based on testing and code auditing.  This explains
the RFC tag...

 drivers/scsi/storvsc_drv.c | 17 ++++++++++++++---
 1 file changed, 14 insertions(+), 3 deletions(-)

diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c
index ebbbc1299c625..a9bbcbbfb54ee 100644
--- a/drivers/scsi/storvsc_drv.c
+++ b/drivers/scsi/storvsc_drv.c
@@ -292,6 +292,9 @@ struct vmstorage_protocol_version {
 #define STORAGE_CHANNEL_REMOVABLE_FLAG		0x1
 #define STORAGE_CHANNEL_EMULATED_IDE_FLAG	0x2
 
+/* Lower bound on the size of unsolicited packets with ID of 0 */
+#define VSTOR_MIN_UNSOL_PKT_SIZE		48
+
 struct vstor_packet {
 	/* Requested operation type */
 	enum vstor_packet_operation operation;
@@ -1285,11 +1288,13 @@ static void storvsc_on_channel_callback(void *context)
 	foreach_vmbus_pkt(desc, channel) {
 		struct vstor_packet *packet = hv_pkt_data(desc);
 		struct storvsc_cmd_request *request = NULL;
+		u32 pktlen = hv_pkt_datalen(desc);
 		u64 rqst_id = desc->trans_id;
 
-		if (hv_pkt_datalen(desc) < sizeof(struct vstor_packet) -
+		/* Unsolicited packets with ID of 0 are validated separately below */
+		if (rqst_id != 0 && pktlen < sizeof(struct vstor_packet) -
 				stor_device->vmscsi_size_delta) {
-			dev_err(&device->device, "Invalid packet len\n");
+			dev_err(&device->device, "Invalid packet: length=%u\n", pktlen);
 			continue;
 		}
 
@@ -1298,8 +1303,14 @@ static void storvsc_on_channel_callback(void *context)
 		} else if (rqst_id == VMBUS_RQST_RESET) {
 			request = &stor_device->reset_request;
 		} else {
-			/* Hyper-V can send an unsolicited message with ID of 0 */
 			if (rqst_id == 0) {
+				if (pktlen < VSTOR_MIN_UNSOL_PKT_SIZE) {
+					dev_err(&device->device,
+						"Invalid packet with ID of 0: length=%u\n",
+						pktlen);
+					continue;
+				}
+
 				/*
 				 * storvsc_on_receive() looks at the vstor_packet in the message
 				 * from the ring buffer.  If the operation in the vstor_packet is
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* RE: [RFC PATCH] scsi: storvsc: Fix validation for unsolicited incoming packets
  2021-09-28 16:37 [RFC PATCH] scsi: storvsc: Fix validation for unsolicited incoming packets Andrea Parri (Microsoft)
@ 2021-09-28 22:05 ` Haiyang Zhang
  2021-09-29 13:33   ` Haiyang Zhang
  0 siblings, 1 reply; 4+ messages in thread
From: Haiyang Zhang @ 2021-09-28 22:05 UTC (permalink / raw)
  To: Andrea Parri (Microsoft), linux-kernel, linux-hyperv, linux-scsi
  Cc: KY Srinivasan, Stephen Hemminger, Wei Liu,
	James E . J . Bottomley, Martin K . Petersen, Michael Kelley,
	Dexuan Cui



> -----Original Message-----
> From: Andrea Parri (Microsoft) <parri.andrea@gmail.com>
> Sent: Tuesday, September 28, 2021 12:38 PM
> To: linux-kernel@vger.kernel.org; linux-hyperv@vger.kernel.org; linux-
> scsi@vger.kernel.org
> Cc: KY Srinivasan <kys@microsoft.com>; Haiyang Zhang
> <haiyangz@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>;
> Wei Liu <wei.liu@kernel.org>; James E . J . Bottomley
> <jejb@linux.ibm.com>; Martin K . Petersen <martin.petersen@oracle.com>;
> Michael Kelley <mikelley@microsoft.com>; Andrea Parri (Microsoft)
> <parri.andrea@gmail.com>; Dexuan Cui <decui@microsoft.com>
> Subject: [RFC PATCH] scsi: storvsc: Fix validation for unsolicited
> incoming packets
> 
> The validation on the length of incoming packets performed in
> storvsc_on_channel_callback() does not apply to "unsolicited"
> packets with ID of 0 sent by Hyper-V.  Adjust the validation
> by handling such unsolicited packets separately.
> 
> Fixes: 91b1b640b834b2 ("scsi: storvsc: Validate length of incoming
> packet in storvsc_on_channel_callback()")
> Reported-by: Dexuan Cui <decui@microsoft.com>
> Signed-off-by: Andrea Parri (Microsoft) <parri.andrea@gmail.com>
> ---
> The (new) bound, VSTOR_MIN_UNSOL_PKT_SIZE, was "empirically
> derived" based on testing and code auditing.  This explains
> the RFC tag...
> 
>  drivers/scsi/storvsc_drv.c | 17 ++++++++++++++---
>  1 file changed, 14 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c
> index ebbbc1299c625..a9bbcbbfb54ee 100644
> --- a/drivers/scsi/storvsc_drv.c
> +++ b/drivers/scsi/storvsc_drv.c
> @@ -292,6 +292,9 @@ struct vmstorage_protocol_version {
>  #define STORAGE_CHANNEL_REMOVABLE_FLAG		0x1
>  #define STORAGE_CHANNEL_EMULATED_IDE_FLAG	0x2
> 
> +/* Lower bound on the size of unsolicited packets with ID of 0 */
> +#define VSTOR_MIN_UNSOL_PKT_SIZE		48
> +
>  struct vstor_packet {
>  	/* Requested operation type */
>  	enum vstor_packet_operation operation;
> @@ -1285,11 +1288,13 @@ static void storvsc_on_channel_callback(void
> *context)
>  	foreach_vmbus_pkt(desc, channel) {
>  		struct vstor_packet *packet = hv_pkt_data(desc);
>  		struct storvsc_cmd_request *request = NULL;
> +		u32 pktlen = hv_pkt_datalen(desc);
>  		u64 rqst_id = desc->trans_id;
> 
> -		if (hv_pkt_datalen(desc) < sizeof(struct vstor_packet) -
> +		/* Unsolicited packets with ID of 0 are validated separately
> below */
> +		if (rqst_id != 0 && pktlen < sizeof(struct vstor_packet) -
>  				stor_device->vmscsi_size_delta) {
> -			dev_err(&device->device, "Invalid packet len\n");
> +			dev_err(&device->device, "Invalid packet: length=%u\n",
> pktlen);
>  			continue;
>  		}
> 
> @@ -1298,8 +1303,14 @@ static void storvsc_on_channel_callback(void
> *context)
>  		} else if (rqst_id == VMBUS_RQST_RESET) {
>  			request = &stor_device->reset_request;
>  		} else {
> -			/* Hyper-V can send an unsolicited message with ID of 0
> */
>  			if (rqst_id == 0) {
> +				if (pktlen < VSTOR_MIN_UNSOL_PKT_SIZE) {
> +					dev_err(&device->device,
> +						"Invalid packet with ID of 0:
> length=%u\n",
> +						pktlen);
> +					continue;
> +				}
> +
>  				/*
>  				 * storvsc_on_receive() looks at the vstor_packet
> in the message
>  				 * from the ring buffer.  If the operation in the
> vstor_packet is

The patch looks good. But for readability, I'd suggested put the length 
checks together like this:

	u32 minlen = rqst_id ? sizeof(struct vstor_packet) -
		stor_device->vmscsi_size_delta : VSTOR_MIN_UNSOL_PKT_SIZE;

	if (pktlen < minlen) {
		dev_err(&device->device,
			   "Invalid pkt: id=%llu, len=%u, minlen=%u\n",
			   rqst_id, pktlen, minlen);
		continue;
	}

Thanks.

Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com>



^ permalink raw reply	[flat|nested] 4+ messages in thread

* RE: [RFC PATCH] scsi: storvsc: Fix validation for unsolicited incoming packets
  2021-09-28 22:05 ` Haiyang Zhang
@ 2021-09-29 13:33   ` Haiyang Zhang
  2021-09-29 13:55     ` Andrea Parri
  0 siblings, 1 reply; 4+ messages in thread
From: Haiyang Zhang @ 2021-09-29 13:33 UTC (permalink / raw)
  To: Andrea Parri (Microsoft), linux-kernel, linux-hyperv, linux-scsi
  Cc: KY Srinivasan, Stephen Hemminger, Wei Liu,
	James E . J . Bottomley, Martin K . Petersen, Michael Kelley,
	Dexuan Cui



> -----Original Message-----
> From: Haiyang Zhang
> Sent: Tuesday, September 28, 2021 6:06 PM
> To: Andrea Parri (Microsoft) <parri.andrea@gmail.com>; linux-
> kernel@vger.kernel.org; linux-hyperv@vger.kernel.org; linux-
> scsi@vger.kernel.org
> Cc: KY Srinivasan <kys@microsoft.com>; Stephen Hemminger
> <sthemmin@microsoft.com>; Wei Liu <wei.liu@kernel.org>; James E . J .
> Bottomley <jejb@linux.ibm.com>; Martin K . Petersen
> <martin.petersen@oracle.com>; Michael Kelley <mikelley@microsoft.com>;
> Dexuan Cui <decui@microsoft.com>
> Subject: RE: [RFC PATCH] scsi: storvsc: Fix validation for unsolicited
> incoming packets
> 
> 
> 
> > -----Original Message-----
> > From: Andrea Parri (Microsoft) <parri.andrea@gmail.com>
> > Sent: Tuesday, September 28, 2021 12:38 PM
> > To: linux-kernel@vger.kernel.org; linux-hyperv@vger.kernel.org; linux-
> > scsi@vger.kernel.org
> > Cc: KY Srinivasan <kys@microsoft.com>; Haiyang Zhang
> > <haiyangz@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>;
> > Wei Liu <wei.liu@kernel.org>; James E . J . Bottomley
> > <jejb@linux.ibm.com>; Martin K . Petersen
> > <martin.petersen@oracle.com>; Michael Kelley <mikelley@microsoft.com>;
> > Andrea Parri (Microsoft) <parri.andrea@gmail.com>; Dexuan Cui
> > <decui@microsoft.com>
> > Subject: [RFC PATCH] scsi: storvsc: Fix validation for unsolicited
> > incoming packets
> >
> > The validation on the length of incoming packets performed in
> > storvsc_on_channel_callback() does not apply to "unsolicited"
> > packets with ID of 0 sent by Hyper-V.  Adjust the validation by
> > handling such unsolicited packets separately.
> >
> > Fixes: 91b1b640b834b2 ("scsi: storvsc: Validate length of incoming
> > packet in storvsc_on_channel_callback()")
> > Reported-by: Dexuan Cui <decui@microsoft.com>
> > Signed-off-by: Andrea Parri (Microsoft) <parri.andrea@gmail.com>
> > ---
> > The (new) bound, VSTOR_MIN_UNSOL_PKT_SIZE, was "empirically derived"
> > based on testing and code auditing.  This explains the RFC tag...
> >
> >  drivers/scsi/storvsc_drv.c | 17 ++++++++++++++---
> >  1 file changed, 14 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c
> > index ebbbc1299c625..a9bbcbbfb54ee 100644
> > --- a/drivers/scsi/storvsc_drv.c
> > +++ b/drivers/scsi/storvsc_drv.c
> > @@ -292,6 +292,9 @@ struct vmstorage_protocol_version {
> >  #define STORAGE_CHANNEL_REMOVABLE_FLAG		0x1
> >  #define STORAGE_CHANNEL_EMULATED_IDE_FLAG	0x2
> >
> > +/* Lower bound on the size of unsolicited packets with ID of 0 */
> > +#define VSTOR_MIN_UNSOL_PKT_SIZE		48
> > +
> >  struct vstor_packet {
> >  	/* Requested operation type */
> >  	enum vstor_packet_operation operation; @@ -1285,11 +1288,13 @@
> > static void storvsc_on_channel_callback(void
> > *context)
> >  	foreach_vmbus_pkt(desc, channel) {
> >  		struct vstor_packet *packet = hv_pkt_data(desc);
> >  		struct storvsc_cmd_request *request = NULL;
> > +		u32 pktlen = hv_pkt_datalen(desc);
> >  		u64 rqst_id = desc->trans_id;
> >
> > -		if (hv_pkt_datalen(desc) < sizeof(struct vstor_packet) -
> > +		/* Unsolicited packets with ID of 0 are validated separately
> > below */
> > +		if (rqst_id != 0 && pktlen < sizeof(struct vstor_packet) -
> >  				stor_device->vmscsi_size_delta) {
> > -			dev_err(&device->device, "Invalid packet len\n");
> > +			dev_err(&device->device, "Invalid packet: length=%u\n",
> > pktlen);
> >  			continue;
> >  		}
> >
> > @@ -1298,8 +1303,14 @@ static void storvsc_on_channel_callback(void
> > *context)
> >  		} else if (rqst_id == VMBUS_RQST_RESET) {
> >  			request = &stor_device->reset_request;
> >  		} else {
> > -			/* Hyper-V can send an unsolicited message with ID of 0
> > */
> >  			if (rqst_id == 0) {
> > +				if (pktlen < VSTOR_MIN_UNSOL_PKT_SIZE) {
> > +					dev_err(&device->device,
> > +						"Invalid packet with ID of 0:
> > length=%u\n",
> > +						pktlen);
> > +					continue;
> > +				}
> > +
> >  				/*
> >  				 * storvsc_on_receive() looks at the vstor_packet
> in the message
> >  				 * from the ring buffer.  If the operation in the
> vstor_packet is
> 
> The patch looks good. But for readability, I'd suggested put the length
> checks together like this:
> 
> 	u32 minlen = rqst_id ? sizeof(struct vstor_packet) -
> 		stor_device->vmscsi_size_delta : VSTOR_MIN_UNSOL_PKT_SIZE;
> 
> 	if (pktlen < minlen) {
> 		dev_err(&device->device,
> 			   "Invalid pkt: id=%llu, len=%u, minlen=%u\n",
> 			   rqst_id, pktlen, minlen);
> 		continue;
> 	}
> 
> Thanks.
> 
> Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com>
The tag was meant to be:
Reviewed-by: Haiyang Zhang <haiyangz@microsoft.com>

Thanks.



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [RFC PATCH] scsi: storvsc: Fix validation for unsolicited incoming packets
  2021-09-29 13:33   ` Haiyang Zhang
@ 2021-09-29 13:55     ` Andrea Parri
  0 siblings, 0 replies; 4+ messages in thread
From: Andrea Parri @ 2021-09-29 13:55 UTC (permalink / raw)
  To: Haiyang Zhang
  Cc: linux-kernel, linux-hyperv, linux-scsi, KY Srinivasan,
	Stephen Hemminger, Wei Liu, James E . J . Bottomley,
	Martin K . Petersen, Michael Kelley, Dexuan Cui

> > The patch looks good. But for readability, I'd suggested put the length
> > checks together like this:
> > 
> > 	u32 minlen = rqst_id ? sizeof(struct vstor_packet) -
> > 		stor_device->vmscsi_size_delta : VSTOR_MIN_UNSOL_PKT_SIZE;
> > 
> > 	if (pktlen < minlen) {
> > 		dev_err(&device->device,
> > 			   "Invalid pkt: id=%llu, len=%u, minlen=%u\n",
> > 			   rqst_id, pktlen, minlen);
> > 		continue;
> > 	}
> > 
> > Thanks.
> > 
> > Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com>
> The tag was meant to be:
> Reviewed-by: Haiyang Zhang <haiyangz@microsoft.com>

Thank you, Haiyang.  I'll update as suggested.

  Andrea

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-09-29 13:56 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-28 16:37 [RFC PATCH] scsi: storvsc: Fix validation for unsolicited incoming packets Andrea Parri (Microsoft)
2021-09-28 22:05 ` Haiyang Zhang
2021-09-29 13:33   ` Haiyang Zhang
2021-09-29 13:55     ` Andrea Parri

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).