linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] Input: Allocate keycode for SNIP key
@ 2020-03-04  0:21 Rajat Jain
  2020-03-12 19:32 ` Rajat Jain
  2020-03-12 20:31 ` Harry Cutts
  0 siblings, 2 replies; 4+ messages in thread
From: Rajat Jain @ 2020-03-04  0:21 UTC (permalink / raw)
  To: Dmitry Torokhov, linux-input, linux-kernel, dtor; +Cc: Rajat Jain

New chromeos keyboards have a "snip" key that is basically a selective
screenshot (allows a user to select an area of screen to be copied).
Allocate a keyvode for it.

Signed-off-by: Rajat Jain <rajatja@google.com>
---
V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.

 include/uapi/linux/input-event-codes.h | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
index 0f1db1cccc3fd..08c8572891efb 100644
--- a/include/uapi/linux/input-event-codes.h
+++ b/include/uapi/linux/input-event-codes.h
@@ -652,6 +652,9 @@
 /* Electronic privacy screen control */
 #define KEY_PRIVACY_SCREEN_TOGGLE	0x279
 
+/* Selective Screenshot */
+#define KEY_SNIP                        0x280
+
 /*
  * Some keyboards have keys which do not have a defined meaning, these keys
  * are intended to be programmed / bound to macros by the user. For most
-- 
2.25.0.265.gbab2e86ba0-goog


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] Input: Allocate keycode for SNIP key
  2020-03-04  0:21 [PATCH v2] Input: Allocate keycode for SNIP key Rajat Jain
@ 2020-03-12 19:32 ` Rajat Jain
  2020-03-12 20:31 ` Harry Cutts
  1 sibling, 0 replies; 4+ messages in thread
From: Rajat Jain @ 2020-03-12 19:32 UTC (permalink / raw)
  To: Dmitry Torokhov, linux-input, Linux Kernel Mailing List, Dmitry Torokhov

Hi Dmitry,


On Tue, Mar 3, 2020 at 4:21 PM Rajat Jain <rajatja@google.com> wrote:
>
> New chromeos keyboards have a "snip" key that is basically a selective
> screenshot (allows a user to select an area of screen to be copied).
> Allocate a keyvode for it.

Any comments on this patch?

Thanks & Best Regards,

Rajat

>
> Signed-off-by: Rajat Jain <rajatja@google.com>
> ---
> V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.
>
>  include/uapi/linux/input-event-codes.h | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
> index 0f1db1cccc3fd..08c8572891efb 100644
> --- a/include/uapi/linux/input-event-codes.h
> +++ b/include/uapi/linux/input-event-codes.h
> @@ -652,6 +652,9 @@
>  /* Electronic privacy screen control */
>  #define KEY_PRIVACY_SCREEN_TOGGLE      0x279
>
> +/* Selective Screenshot */
> +#define KEY_SNIP                        0x280
> +
>  /*
>   * Some keyboards have keys which do not have a defined meaning, these keys
>   * are intended to be programmed / bound to macros by the user. For most
> --
> 2.25.0.265.gbab2e86ba0-goog
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] Input: Allocate keycode for SNIP key
  2020-03-04  0:21 [PATCH v2] Input: Allocate keycode for SNIP key Rajat Jain
  2020-03-12 19:32 ` Rajat Jain
@ 2020-03-12 20:31 ` Harry Cutts
  2020-03-13 17:46   ` Rajat Jain
  1 sibling, 1 reply; 4+ messages in thread
From: Harry Cutts @ 2020-03-12 20:31 UTC (permalink / raw)
  To: Rajat Jain; +Cc: Dmitry Torokhov, linux-input, lkml, Dmitry Torokhov

On Tue, 3 Mar 2020 at 16:21, Rajat Jain <rajatja@google.com> wrote:
>
> New chromeos keyboards have a "snip" key that is basically a selective
> screenshot (allows a user to select an area of screen to be copied).
> Allocate a keyvode for it.
>
> Signed-off-by: Rajat Jain <rajatja@google.com>
> ---
> V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.
>
>  include/uapi/linux/input-event-codes.h | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
> index 0f1db1cccc3fd..08c8572891efb 100644
> --- a/include/uapi/linux/input-event-codes.h
> +++ b/include/uapi/linux/input-event-codes.h
> @@ -652,6 +652,9 @@
>  /* Electronic privacy screen control */
>  #define KEY_PRIVACY_SCREEN_TOGGLE      0x279
>
> +/* Selective Screenshot */
> +#define KEY_SNIP                        0x280
> +

It's not very obvious to me what KEY_SNIP represents, without the
comment above. Maybe you could call it something like
KEY_SELECTIVE_SCREENSHOT, so that its purpose is more apparent to
someone seeing it in use.

Harry Cutts
Chrome OS Touch/Input team

>  /*
>   * Some keyboards have keys which do not have a defined meaning, these keys
>   * are intended to be programmed / bound to macros by the user. For most
> --
> 2.25.0.265.gbab2e86ba0-goog
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] Input: Allocate keycode for SNIP key
  2020-03-12 20:31 ` Harry Cutts
@ 2020-03-13 17:46   ` Rajat Jain
  0 siblings, 0 replies; 4+ messages in thread
From: Rajat Jain @ 2020-03-13 17:46 UTC (permalink / raw)
  To: Harry Cutts; +Cc: Dmitry Torokhov, linux-input, lkml, Dmitry Torokhov

On Thu, Mar 12, 2020 at 1:31 PM Harry Cutts <hcutts@chromium.org> wrote:
>
> On Tue, 3 Mar 2020 at 16:21, Rajat Jain <rajatja@google.com> wrote:
> >
> > New chromeos keyboards have a "snip" key that is basically a selective
> > screenshot (allows a user to select an area of screen to be copied).
> > Allocate a keyvode for it.
> >
> > Signed-off-by: Rajat Jain <rajatja@google.com>
> > ---
> > V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.
> >
> >  include/uapi/linux/input-event-codes.h | 3 +++
> >  1 file changed, 3 insertions(+)
> >
> > diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
> > index 0f1db1cccc3fd..08c8572891efb 100644
> > --- a/include/uapi/linux/input-event-codes.h
> > +++ b/include/uapi/linux/input-event-codes.h
> > @@ -652,6 +652,9 @@
> >  /* Electronic privacy screen control */
> >  #define KEY_PRIVACY_SCREEN_TOGGLE      0x279
> >
> > +/* Selective Screenshot */
> > +#define KEY_SNIP                        0x280
> > +
>
> It's not very obvious to me what KEY_SNIP represents, without the
> comment above. Maybe you could call it something like
> KEY_SELECTIVE_SCREENSHOT, so that its purpose is more apparent to
> someone seeing it in use.

Sure, I do not have any preference, so I will change this to
KEY_SELECTIVE_SCREENSHOT.

Thanks,

Rajat

>
> Harry Cutts
> Chrome OS Touch/Input team
>
> >  /*
> >   * Some keyboards have keys which do not have a defined meaning, these keys
> >   * are intended to be programmed / bound to macros by the user. For most
> > --
> > 2.25.0.265.gbab2e86ba0-goog
> >

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-03-13 17:47 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-03-04  0:21 [PATCH v2] Input: Allocate keycode for SNIP key Rajat Jain
2020-03-12 19:32 ` Rajat Jain
2020-03-12 20:31 ` Harry Cutts
2020-03-13 17:46   ` Rajat Jain

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).