linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/4] rtw88: four small code-cleanups and refactorings
@ 2022-01-14 23:48 Martin Blumenstingl
  2022-01-14 23:48 ` [PATCH 1/4] rtw88: pci: Change type of rtw_hw_queue_mapping() and ac_to_hwq to enum Martin Blumenstingl
                   ` (3 more replies)
  0 siblings, 4 replies; 13+ messages in thread
From: Martin Blumenstingl @ 2022-01-14 23:48 UTC (permalink / raw)
  To: linux-wireless
  Cc: tony0620emma, kvalo, netdev, linux-kernel, Neo Jou,
	Jernej Skrabec, Pkshih, Martin Blumenstingl

Hello,

this series consists of four small patches which clean up and refactor
existing code in preparation for SDIO support. Functionality is
supposed to stay the same with these changes.

The goal of the first two patches is to make it easier to understand
the allowed values in the queue by using enum rtw_tx_queue_type instead
of u8.

The third patch in this series moves the rtw_tx_queue_type code out of
pci.c so it can be re-used by SDIO (and also USB) HCIs.

The last patch is another small cleanup to improve readability of the
code by using (already existing) macros instead of magic BIT(n).

This series is built on top of v3 of my other series called "rtw88:
prepare locking for SDIO support" [0].


[0] https://lore.kernel.org/linux-wireless/20220108005533.947787-1-martin.blumenstingl@googlemail.com/


Martin Blumenstingl (4):
  rtw88: pci: Change type of rtw_hw_queue_mapping() and ac_to_hwq to
    enum
  rtw88: pci: Change queue datatype from u8 to enum rtw_tx_queue_type
  rtw88: Move enum rtw_tx_queue_type mapping code to tx.{c,h}
  rtw88: mac: Use existing interface mask macros in rtw_pwr_seq_parser()

 drivers/net/wireless/realtek/rtw88/mac.c |  4 +-
 drivers/net/wireless/realtek/rtw88/pci.c | 47 ++++++------------------
 drivers/net/wireless/realtek/rtw88/tx.c  | 35 ++++++++++++++++++
 drivers/net/wireless/realtek/rtw88/tx.h  |  3 ++
 4 files changed, 51 insertions(+), 38 deletions(-)

-- 
2.34.1


^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2022-01-27 12:11 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-14 23:48 [PATCH 0/4] rtw88: four small code-cleanups and refactorings Martin Blumenstingl
2022-01-14 23:48 ` [PATCH 1/4] rtw88: pci: Change type of rtw_hw_queue_mapping() and ac_to_hwq to enum Martin Blumenstingl
2022-01-17 12:11   ` Kalle Valo
2022-01-17 17:48     ` Martin Blumenstingl
2022-01-14 23:48 ` [PATCH 2/4] rtw88: pci: Change queue datatype from u8 to enum rtw_tx_queue_type Martin Blumenstingl
2022-01-19  6:04   ` Pkshih
2022-01-14 23:48 ` [PATCH 3/4] rtw88: Move enum rtw_tx_queue_type mapping code to tx.{c,h} Martin Blumenstingl
2022-01-19  6:04   ` Pkshih
2022-01-19  6:19     ` Kalle Valo
2022-01-23 18:34       ` Martin Blumenstingl
2022-01-27 12:11         ` Kalle Valo
2022-01-14 23:48 ` [PATCH 4/4] rtw88: mac: Use existing interface mask macros in rtw_pwr_seq_parser() Martin Blumenstingl
2022-01-19  6:04   ` Pkshih

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).