linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Yuyang Du <duyuyang@gmail.com>
To: Joe Perches <joe@perches.com>
Cc: peterz@infradead.org, will.deacon@arm.com, mingo@kernel.org,
	bvanassche@acm.org, ming.lei@redhat.com,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 01/19] locking/lockdep: Change all print_*() return type to void
Date: Tue, 19 Mar 2019 11:28:01 +0800	[thread overview]
Message-ID: <CAHttsrZAtfNuk80R=m3E--z6O6RCTNSbBN35+PPAHN2UgDYzog@mail.gmail.com> (raw)
In-Reply-To: <494746a793619dd9b43fb152de811a6e7de77cce.camel@perches.com>

Thanks for the review.

On Mon, 18 Mar 2019 at 17:45, Joe Perches <joe@perches.com> wrote:
>
> On Mon, 2019-03-18 at 16:57 +0800, Yuyang Du wrote:
> > Since none of the print_*() function's return value is necessary, change
> > their return type to void. No functional change.
> >
> > In cases where an invariable return value is used, this change slightly
> > improves readability, i.e.:
> []
> > diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
> []
> > @@ -1430,23 +1430,20 @@ static inline int __bfs_backwards(struct lock_list *src_entry,
> []
> > -static void
> > -print_circular_lock_scenario(struct held_lock *src,
> > -                          struct held_lock *tgt,
> > -                          struct lock_list *prt)
> > +static void print_circular_lock_scenario(struct held_lock *src,
> > +                                      struct held_lock *tgt,
> > +                                      struct lock_list *prt)
>
> trivia:
>
> This style change seems superfluous as many
> other existing functions use the previous style.

Those "many other" are kind of bizarre already in the context of that
file IMHO. So the change went to great lengths in #05 :)

  reply	other threads:[~2019-03-19  3:28 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-18  8:57 [PATCH v2 00/19] locking/lockdep: Add comments and make some code Yuyang Du
2019-03-18  8:57 ` [PATCH v2 01/19] locking/lockdep: Change all print_*() return type to void Yuyang Du
2019-03-18  9:45   ` Joe Perches
2019-03-19  3:28     ` Yuyang Du [this message]
2019-03-19 16:30     ` Bart Van Assche
2019-03-18  8:57 ` [PATCH v2 02/19] locking/lockdep: Add description and explanation in lockdep design doc Yuyang Du
2019-03-18  8:57 ` [PATCH v2 03/19] locking/lockdep: Adjust lock usage bit character checks Yuyang Du
2019-03-18  8:57 ` [PATCH v2 04/19] locking/lockdep: Remove useless conditional macro Yuyang Du
2019-03-18  8:57 ` [PATCH v2 05/19] locking/lockdep: Adjust indents for function definitions Yuyang Du
2019-03-19 16:33   ` Bart Van Assche
2019-03-19 16:36     ` Peter Zijlstra
2019-03-18  8:57 ` [PATCH v2 06/19] locking/lockdep: Print the right depth for chain key colission Yuyang Du
2019-03-18  8:57 ` [PATCH v2 07/19] locking/lockdep: Update obsolete struct field description Yuyang Du
2019-03-19 16:35   ` Bart Van Assche
2019-03-19 16:44     ` Peter Zijlstra
2019-03-18  8:57 ` [PATCH v2 08/19] locking/lockdep: Use lockdep_init_task for task initiation consistently Yuyang Du
2019-03-18  8:57 ` [PATCH v2 09/19] locking/lockdep: Define INITIAL_CHAIN_KEY for chain keys to start with Yuyang Du
2019-03-18  8:57 ` [PATCH v2 10/19] locking/lockdep: Change the range of class_idx in held_lock struct Yuyang Du
2019-03-18  8:57 ` [PATCH v2 11/19] locking/lockdep: Remove unused argument in validate_chain() Yuyang Du
2019-03-19 16:45   ` Bart Van Assche
2019-03-18  8:57 ` [PATCH v2 12/19] locking/lockdep: Update comment Yuyang Du
2019-03-18  8:57 ` [PATCH v2 13/19] locking/lockdep: Remove unnecessary function pointer argument Yuyang Du
2019-03-19 16:48   ` Bart Van Assche
2019-03-18  8:57 ` [PATCH v2 14/19] locking/lockdep: Change type of the element field in circular_queue Yuyang Du
2019-03-19 16:50   ` Bart Van Assche
2019-03-19 16:51   ` Bart Van Assche
2019-03-18  8:57 ` [PATCH v2 15/19] locking/lockdep: Remove __cq_empty() Yuyang Du
2019-03-19 16:54   ` Bart Van Assche
2019-03-20  2:30     ` Yuyang Du
2019-03-18  8:57 ` [PATCH v2 16/19] locking/lockdep: Use function pointer to avoid constant checks Yuyang Du
2019-03-19 16:56   ` Bart Van Assche
2019-03-18  8:57 ` [PATCH v2 17/19] locking/lockdep: Combine check_noncircular and check_redundant Yuyang Du
2019-03-18  8:57 ` [PATCH v2 18/19] locking/lockdep: Update comments on dependency search Yuyang Du
2019-03-18  8:57 ` [PATCH v2 19/19] locking/lockdep: Change if to else-if when checking bfs errors Yuyang Du
2019-03-19 16:29   ` Bart Van Assche
2019-03-19 17:19     ` Joe Perches
2019-03-20  2:02     ` Yuyang Du

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHttsrZAtfNuk80R=m3E--z6O6RCTNSbBN35+PPAHN2UgDYzog@mail.gmail.com' \
    --to=duyuyang@gmail.com \
    --cc=bvanassche@acm.org \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ming.lei@redhat.com \
    --cc=mingo@kernel.org \
    --cc=peterz@infradead.org \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).