linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCHv7 0/5] Common Mailbox Framework
@ 2014-06-12 16:58 Jassi Brar
  2014-06-12 17:00 ` [PATCHv7 1/5] mailbox: rename pl320-ipc specific mailbox.h Jassi Brar
                   ` (5 more replies)
  0 siblings, 6 replies; 20+ messages in thread
From: Jassi Brar @ 2014-06-12 16:58 UTC (permalink / raw)
  To: linux-kernel
  Cc: devicetree, mporter, patches, bjorn, ashwin.chaugule, gregkh,
	s-anna, loic.pallardy, lftan.linux, slapdau, courtney.cavin,
	pawel.moll, robh+dt, mark.rutland, ijc+devicetree, arnd, joshc,
	linus.walleij, galak, ks.giri

Hello,
  Here is the next revision of Mailbox framwork.

Changes since v6:
 o Separate out generic DT bindings patch.
 o Discard unnecessary aligned attributes.

Changes since v5:
 o Use standard error types instead of special type mbox_result.
 o Constify client struct in request_channel
 o Use reinit_completion instead of init_completion every time.
 o Improve commentary in bindings and code.

Changes since v4:
 o Common DT binding for Controller and Client drivers
    As a result, discard string based channel matching
 o Provide for an atomic 'peek' api, that a client could
    call to trigger the controller driver push data upwards.
 o OMAP and Highbank conversion to new api is left out, which
    can be converted later by the developers.

Changes since v3:
 o Change name of symbols from ipc to mbox
 o Return real types instead of void *
 o Align structures
 o Change some symbol names
	rxcb -> rx_callback
	txcb -> tx_done
 o Added kernel-doc for exported API
 o Dropped the cl_id and use clients pointer for callbacks.
 o Fixed locking of channel pool
 o Return negative error code for unsuccessful ipc_send_message()
 o Module referencing during mailbox assignment to a client.
 o Made error code symbols specific to mailbox.

Thanks
Jassi

^ permalink raw reply	[flat|nested] 20+ messages in thread

end of thread, other threads:[~2014-06-30 16:22 UTC | newest]

Thread overview: 20+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-06-12 16:58 [PATCHv7 0/5] Common Mailbox Framework Jassi Brar
2014-06-12 17:00 ` [PATCHv7 1/5] mailbox: rename pl320-ipc specific mailbox.h Jassi Brar
2014-06-12 17:01 ` [PATCHv7 2/5] mailbox: Introduce framework for mailbox Jassi Brar
2014-06-13 20:40   ` Mark Brown
2014-06-18  0:27   ` Kevin Hilman
2014-06-18  8:33     ` Jassi Brar
2014-06-18 17:03       ` Kevin Hilman
2014-06-19  2:55         ` Jassi Brar
2014-06-19 12:14           ` Ashwin Chaugule
2014-06-19 12:36           ` Sudeep Holla
2014-06-19 18:17   ` Sudeep Holla
     [not found]     ` <20140619190342.GT4173@beef>
2014-06-19 20:29       ` Jassi Brar
2014-06-19 20:40         ` Matt Porter
2014-06-20 18:05   ` Lubomir Rintel
2014-06-22 10:56   ` Lubomir Rintel
2014-06-12 17:01 ` [PATCHv7 3/5] Mailbox: Generic: Specify mailbox api bindings Jassi Brar
2014-06-12 17:02 ` [PATCHv7 4/5] mailbox: Fix deleteing poll timer Jassi Brar
2014-06-12 17:02 ` [PATCHv7 5/5] MAINTAINERS: Add maintainer entry for Mailbox API Jassi Brar
2014-06-30 16:16 ` [PATCHv7 0/5] Common Mailbox Framework Lubomir Rintel
2014-06-30 16:22   ` Jassi Brar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).