linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Masahiro Yamada <masahiroy@kernel.org>
To: Greg Thelen <gthelen@google.com>,
	Ben Hutchings <ben@decadent.org.uk>,
	"H. Peter Anvin" <hpa@zytor.com>
Cc: Linux Kbuild mailing list <linux-kbuild@vger.kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Sam Ravnborg <sam@ravnborg.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 04/13] initramfs: rename gen_initramfs_list.sh to gen_initramfs.sh
Date: Mon, 6 Jan 2020 19:26:22 +0900	[thread overview]
Message-ID: <CAK7LNAT2ai=-wbLmU2hqihbzVy7kKCGg=ipOK09XtSWiDYMW1Q@mail.gmail.com> (raw)
In-Reply-To: <xr93ftgt6ndv.fsf@gthelen.svl.corp.google.com>

(+CC Ben Hutchings, H. Peter Anvin)

In my understanding, the klibc build system is standalone.
So, the change in Linux kernel does not affect klibc at all.
Only the depending part is UAPI headers (make headers_install).

So, this patch
(https://lore.kernel.org/patchwork/patch/1175336/)
should be OK.

Please correct me if I am wrong.


On Mon, Jan 6, 2020 at 4:43 PM Greg Thelen <gthelen@google.com> wrote:
>
> Masahiro Yamada <masahiroy@kernel.org> wrote:
>
> > The comments in usr/Makefile wrongly refer to the script name (twice).
> >
> > Line 37:
> >     # The dependency list is generated by gen_initramfs.sh -l
> >
> > Line 54:
> >     # 4) Arguments to gen_initramfs.sh changes
> >
> > There does not exist such a script.
> >
> > I was going to fix the comments, but after some consideration, I thought
> > "gen_initramfs.sh" would be more suitable than "gen_initramfs_list.sh"
> > because it generates an initramfs image in the common usage.
> >
> > The script generates a list that can be fed to gen_init_cpio only when
> > it is directly run without -o or -l option.
> >
> > Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
> > ---
> >
> > Changes in v2: None
> >
> >  usr/Makefile                                    | 2 +-
> >  usr/{gen_initramfs_list.sh => gen_initramfs.sh} | 0
> >  2 files changed, 1 insertion(+), 1 deletion(-)
> >  rename usr/{gen_initramfs_list.sh => gen_initramfs.sh} (100%)
>
> Will this break klibc?  It might have a ref to the old name.
> https://git.kernel.org/pub/scm/libs/klibc/klibc.git/tree/usr/Kbuild#n55

I do not think so.

As I stated above, the klibc build system is independent of
any script in the Linux kernel.

The klibc Makefile refers to
scripts/gen_initramfs_list.sh, which does not exist.

My path is renaming
usr/gen_initramfs_list.sh to usr/gen_initramfs.sh


If the renaming had been problematic for klibc,
commit f6f57a46435d7253a52a1a07a58183678ad266a0
("initramfs: move gen_initramfs_list.sh from scripts/ to usr/")
would have already caused a problem.



Ben, Hans,
Is usr/Kbuild in klibc used?
If it is not used, is it better to delete it to avoid confusion?


Masahiro Yamada




> > diff --git a/usr/Makefile b/usr/Makefile
> > index 55c942da01cd..e44a66b8c051 100644
> > --- a/usr/Makefile
> > +++ b/usr/Makefile
> > @@ -24,7 +24,7 @@ $(obj)/initramfs_data.o: $(obj)/$(datafile_y) FORCE
> >  # Generate the initramfs cpio archive
> >
> >  hostprogs-y := gen_init_cpio
> > -initramfs   := $(CONFIG_SHELL) $(srctree)/$(src)/gen_initramfs_list.sh
> > +initramfs   := $(CONFIG_SHELL) $(srctree)/$(src)/gen_initramfs.sh
> >  ramfs-input := $(if $(filter-out "",$(CONFIG_INITRAMFS_SOURCE)), \
> >                       $(shell echo $(CONFIG_INITRAMFS_SOURCE)),-d)
> >  ramfs-args  := \
> > diff --git a/usr/gen_initramfs_list.sh b/usr/gen_initramfs.sh
> > similarity index 100%
> > rename from usr/gen_initramfs_list.sh
> > rename to usr/gen_initramfs.sh



-- 
Best Regards
Masahiro Yamada

  reply	other threads:[~2020-01-06 10:27 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-04 15:02 [PATCH v2 00/13] initramfs: a lot of cleanups Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 01/13] initramfs: replace klibcdirs in Makefile with FORCE Masahiro Yamada
2020-01-06  7:33   ` Greg Thelen
2020-01-07 10:46   ` Masahiro Yamada
2020-01-07 17:13     ` hpa
2020-01-04 15:02 ` [PATCH v2 02/13] gen_initramfs_list.sh: remove unused variable 'default_list' Masahiro Yamada
2020-01-06  7:34   ` Greg Thelen
2020-01-04 15:02 ` [PATCH v2 03/13] gen_initramfs_list.sh: fix the tool name in the comment Masahiro Yamada
2020-01-06  7:34   ` Greg Thelen
2020-01-04 15:02 ` [PATCH v2 04/13] initramfs: rename gen_initramfs_list.sh to gen_initramfs.sh Masahiro Yamada
2020-01-06  7:43   ` Greg Thelen
2020-01-06 10:26     ` Masahiro Yamada [this message]
2020-01-07  3:02       ` Ben Hutchings
2020-01-07  3:21       ` hpa
2020-01-04 15:02 ` [PATCH v2 05/13] initramfs: remove redundant dependency on BLK_DEV_INITRD Masahiro Yamada
2020-01-06  7:44   ` Greg Thelen
2020-01-04 15:02 ` [PATCH v2 06/13] initramfs: make compression options not depend on INITRAMFS_SOURCE Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 07/13] initramfs: make initramfs compression choice non-optional Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 08/13] initramfs: specify $(src)/gen_initramfs.sh as a prerequisite in Makefile Masahiro Yamada
2020-01-06  7:51   ` Greg Thelen
2020-01-04 15:02 ` [PATCH v2 09/13] initramfs: generate dependency list and cpio at the same time Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 10/13] initramfs: add default_cpio_list, and delete -d option support Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 11/13] gen_initramfs.sh: always output cpio even without -o option Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 12/13] initramfs: refactor the initramfs build rules Masahiro Yamada
2020-01-04 15:02 ` [PATCH v2 13/13] gen_initramfs.sh: remove intermediate cpio_list on errors Masahiro Yamada
2020-01-21 15:59 ` [PATCH v2 00/13] initramfs: a lot of cleanups Masahiro Yamada

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAK7LNAT2ai=-wbLmU2hqihbzVy7kKCGg=ipOK09XtSWiDYMW1Q@mail.gmail.com' \
    --to=masahiroy@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=ben@decadent.org.uk \
    --cc=gthelen@google.com \
    --cc=hpa@zytor.com \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).