linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/3] davinci: ohci: fix usb ohci device name
@ 2016-11-03 16:03 Axel Haslam
  2016-11-03 16:03 ` [PATCH v2 1/3] ARM: davinci: da8xx: Fix " Axel Haslam
                   ` (3 more replies)
  0 siblings, 4 replies; 9+ messages in thread
From: Axel Haslam @ 2016-11-03 16:03 UTC (permalink / raw)
  To: khilman, nsekhar, david, gregkh, kishon
  Cc: linux-arm-kernel, linux-kernel, linux-usb, Axel Haslam

The usb ohci clock match is not working because the usb clock
is registered as "ohci" instead of "ohci.0"

But since there is only a single ohci instance, lets pass -1 to
the platform data id parameter and avoid the extra ".0" matching.

while we are fixing this, rename the driver from "ohci" to
"ohci-da8xx" which  is less generic and consistent with other
usb drivers.

changes form v1 -> v2
*Reword commit messages (David Lechner)

Because of the recently accepted patches on the ARM-davinci side,
This patch series is based on:
branch: /v4.10/soc of the linux-davinci tree.

It Depends on two accepted usb patches missing on that branch:
6c21caa USB: OHCI: make ohci-da8xx a separate driver (in next-usb)
6110c42 usb: ohci-da8xx: Remove code that references mach (in linux-next)

A branch with both patches applied + this series can be found here:
https://github.com/axelhaslamx/linux-axel/commits/ti-davinci-ohci-rename


Axel Haslam (3):
  ARM: davinci: da8xx: Fix ohci device name
  phy: da8xx-usb: rename the ohci device to ohci-da8xx
  usb: ohci-da8xx: rename driver to ohci-da8xx

 arch/arm/mach-davinci/da830.c     | 2 +-
 arch/arm/mach-davinci/da850.c     | 2 +-
 arch/arm/mach-davinci/da8xx-dt.c  | 2 +-
 arch/arm/mach-davinci/usb-da8xx.c | 4 ++--
 drivers/phy/phy-da8xx-usb.c       | 5 +++--
 drivers/usb/host/ohci-da8xx.c     | 2 +-
 6 files changed, 9 insertions(+), 8 deletions(-)

-- 
2.10.1

^ permalink raw reply	[flat|nested] 9+ messages in thread

* [PATCH v2 1/3] ARM: davinci: da8xx: Fix ohci device name
  2016-11-03 16:03 [PATCH v2 0/3] davinci: ohci: fix usb ohci device name Axel Haslam
@ 2016-11-03 16:03 ` Axel Haslam
  2016-11-23 12:07   ` Sekhar Nori
  2016-11-03 16:03 ` [PATCH v2 2/3] phy: da8xx-usb: rename the ohci device to ohci-da8xx Axel Haslam
                   ` (2 subsequent siblings)
  3 siblings, 1 reply; 9+ messages in thread
From: Axel Haslam @ 2016-11-03 16:03 UTC (permalink / raw)
  To: khilman, nsekhar, david, gregkh, kishon
  Cc: linux-arm-kernel, linux-kernel, linux-usb, Axel Haslam

While the clk lookup table is making reference to "ohci"
other subsystems (such as phy) are trying to match "ohci.0"

Since there is a single ohci instance, instead of changing
the clk name, change the dev id to -1, and add the "-da8xx"
postfix to match the driver name that will also be changed
in a subsequent patch.

Signed-off-by: Axel Haslam <ahaslam@baylibre.com>
---
 arch/arm/mach-davinci/da830.c     | 2 +-
 arch/arm/mach-davinci/da850.c     | 2 +-
 arch/arm/mach-davinci/da8xx-dt.c  | 2 +-
 arch/arm/mach-davinci/usb-da8xx.c | 4 ++--
 4 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/arm/mach-davinci/da830.c b/arch/arm/mach-davinci/da830.c
index 41459bd..073c458 100644
--- a/arch/arm/mach-davinci/da830.c
+++ b/arch/arm/mach-davinci/da830.c
@@ -420,7 +420,7 @@ static struct clk_lookup da830_clks[] = {
 	CLK("davinci_mdio.0",   "fck",          &emac_clk),
 	CLK(NULL,		"gpio",		&gpio_clk),
 	CLK("i2c_davinci.2",	NULL,		&i2c1_clk),
-	CLK("ohci",		"usb11",	&usb11_clk),
+	CLK("ohci-da8xx",	"usb11",	&usb11_clk),
 	CLK(NULL,		"emif3",	&emif3_clk),
 	CLK(NULL,		"arm",		&arm_clk),
 	CLK(NULL,		"rmii",		&rmii_clk),
diff --git a/arch/arm/mach-davinci/da850.c b/arch/arm/mach-davinci/da850.c
index 196e262..3961556 100644
--- a/arch/arm/mach-davinci/da850.c
+++ b/arch/arm/mach-davinci/da850.c
@@ -503,7 +503,7 @@ static struct clk_lookup da850_clks[] = {
 	CLK("da830-mmc.1",	NULL,		&mmcsd1_clk),
 	CLK("ti-aemif",		NULL,		&aemif_clk),
 	CLK(NULL,		"aemif",	&aemif_clk),
-	CLK("ohci",		"usb11",	&usb11_clk),
+	CLK("ohci-da8xx",	"usb11",	&usb11_clk),
 	CLK("musb-da8xx",	"usb20",	&usb20_clk),
 	CLK("spi_davinci.0",	NULL,		&spi0_clk),
 	CLK("spi_davinci.1",	NULL,		&spi1_clk),
diff --git a/arch/arm/mach-davinci/da8xx-dt.c b/arch/arm/mach-davinci/da8xx-dt.c
index 92ae093..2afb067 100644
--- a/arch/arm/mach-davinci/da8xx-dt.c
+++ b/arch/arm/mach-davinci/da8xx-dt.c
@@ -39,7 +39,7 @@ static struct of_dev_auxdata da850_auxdata_lookup[] __initdata = {
 	OF_DEV_AUXDATA("ti,da830-mcasp-audio", 0x01d00000, "davinci-mcasp.0", NULL),
 	OF_DEV_AUXDATA("ti,da850-aemif", 0x68000000, "ti-aemif", NULL),
 	OF_DEV_AUXDATA("ti,da850-tilcdc", 0x01e13000, "da8xx_lcdc.0", NULL),
-	OF_DEV_AUXDATA("ti,da830-ohci", 0x01e25000, "ohci", NULL),
+	OF_DEV_AUXDATA("ti,da830-ohci", 0x01e25000, "ohci-da8xx", NULL),
 	OF_DEV_AUXDATA("ti,da830-musb", 0x01e00000, "musb-da8xx", NULL),
 	OF_DEV_AUXDATA("ti,da830-usb-phy", 0x01c1417c, "da8xx-usb-phy", NULL),
 	{}
diff --git a/arch/arm/mach-davinci/usb-da8xx.c b/arch/arm/mach-davinci/usb-da8xx.c
index b010e5f..c6feecf 100644
--- a/arch/arm/mach-davinci/usb-da8xx.c
+++ b/arch/arm/mach-davinci/usb-da8xx.c
@@ -109,8 +109,8 @@ static struct resource da8xx_usb11_resources[] = {
 static u64 da8xx_usb11_dma_mask = DMA_BIT_MASK(32);
 
 static struct platform_device da8xx_usb11_device = {
-	.name		= "ohci",
-	.id		= 0,
+	.name		= "ohci-da8xx",
+	.id		= -1,
 	.dev = {
 		.dma_mask		= &da8xx_usb11_dma_mask,
 		.coherent_dma_mask	= DMA_BIT_MASK(32),
-- 
2.10.1

^ permalink raw reply related	[flat|nested] 9+ messages in thread

* [PATCH v2 2/3] phy: da8xx-usb: rename the ohci device to ohci-da8xx
  2016-11-03 16:03 [PATCH v2 0/3] davinci: ohci: fix usb ohci device name Axel Haslam
  2016-11-03 16:03 ` [PATCH v2 1/3] ARM: davinci: da8xx: Fix " Axel Haslam
@ 2016-11-03 16:03 ` Axel Haslam
  2016-11-05  5:21   ` Kishon Vijay Abraham I
  2016-11-03 16:03 ` [PATCH v2 3/3] usb: ohci-da8xx: rename driver " Axel Haslam
  2016-11-03 16:49 ` [PATCH v2 0/3] davinci: ohci: fix usb ohci device name David Lechner
  3 siblings, 1 reply; 9+ messages in thread
From: Axel Haslam @ 2016-11-03 16:03 UTC (permalink / raw)
  To: khilman, nsekhar, david, gregkh, kishon
  Cc: linux-arm-kernel, linux-kernel, linux-usb, Axel Haslam

The ohci device name has changed in the board configuraion files,
hence, change the phy lookup table to match the new name.

Signed-off-by: Axel Haslam <ahaslam@baylibre.com>
---
 drivers/phy/phy-da8xx-usb.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/phy/phy-da8xx-usb.c b/drivers/phy/phy-da8xx-usb.c
index 32ae78c..c85fb0b 100644
--- a/drivers/phy/phy-da8xx-usb.c
+++ b/drivers/phy/phy-da8xx-usb.c
@@ -198,7 +198,8 @@ static int da8xx_usb_phy_probe(struct platform_device *pdev)
 	} else {
 		int ret;
 
-		ret = phy_create_lookup(d_phy->usb11_phy, "usb-phy", "ohci.0");
+		ret = phy_create_lookup(d_phy->usb11_phy, "usb-phy",
+					"ohci-da8xx");
 		if (ret)
 			dev_warn(dev, "Failed to create usb11 phy lookup\n");
 		ret = phy_create_lookup(d_phy->usb20_phy, "usb-phy",
@@ -216,7 +217,7 @@ static int da8xx_usb_phy_remove(struct platform_device *pdev)
 
 	if (!pdev->dev.of_node) {
 		phy_remove_lookup(d_phy->usb20_phy, "usb-phy", "musb-da8xx");
-		phy_remove_lookup(d_phy->usb11_phy, "usb-phy", "ohci.0");
+		phy_remove_lookup(d_phy->usb11_phy, "usb-phy", "ohci-da8xx");
 	}
 
 	return 0;
-- 
2.10.1

^ permalink raw reply related	[flat|nested] 9+ messages in thread

* [PATCH v2 3/3] usb: ohci-da8xx: rename driver to ohci-da8xx
  2016-11-03 16:03 [PATCH v2 0/3] davinci: ohci: fix usb ohci device name Axel Haslam
  2016-11-03 16:03 ` [PATCH v2 1/3] ARM: davinci: da8xx: Fix " Axel Haslam
  2016-11-03 16:03 ` [PATCH v2 2/3] phy: da8xx-usb: rename the ohci device to ohci-da8xx Axel Haslam
@ 2016-11-03 16:03 ` Axel Haslam
  2016-11-21 17:10   ` Axel Haslam
  2016-11-03 16:49 ` [PATCH v2 0/3] davinci: ohci: fix usb ohci device name David Lechner
  3 siblings, 1 reply; 9+ messages in thread
From: Axel Haslam @ 2016-11-03 16:03 UTC (permalink / raw)
  To: khilman, nsekhar, david, gregkh, kishon
  Cc: linux-arm-kernel, linux-kernel, linux-usb, Axel Haslam

The davinci ohci driver name (currently "ohci") is too generic.
To be consistent with other usb dirvers, append the "-da8xx" postfix
to the name.

Signed-off-by: Axel Haslam <ahaslam@baylibre.com>
---
 drivers/usb/host/ohci-da8xx.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/usb/host/ohci-da8xx.c b/drivers/usb/host/ohci-da8xx.c
index 30c4878..429d58b 100644
--- a/drivers/usb/host/ohci-da8xx.c
+++ b/drivers/usb/host/ohci-da8xx.c
@@ -27,7 +27,7 @@
 #include "ohci.h"
 
 #define DRIVER_DESC "DA8XX"
-#define DRV_NAME "ohci"
+#define DRV_NAME "ohci-da8xx"
 
 static struct hc_driver __read_mostly ohci_da8xx_hc_driver;
 
-- 
2.10.1

^ permalink raw reply related	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 0/3] davinci: ohci: fix usb ohci device name
  2016-11-03 16:03 [PATCH v2 0/3] davinci: ohci: fix usb ohci device name Axel Haslam
                   ` (2 preceding siblings ...)
  2016-11-03 16:03 ` [PATCH v2 3/3] usb: ohci-da8xx: rename driver " Axel Haslam
@ 2016-11-03 16:49 ` David Lechner
  3 siblings, 0 replies; 9+ messages in thread
From: David Lechner @ 2016-11-03 16:49 UTC (permalink / raw)
  To: Axel Haslam, khilman, nsekhar, gregkh, kishon
  Cc: linux-arm-kernel, linux-kernel, linux-usb

On 11/03/2016 11:03 AM, Axel Haslam wrote:
> The usb ohci clock match is not working because the usb clock
> is registered as "ohci" instead of "ohci.0"
>
> But since there is only a single ohci instance, lets pass -1 to
> the platform data id parameter and avoid the extra ".0" matching.
>
> while we are fixing this, rename the driver from "ohci" to
> "ohci-da8xx" which  is less generic and consistent with other
> usb drivers.
>
> changes form v1 -> v2
> *Reword commit messages (David Lechner)
>
> Because of the recently accepted patches on the ARM-davinci side,
> This patch series is based on:
> branch: /v4.10/soc of the linux-davinci tree.
>
> It Depends on two accepted usb patches missing on that branch:
> 6c21caa USB: OHCI: make ohci-da8xx a separate driver (in next-usb)
> 6110c42 usb: ohci-da8xx: Remove code that references mach (in linux-next)
>
> A branch with both patches applied + this series can be found here:
> https://github.com/axelhaslamx/linux-axel/commits/ti-davinci-ohci-rename
>
>
> Axel Haslam (3):
>   ARM: davinci: da8xx: Fix ohci device name
>   phy: da8xx-usb: rename the ohci device to ohci-da8xx
>   usb: ohci-da8xx: rename driver to ohci-da8xx
>
>  arch/arm/mach-davinci/da830.c     | 2 +-
>  arch/arm/mach-davinci/da850.c     | 2 +-
>  arch/arm/mach-davinci/da8xx-dt.c  | 2 +-
>  arch/arm/mach-davinci/usb-da8xx.c | 4 ++--
>  drivers/phy/phy-da8xx-usb.c       | 5 +++--
>  drivers/usb/host/ohci-da8xx.c     | 2 +-
>  6 files changed, 9 insertions(+), 8 deletions(-)
>

Thanks for making the changes. The commit messages make better sense to 
me now. :-)

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 2/3] phy: da8xx-usb: rename the ohci device to ohci-da8xx
  2016-11-03 16:03 ` [PATCH v2 2/3] phy: da8xx-usb: rename the ohci device to ohci-da8xx Axel Haslam
@ 2016-11-05  5:21   ` Kishon Vijay Abraham I
  0 siblings, 0 replies; 9+ messages in thread
From: Kishon Vijay Abraham I @ 2016-11-05  5:21 UTC (permalink / raw)
  To: Axel Haslam, khilman, nsekhar, david, gregkh
  Cc: linux-arm-kernel, linux-kernel, linux-usb



On Thursday 03 November 2016 09:33 PM, Axel Haslam wrote:
> The ohci device name has changed in the board configuraion files,
> hence, change the phy lookup table to match the new name.
> 
> Signed-off-by: Axel Haslam <ahaslam@baylibre.com>

merged, thanks.

-Kishon
> ---
>  drivers/phy/phy-da8xx-usb.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/phy/phy-da8xx-usb.c b/drivers/phy/phy-da8xx-usb.c
> index 32ae78c..c85fb0b 100644
> --- a/drivers/phy/phy-da8xx-usb.c
> +++ b/drivers/phy/phy-da8xx-usb.c
> @@ -198,7 +198,8 @@ static int da8xx_usb_phy_probe(struct platform_device *pdev)
>  	} else {
>  		int ret;
>  
> -		ret = phy_create_lookup(d_phy->usb11_phy, "usb-phy", "ohci.0");
> +		ret = phy_create_lookup(d_phy->usb11_phy, "usb-phy",
> +					"ohci-da8xx");
>  		if (ret)
>  			dev_warn(dev, "Failed to create usb11 phy lookup\n");
>  		ret = phy_create_lookup(d_phy->usb20_phy, "usb-phy",
> @@ -216,7 +217,7 @@ static int da8xx_usb_phy_remove(struct platform_device *pdev)
>  
>  	if (!pdev->dev.of_node) {
>  		phy_remove_lookup(d_phy->usb20_phy, "usb-phy", "musb-da8xx");
> -		phy_remove_lookup(d_phy->usb11_phy, "usb-phy", "ohci.0");
> +		phy_remove_lookup(d_phy->usb11_phy, "usb-phy", "ohci-da8xx");
>  	}
>  
>  	return 0;
> 

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 3/3] usb: ohci-da8xx: rename driver to ohci-da8xx
  2016-11-03 16:03 ` [PATCH v2 3/3] usb: ohci-da8xx: rename driver " Axel Haslam
@ 2016-11-21 17:10   ` Axel Haslam
  2016-11-23  9:32     ` Greg KH
  0 siblings, 1 reply; 9+ messages in thread
From: Axel Haslam @ 2016-11-21 17:10 UTC (permalink / raw)
  To: Kevin Hilman, Sekhar Nori, David Lechner, Greg KH
  Cc: linux-arm-kernel, linux-kernel, linux-usb, Axel Haslam, kishon

Hi Greg,

On Thu, Nov 3, 2016 at 5:03 PM, Axel Haslam <ahaslam@baylibre.com> wrote:
> The davinci ohci driver name (currently "ohci") is too generic.
> To be consistent with other usb dirvers, append the "-da8xx" postfix
> to the name.
>

if there are no objections, would it be possible to pick up this patch?
the corresponding phy patch was merged and the platform changes
are ack'ed, and will we taken by the davinci maintainer once this patch
gets in.

i can resend stand-alone if its preferred.

Regards
Axel

> Signed-off-by: Axel Haslam <ahaslam@baylibre.com>
> ---
>  drivers/usb/host/ohci-da8xx.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/usb/host/ohci-da8xx.c b/drivers/usb/host/ohci-da8xx.c
> index 30c4878..429d58b 100644
> --- a/drivers/usb/host/ohci-da8xx.c
> +++ b/drivers/usb/host/ohci-da8xx.c
> @@ -27,7 +27,7 @@
>  #include "ohci.h"
>
>  #define DRIVER_DESC "DA8XX"
> -#define DRV_NAME "ohci"
> +#define DRV_NAME "ohci-da8xx"
>
>  static struct hc_driver __read_mostly ohci_da8xx_hc_driver;
>
> --
> 2.10.1
>

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 3/3] usb: ohci-da8xx: rename driver to ohci-da8xx
  2016-11-21 17:10   ` Axel Haslam
@ 2016-11-23  9:32     ` Greg KH
  0 siblings, 0 replies; 9+ messages in thread
From: Greg KH @ 2016-11-23  9:32 UTC (permalink / raw)
  To: Axel Haslam
  Cc: Kevin Hilman, Sekhar Nori, David Lechner, linux-arm-kernel,
	linux-kernel, linux-usb, kishon

On Mon, Nov 21, 2016 at 06:10:50PM +0100, Axel Haslam wrote:
> Hi Greg,
> 
> On Thu, Nov 3, 2016 at 5:03 PM, Axel Haslam <ahaslam@baylibre.com> wrote:
> > The davinci ohci driver name (currently "ohci") is too generic.
> > To be consistent with other usb dirvers, append the "-da8xx" postfix
> > to the name.
> >
> 
> if there are no objections, would it be possible to pick up this patch?
> the corresponding phy patch was merged and the platform changes
> are ack'ed, and will we taken by the davinci maintainer once this patch
> gets in.

Now applied.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 1/3] ARM: davinci: da8xx: Fix ohci device name
  2016-11-03 16:03 ` [PATCH v2 1/3] ARM: davinci: da8xx: Fix " Axel Haslam
@ 2016-11-23 12:07   ` Sekhar Nori
  0 siblings, 0 replies; 9+ messages in thread
From: Sekhar Nori @ 2016-11-23 12:07 UTC (permalink / raw)
  To: Axel Haslam, khilman, david, gregkh, kishon
  Cc: linux-arm-kernel, linux-kernel, linux-usb

On Thursday 03 November 2016 09:33 PM, Axel Haslam wrote:
> While the clk lookup table is making reference to "ohci"
> other subsystems (such as phy) are trying to match "ohci.0"
> 
> Since there is a single ohci instance, instead of changing
> the clk name, change the dev id to -1, and add the "-da8xx"
> postfix to match the driver name that will also be changed
> in a subsequent patch.
> 
> Signed-off-by: Axel Haslam <ahaslam@baylibre.com>

Applied to v4.10/soc

Thanks,
Sekhar

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2016-11-23 15:40 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-11-03 16:03 [PATCH v2 0/3] davinci: ohci: fix usb ohci device name Axel Haslam
2016-11-03 16:03 ` [PATCH v2 1/3] ARM: davinci: da8xx: Fix " Axel Haslam
2016-11-23 12:07   ` Sekhar Nori
2016-11-03 16:03 ` [PATCH v2 2/3] phy: da8xx-usb: rename the ohci device to ohci-da8xx Axel Haslam
2016-11-05  5:21   ` Kishon Vijay Abraham I
2016-11-03 16:03 ` [PATCH v2 3/3] usb: ohci-da8xx: rename driver " Axel Haslam
2016-11-21 17:10   ` Axel Haslam
2016-11-23  9:32     ` Greg KH
2016-11-03 16:49 ` [PATCH v2 0/3] davinci: ohci: fix usb ohci device name David Lechner

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).