linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Rob Herring <robh+dt@kernel.org>
To: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Cc: Mark Brown <broonie@kernel.org>,
	Linux-ALSA <alsa-devel@alsa-project.org>,
	Liam Girdwood <lgirdwood@gmail.com>, Simon <horms@verge.net.au>,
	Laurent <laurent.pinchart@ideasonboard.com>,
	Guennadi <g.liakhovetski@gmx.de>,
	Grant Likely <grant.likely@linaro.org>,
	Frank Rowand <frowand.list@gmail.com>,
	Linux-DT <devicetree@vger.kernel.org>,
	Linux-Kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 20/23] ASoC: add simple-graph-card document
Date: Tue, 18 Oct 2016 10:53:31 -0500	[thread overview]
Message-ID: <CAL_JsqJY-KtoR7C-vKBP1p3XRKkiVHBM9mzCdV3_P2DSp-xw9A@mail.gmail.com> (raw)
In-Reply-To: <87zim32xbo.wl%kuninori.morimoto.gx@renesas.com>

On Mon, Oct 17, 2016 at 3:38 AM, Kuninori Morimoto
<kuninori.morimoto.gx@renesas.com> wrote:
>
> From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
>
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> ---
>  .../bindings/sound/simple-graph-card.txt           | 65 ++++++++++++++++++++++
>  1 file changed, 65 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/sound/simple-graph-card.txt
>
> diff --git a/Documentation/devicetree/bindings/sound/simple-graph-card.txt b/Documentation/devicetree/bindings/sound/simple-graph-card.txt
> new file mode 100644
> index 0000000..c191c0d
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/sound/simple-graph-card.txt
> @@ -0,0 +1,65 @@
> +Simple-Graph-Card:
> +
> +Simple-Graph-Card specifies audio DAI connections of SoC <-> codec.
> +It is based on common bindings for device graphs.
> +see ${LINUX}/Documentation/devicetree/bindings/graph.txt
> +
> +Basically, Simple-Graph-Card is same as Simple-Card, but using graph style.
> +see ${LINUX}/Documentation/devicetree/bindings/sound/simple-card.txt
> +
> +Below are same as Simple-Card.
> +
> +- simple-audio-card,name
> +- simple-audio-card,widgets
> +- simple-audio-card,routing
> +- simple-audio-card,mclk-fs
> +- simple-audio-card,hp-det-gpio
> +- simple-audio-card,mic-det-gpio
> +- simple-audio-card,format
> +- simple-audio-card,frame-master
> +- simple-audio-card,bitclock-master
> +- simple-audio-card,bitclock-inversion
> +- simple-audio-card,frame-inversion
> +- simple-audio-card,mclk-fs
> +- simple-audio-card,dai-tdm-slot-num
> +- simple-audio-card,dai-tdm-slot-width
> +- clocks / system-clock-frequency
> +
> +This Simple-Graph-Card should be located as CPU driver's port[s].
> +And then, CPU driver need to probe it by itself.
> +
> +Required properties:
> +
> +- compatible                           : "asoc-simple-graph-card";
> +- type                                 : "sound";
> +
> +Example
> +
> +ak4643: codec@12 {
> +       compatible = "asahi-kasei,ak4643";
> +       ...
> +       port {
> +               type = "sound";
> +               ak4643_port: endpoint {
> +                       remote-endpoint = <&rcar_ak4643_port>;
> +                       clocks = <&audio_clock>;

This belongs in the codec node.

> +               };
> +       };
> +};
> +
> +rcar_sound {
> +       ...
> +       port {
> +               compatible = "asoc-simple-graph-card";
> +
> +               simple-audio-card,format = "left_j";
> +               simple-audio-card,bitclock-master = <&ak4643_port>;
> +               simple-audio-card,frame-master = <&ak4643_port>;

Don't add a bunch of properties with in port and endpoint nodes. The
purpose is to describe the graph. Put these in the parent node or
perhaps the codec node.

> +               type = "sound";

I'm still not convinced this is necessary. This is implied either by
the fact there is only one port or perhaps the compatible string.

> +               rcar_ak4643_port: endpoint {
> +                       remote-endpoint = <&ak4643_port>;
> +                       playback = <&ssi0 &src2 &dvc0>;
> +                       capture  = <&ssi1 &src3 &dvc1>;
> +               };
> +       };
> +};
> --
> 1.9.1
>

  reply	other threads:[~2016-10-18 15:54 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-17  8:30 [PATCH 0/23] ASoC: add OF graph base simple-card Kuninori Morimoto
2016-10-17  8:32 ` [PATCH 01/23] ASoC: simple-scu-card: code sync: follow to simple family style Kuninori Morimoto
2016-10-28 18:49   ` Applied "ASoC: simple-scu-card: code sync: follow to simple family style" to the asoc tree Mark Brown
2016-10-17  8:32 ` [PATCH 02/23] ASoC: simple-scu-card: code sync: rename asoc_simple_card_priv Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-scu-card: code sync: rename asoc_simple_card_priv" to the asoc tree Mark Brown
2016-10-17  8:32 ` [PATCH 03/23] ASoC: simple-scu-card: code sync: tidyup props/link naming Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-scu-card: code sync: tidyup props/link naming" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 04/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_card_name Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_card_name" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 05/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_simple_widgets Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_simple_widgets" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 06/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_routing Kuninori Morimoto
2016-11-11 15:29   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_routing" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 07/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_prefix Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_prefix" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 08/23] ASoC: soc-core: snd_soc_get_dai_name() become non static Kuninori Morimoto
2016-10-18  7:27   ` [alsa-devel] " Jean-Francois Moine
2016-11-11 15:28   ` Applied "ASoC: soc-core: snd_soc_get_dai_name() become non static" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 09/23] ASoC: simple-card-utils: remove unnecessary cpu/codec pointer check Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-card-utils: remove unnecessary cpu/codec pointer check" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 10/23] ASoC: simple-card-utils: adjust for graph on asoc_simple_card_parse_card_name Kuninori Morimoto
2016-10-17  8:35 ` [PATCH 11/23] Documentation: of: add type property Kuninori Morimoto
2016-10-17  8:35 ` [PATCH 12/23] of_graph: add of_graph_get_remote_endpoint() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 13/23] of_graph: add of_graph_port_type_is() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 14/23] of_graph: add of_graph_get_port_parent() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 15/23] of_graph: add of_graph_get_top_port() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 16/23] of_graph: add for_each_of_port() / for_each_of_endpoint_in_port() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 17/23] of_graph: add of_graph_get_endpoint_count() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 18/23] ASoC: simple-card-utils: add asoc_simple_card_parse_graph_dai() Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 19/23] ASoC: simple-card-utils: add asoc_simple_card_try_to_probe_graph_card() Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 20/23] ASoC: add simple-graph-card document Kuninori Morimoto
2016-10-18 15:53   ` Rob Herring [this message]
2016-10-19  1:36     ` Kuninori Morimoto
2016-10-19  2:39       ` Rob Herring
2016-10-19  6:13         ` Kuninori Morimoto
2016-10-21  5:45       ` Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 21/23] ASoC: add simple-graph-card support Kuninori Morimoto
2016-10-17  8:39 ` [PATCH 22/23] ASoC: add simple-graph-scu-card document Kuninori Morimoto
2016-10-17  8:39 ` [PATCH 23/23] ASoC: add simple-graph-scu-card support Kuninori Morimoto
2016-10-18  7:10 ` [alsa-devel] [PATCH 0/23] ASoC: add OF graph base simple-card Jean-Francois Moine
2016-10-18  8:44   ` Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAL_JsqJY-KtoR7C-vKBP1p3XRKkiVHBM9mzCdV3_P2DSp-xw9A@mail.gmail.com \
    --to=robh+dt@kernel.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=frowand.list@gmail.com \
    --cc=g.liakhovetski@gmx.de \
    --cc=grant.likely@linaro.org \
    --cc=horms@verge.net.au \
    --cc=kuninori.morimoto.gx@renesas.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).